aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-06-14 03:25:48 +0800
committerglewis <glewis@FreeBSD.org>2002-06-14 03:25:48 +0800
commit34fb094855572b1a522a7a7877cb457168ea59ff (patch)
tree03b13ce94f04f856f3d8309b6b4107600e5af6bd /java
parent04719aec803a7a8d3ddbd1063d70146ebdfac5b0 (diff)
downloadfreebsd-ports-gnome-34fb094855572b1a522a7a7877cb457168ea59ff.tar.gz
freebsd-ports-gnome-34fb094855572b1a522a7a7877cb457168ea59ff.tar.zst
freebsd-ports-gnome-34fb094855572b1a522a7a7877cb457168ea59ff.zip
Fix problems I created with the previous change:
. Add a post-patch target to clean up *.orig files (taken from the linux-sun-jdk13 port). . Fix the name of the installation location to be consistent with other JDK ports and to not move with, for example, PORTREVISION changes. Approved by: znerd (maintainer)
Diffstat (limited to 'java')
-rw-r--r--java/linux-sun-jdk12/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/java/linux-sun-jdk12/Makefile b/java/linux-sun-jdk12/Makefile
index 50824f06d350..710177128085 100644
--- a/java/linux-sun-jdk12/Makefile
+++ b/java/linux-sun-jdk12/Makefile
@@ -33,7 +33,7 @@ RESTRICTED= "Redistribution of repackaged binaries not permitted"
IGNORE= "You can not legally distribute binaries"
.endif
-APP_HOME= ${PREFIX}/${PKGNAME}
+APP_HOME= ${PREFIX}/${PKGNAMEPREFIX}jdk1.2.2
DOWNLOAD_URL= http://java.sun.com/Download5?config-file=${PORTNAME}-${JDK_VERSION:S/./_/g}.config&platform=linux-${ARCH}
.include <bsd.port.pre.mk>
@@ -42,6 +42,9 @@ DOWNLOAD_URL= http://java.sun.com/Download5?config-file=${PORTNAME}-${JDK_VERSIO
IGNORE=You must manually fetch the Sun Java 2 Standard Edition SDK ${JDK_VERSION} for Linux archive (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again.
.endif
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.orig' -print | xargs ${RM} -f
+
do-install:
@${ECHO} -n "Creating destination directory ${APP_HOME}..."
@${MKDIR} ${APP_HOME}