aboutsummaryrefslogtreecommitdiffstats
path: root/lang/itcl
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
committerasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
commitd21b71cc5a3e11bccc9aa5fe5763254cd565d9a5 (patch)
tree560e7eb8a07c987120c853aef90742f320b09b93 /lang/itcl
parent8d54bac5baa3871cb4702456e31c93aedc116bd5 (diff)
downloadfreebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.gz
freebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.zst
freebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.zip
Add
post-install: pkg_add -m ${PREFIX}/lib to Makefiles and @exec ldconfig -m %D to packing lists of ports that install shared libraries. This should get rid of a huge chunk of confusion for novice users! All hail Paul Kranenburg! :)
Diffstat (limited to 'lang/itcl')
-rw-r--r--lang/itcl/Makefile5
-rw-r--r--lang/itcl/pkg-plist1
2 files changed, 5 insertions, 1 deletions
diff --git a/lang/itcl/Makefile b/lang/itcl/Makefile
index 1c366d119667..f02527f176d3 100644
--- a/lang/itcl/Makefile
+++ b/lang/itcl/Makefile
@@ -3,7 +3,7 @@
# Date created: Mon Oct 3 22:06:21 EDT 1994
# Whom: rww
#
-# $Id: Makefile,v 1.5 1995/04/15 05:44:39 asami Exp $
+# $Id: Makefile,v 1.6 1995/05/13 07:53:08 asami Exp $
#
DISTNAME= itcl-1.5
@@ -16,4 +16,7 @@ LIB_DEPENDS= tk\\.3\\.:${PORTSDIR}/x11/tk
PATCH_STRIP= -p1
+post-install:
+ ldconfig -m ${PREFIX}/lib
+
.include <bsd.port.mk>
diff --git a/lang/itcl/pkg-plist b/lang/itcl/pkg-plist
index bbfcfe45f641..6cf25c3d1f6d 100644
--- a/lang/itcl/pkg-plist
+++ b/lang/itcl/pkg-plist
@@ -2,6 +2,7 @@
include/itcl.h
lib/libitcl.a
lib/libitcl.so.1.5
+@exec ldconfig -m %B
bin/itcl_wish
bin/itcl_sh
man/mann/incrTcl.n