aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-07-19 03:09:24 +0800
committerobrien <obrien@FreeBSD.org>1998-07-19 03:09:24 +0800
commit813991733fd326634c9e0b76851420b9d7caa5b1 (patch)
tree5f33d25c2e26828ff97a08b06cea5ffda2ba1b53 /mail
parent9e9f8e58374b2cbd462a2be6e8b4e9f43429853f (diff)
downloadfreebsd-ports-gnome-813991733fd326634c9e0b76851420b9d7caa5b1.tar.gz
freebsd-ports-gnome-813991733fd326634c9e0b76851420b9d7caa5b1.tar.zst
freebsd-ports-gnome-813991733fd326634c9e0b76851420b9d7caa5b1.zip
Revert to compiling agaist stock ncurses by default (requested by ache)
If "BATCH" is defined (ie. building packages for the CDROM, link agaist libslang. Also does the right thing if "USE_NCURSES_PORT" or "USE_SLANG" is defined. Note that resizing works better for me with Slang than with the ncurses 4.2 port. I'm using Slang over the ncurses port because the ncurses 4.2 port does NOT support the "xterm-color" terminal type. (and a big reason for linking with ncurses is for color support)
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile17
-rw-r--r--mail/mutt/Makefile17
-rw-r--r--mail/mutt14/Makefile17
3 files changed, 39 insertions, 12 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 8915456342cf..08480bf54476 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -4,7 +4,7 @@
# Date created: Thur July 25, 1996
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.44 1998/07/16 05:57:09 obrien Exp $
+# $Id: Makefile,v 1.45 1998/07/17 18:52:17 obrien Exp $
DISTNAME= mutt-0.93.1i
PKGNAME= mutt-0.93.1
@@ -25,9 +25,14 @@ PATCHFILES=
MAINTAINER= obrien@FreeBSD.org
-LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
.if defined(BATCH)
+LIB_DEPENDS= slang\\.1\\.:${PORTSDIR}/devel/libslang
+BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
+.elif defined(USE_NCURSES_PORT)
+LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
+.elif defined(USE_SLANG)
+LIB_DEPENDS= slang\\.1\\.:${PORTSDIR}/devel/libslang
.endif
DIST_SUBDIR= mutt
@@ -36,8 +41,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dsn --enable-pop --enable-imap --enable-flock \
--disable-fcntl --enable-hidden-host \
--with-sharedir=${PREFIX}/share/misc \
- --with-docdir=${PREFIX}/share/doc/mutt \
- --with-curses=${PREFIX}
+ --with-docdir=${PREFIX}/share/doc/mutt
+.if defined(BATCH) || defined(USE_SLANG)
+CONFIGURE_ARGS+= --with-slang=${PREFIX}
+.elif defined(USE_NCURSES_PORT)
+CONFIGURE_ARGS+= --with-curses=${PREFIX}
+.endif
MAN1= mutt.1
post-patch:
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 8915456342cf..08480bf54476 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -4,7 +4,7 @@
# Date created: Thur July 25, 1996
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.44 1998/07/16 05:57:09 obrien Exp $
+# $Id: Makefile,v 1.45 1998/07/17 18:52:17 obrien Exp $
DISTNAME= mutt-0.93.1i
PKGNAME= mutt-0.93.1
@@ -25,9 +25,14 @@ PATCHFILES=
MAINTAINER= obrien@FreeBSD.org
-LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
.if defined(BATCH)
+LIB_DEPENDS= slang\\.1\\.:${PORTSDIR}/devel/libslang
+BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
+.elif defined(USE_NCURSES_PORT)
+LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
+.elif defined(USE_SLANG)
+LIB_DEPENDS= slang\\.1\\.:${PORTSDIR}/devel/libslang
.endif
DIST_SUBDIR= mutt
@@ -36,8 +41,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dsn --enable-pop --enable-imap --enable-flock \
--disable-fcntl --enable-hidden-host \
--with-sharedir=${PREFIX}/share/misc \
- --with-docdir=${PREFIX}/share/doc/mutt \
- --with-curses=${PREFIX}
+ --with-docdir=${PREFIX}/share/doc/mutt
+.if defined(BATCH) || defined(USE_SLANG)
+CONFIGURE_ARGS+= --with-slang=${PREFIX}
+.elif defined(USE_NCURSES_PORT)
+CONFIGURE_ARGS+= --with-curses=${PREFIX}
+.endif
MAN1= mutt.1
post-patch:
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 8915456342cf..08480bf54476 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -4,7 +4,7 @@
# Date created: Thur July 25, 1996
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.44 1998/07/16 05:57:09 obrien Exp $
+# $Id: Makefile,v 1.45 1998/07/17 18:52:17 obrien Exp $
DISTNAME= mutt-0.93.1i
PKGNAME= mutt-0.93.1
@@ -25,9 +25,14 @@ PATCHFILES=
MAINTAINER= obrien@FreeBSD.org
-LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
.if defined(BATCH)
+LIB_DEPENDS= slang\\.1\\.:${PORTSDIR}/devel/libslang
+BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
+.elif defined(USE_NCURSES_PORT)
+LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
+.elif defined(USE_SLANG)
+LIB_DEPENDS= slang\\.1\\.:${PORTSDIR}/devel/libslang
.endif
DIST_SUBDIR= mutt
@@ -36,8 +41,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dsn --enable-pop --enable-imap --enable-flock \
--disable-fcntl --enable-hidden-host \
--with-sharedir=${PREFIX}/share/misc \
- --with-docdir=${PREFIX}/share/doc/mutt \
- --with-curses=${PREFIX}
+ --with-docdir=${PREFIX}/share/doc/mutt
+.if defined(BATCH) || defined(USE_SLANG)
+CONFIGURE_ARGS+= --with-slang=${PREFIX}
+.elif defined(USE_NCURSES_PORT)
+CONFIGURE_ARGS+= --with-curses=${PREFIX}
+.endif
MAN1= mutt.1
post-patch: