aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-04-28 01:49:56 +0800
committeryuri <yuri@FreeBSD.org>2019-04-28 01:49:56 +0800
commitd43bee36d0a7a1bd1c2c54bb469f59c16e8e9eef (patch)
tree0cef4f6e0910aedba99e0a9750f4605b7d1f8e4f /math
parent6c67e17b0f0a62e3c726e1f40fd680f6eefb34a6 (diff)
downloadfreebsd-ports-gnome-d43bee36d0a7a1bd1c2c54bb469f59c16e8e9eef.tar.gz
freebsd-ports-gnome-d43bee36d0a7a1bd1c2c54bb469f59c16e8e9eef.tar.zst
freebsd-ports-gnome-d43bee36d0a7a1bd1c2c54bb469f59c16e8e9eef.zip
math/mppp: fix build with GCC-based architectures, enable -DMPPP_WITH_QUADMATH=ON
Add USES=compiler:c++14-lang everywhere, not just for tests, because this library has recently become non-NOARCH. PR: 237608 Submitted by: pkubaj
Diffstat (limited to 'math')
-rw-r--r--math/mppp/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/mppp/Makefile b/math/mppp/Makefile
index 3df67b4b1266..102d4866f4ac 100644
--- a/math/mppp/Makefile
+++ b/math/mppp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mppp
DISTVERSIONPREFIX= v
DISTVERSION= 0.14
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -17,12 +18,11 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gmp.h:math/gmp \
RUN_DEPENDS= ${LOCALBASE}/include/gmp.h:math/gmp \
${LOCALBASE}/include/mpfr.h:math/mpfr
-USES= cmake
+USES= cmake compiler:c++14-lang
USE_GITHUB= yes
GH_ACCOUNT= bluescarni
-TEST_USES= compiler:c++14-lang
-TEST_ARGS= -DMPPP_BUILD_TESTS=ON -DMPPP_WITH_MPFR=ON #-DMPPP_WITH_QUADMATH=ON (quadmath requires __float128, only available in clang6)
+TEST_ARGS= -DMPPP_BUILD_TESTS=ON -DMPPP_WITH_MPFR=ON -DMPPP_WITH_QUADMATH=ON
BENCHMARK_ARGS= -DMPPP_BUILD_BENCHMARKS=ON -DMPPP_BENCHMARK_BOOST=ON
do-test: