aboutsummaryrefslogtreecommitdiffstats
path: root/misc/tkcron
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2012-04-08 00:33:05 +0800
committercy <cy@FreeBSD.org>2012-04-08 00:33:05 +0800
commit5f9f00373cd4fd304ba7adb82139e6d2473e34ae (patch)
tree78ac315055cfbdc42178a7b176654730b1225fe8 /misc/tkcron
parent542a37f5698c93a8aeb1b3b466f0d5ddfbd7617d (diff)
downloadfreebsd-ports-gnome-5f9f00373cd4fd304ba7adb82139e6d2473e34ae.tar.gz
freebsd-ports-gnome-5f9f00373cd4fd304ba7adb82139e6d2473e34ae.tar.zst
freebsd-ports-gnome-5f9f00373cd4fd304ba7adb82139e6d2473e34ae.zip
Re-import tkcron, a tk frontend to cron.
Feature safe: yes
Diffstat (limited to 'misc/tkcron')
-rw-r--r--misc/tkcron/Makefile32
-rw-r--r--misc/tkcron/distinfo2
-rw-r--r--misc/tkcron/files/Makefile16
-rw-r--r--misc/tkcron/files/patch-aa11
-rw-r--r--misc/tkcron/pkg-descr6
5 files changed, 67 insertions, 0 deletions
diff --git a/misc/tkcron/Makefile b/misc/tkcron/Makefile
new file mode 100644
index 000000000000..85e209ccb8f5
--- /dev/null
+++ b/misc/tkcron/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tkcron-2.12
+# Date created: 30 July 1996
+# Whom: Sander Vesik <sander@haldjas.folklore.ee>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkcron
+PORTVERSION= 2.12
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.tcl.tk/pub/tcl/mirror/ftp.procplace.com/sorted/packages-7.6/misc/tkcron-2.12/ \
+ http://ftp.sunet.se/pub/lang/tcl/sorted/packages-7.6/misc/tkcron-2.12/ \
+ http://ftp4.de.freesbie.org/pub/misc/x11/tcl/ftp.gmd.de/contrib/sorted/misc/tkcron-2.12/ \
+ http://komquats.com/distfiles/ \
+ http://people.freebsd.org/~cy/distfiles/
+EXTRACT_SUFX= .tcl.gz
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= A frontend to crontab
+
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+
+EXTRACT_CMD= ${GZIP_CMD}
+EXTRACT_BEFORE_ARGS= -cd
+EXTRACT_AFTER_ARGS= > tkcron.tcl
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/tkcron
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/misc/tkcron/distinfo b/misc/tkcron/distinfo
new file mode 100644
index 000000000000..254add8b719b
--- /dev/null
+++ b/misc/tkcron/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tkcron-2.12.tcl.gz) = 1436e2206bd8b347dfa8e65265cfdae3a8f14f78d5ba58426beb2b1c5daeb6dd
+SIZE (tkcron-2.12.tcl.gz) = 4545
diff --git a/misc/tkcron/files/Makefile b/misc/tkcron/files/Makefile
new file mode 100644
index 000000000000..b18a1dee335f
--- /dev/null
+++ b/misc/tkcron/files/Makefile
@@ -0,0 +1,16 @@
+#
+# $FreeBSD$
+#
+
+BINDIR= ${PREFIX}/bin
+WISHDIR?= ${BINDIR}
+
+all: tkcron
+
+tkcron:
+ sed -e "\:/usr/local/bin/wish: s;;${BINDIR}/wish8.2;g" tkcron.tcl > tkcron
+
+install: all
+ install ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} tkcron ${BINDIR}
+
+.include <bsd.own.mk>
diff --git a/misc/tkcron/files/patch-aa b/misc/tkcron/files/patch-aa
new file mode 100644
index 000000000000..b6c4026ef5ad
--- /dev/null
+++ b/misc/tkcron/files/patch-aa
@@ -0,0 +1,11 @@
+--- tkcron.tcl Sat Aug 3 17:53:42 1996
++++ tkcron.tcl Sat Aug 3 17:52:03 1996
+@@ -281,6 +281,7 @@
+
+ # Return the crontab string as a list
+ proc parseCrontabFile {str} {
++ set result ""
+ set crontablist [split $str \n]
+ set listlength [llength $crontablist]
+ for {set i 0} {$i < $listlength} {incr i 1} {
+
diff --git a/misc/tkcron/pkg-descr b/misc/tkcron/pkg-descr
new file mode 100644
index 000000000000..757ac1e020b9
--- /dev/null
+++ b/misc/tkcron/pkg-descr
@@ -0,0 +1,6 @@
+Tkcron is a frontend to crontab which allows the user to conviniently
+add/modify/install/remove cron jobs.
+
+This is crontab version 2.12
+
+ Sander