aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-01-24 15:50:08 +0800
committertg <tg@FreeBSD.org>1997-01-24 15:50:08 +0800
commitf48c6813004223a2d37e5745288014bee734ff1c (patch)
tree37a76b92f37b9926139358e950d03037be040d35 /misc
parentb7da994127c024a5643e036f9f845d7e9e6c5e8f (diff)
downloadfreebsd-ports-gnome-f48c6813004223a2d37e5745288014bee734ff1c.tar.gz
freebsd-ports-gnome-f48c6813004223a2d37e5745288014bee734ff1c.tar.zst
freebsd-ports-gnome-f48c6813004223a2d37e5745288014bee734ff1c.zip
Import of the Red Hat package manager.
Diffstat (limited to 'misc')
-rw-r--r--misc/rpm/Makefile21
-rw-r--r--misc/rpm/distinfo1
-rw-r--r--misc/rpm/pkg-comment1
-rw-r--r--misc/rpm/pkg-descr1
-rw-r--r--misc/rpm/pkg-plist12
5 files changed, 36 insertions, 0 deletions
diff --git a/misc/rpm/Makefile b/misc/rpm/Makefile
new file mode 100644
index 000000000000..712f3e9f8936
--- /dev/null
+++ b/misc/rpm/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: rpm
+# Version required: 2.3.2
+# Date created: 23 January 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= rpm-2.3.2
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.redhat.com/pub/redhat/code/rpm/
+
+MAINTAINER= tg@FreeBSD.ORG
+
+BUILD_DEPENDS= ${PREFIX}/lib/libgdbm.a:${PORTSDIR}/databases/gdbm
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAN8= rpm.8 rpm2cpio.8
+
+.include <bsd.port.mk>
diff --git a/misc/rpm/distinfo b/misc/rpm/distinfo
new file mode 100644
index 000000000000..e98e29fcbc72
--- /dev/null
+++ b/misc/rpm/distinfo
@@ -0,0 +1 @@
+MD5 (rpm-2.3.2.tar.gz) = 0ba665a9ec9cb7cdb2601e8d0aaeef99
diff --git a/misc/rpm/pkg-comment b/misc/rpm/pkg-comment
new file mode 100644
index 000000000000..b312119efb71
--- /dev/null
+++ b/misc/rpm/pkg-comment
@@ -0,0 +1 @@
+The Red Hat Package Manager
diff --git a/misc/rpm/pkg-descr b/misc/rpm/pkg-descr
new file mode 100644
index 000000000000..37e6dfd8bce2
--- /dev/null
+++ b/misc/rpm/pkg-descr
@@ -0,0 +1 @@
+This is the Red Hat Package Manager.
diff --git a/misc/rpm/pkg-plist b/misc/rpm/pkg-plist
new file mode 100644
index 000000000000..fab1fd94157e
--- /dev/null
+++ b/misc/rpm/pkg-plist
@@ -0,0 +1,12 @@
+bin/gendiff
+bin/rpm
+bin/find-requires
+bin/find-provides
+bin/rpm2cpio
+include/rpm/rpmlib.h
+include/rpm/dbindex.h
+include/rpm/header.h
+lib/librpm.a
+man/man8/rpm.8.gz
+man/man8/rpm2cpio.8.gz
+share/misc/rpmrc