aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-27 16:30:20 +0800
committerbapt <bapt@FreeBSD.org>2014-05-27 16:30:20 +0800
commit36a9b0572e0578986bb179621a5790615934e973 (patch)
tree47503cc4070043f8597ae2998d67180a99cb4151 /net-p2p
parent0ed0f1f0ab27a877b4f25a0db3f67d7f76f4725b (diff)
downloadfreebsd-ports-gnome-36a9b0572e0578986bb179621a5790615934e973.tar.gz
freebsd-ports-gnome-36a9b0572e0578986bb179621a5790615934e973.tar.zst
freebsd-ports-gnome-36a9b0572e0578986bb179621a5790615934e973.zip
Fix detection of lua
Reported by: antoine With hat: portmgr
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/verlihub-plugins-luascript/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-p2p/verlihub-plugins-luascript/Makefile b/net-p2p/verlihub-plugins-luascript/Makefile
index 3bdca4ae2877..4a91d5d6a927 100644
--- a/net-p2p/verlihub-plugins-luascript/Makefile
+++ b/net-p2p/verlihub-plugins-luascript/Makefile
@@ -34,11 +34,16 @@ NO_STAGE= yes
BUILD_DEPENDS+= ${LUA_MODLIBDIR}/socket/core.so:${PORTSDIR}/net/luasocket
RUN_DEPENDS+= ${LUA_MODLIBDIR}/socket/core.so:${PORTSDIR}/net/luasocket
CONFIGURE_ARGS+= --with-luasocket
+.endif
post-patch::
- @${REINPLACE_CMD} -e 's|-lluasocket|${LUA_MODLIBDIR}/socket/core.so|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lluamime|${LUA_MODLIBDIR}/mime/core.so|g' ${WRKSRC}/configure
+.if ${PORT_OPTIONS:MSOCKET}
+ @${REINPLACE_CMD} -e 's|-lluasocket|${LUA_MODLIBDIR}/socket/core.so|g' \
+ -e 's|-lluamime|${LUA_MODLIBDIR}/mime/core.so|g' \
+ ${WRKSRC}/configure
.endif
+ @${REINPLACE_CMD} -e 's|llua50|llua-${LUA_VER}|g' \
+ ${WRKSRC}/configure
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"