aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Riak/Makefile
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:19:50 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:19:50 +0800
commitbdb19278dac576ddb2e93d35392167b5938284fe (patch)
treedd6466a83f5282d1da9c115f9793356feb4a496c /net/p5-Net-Riak/Makefile
parent198344c8d0fa41c4393546a76cffab4fa3288dba (diff)
downloadfreebsd-ports-gnome-bdb19278dac576ddb2e93d35392167b5938284fe.tar.gz
freebsd-ports-gnome-bdb19278dac576ddb2e93d35392167b5938284fe.tar.zst
freebsd-ports-gnome-bdb19278dac576ddb2e93d35392167b5938284fe.zip
Interface to Riak.
WWW: http://search.cpan.org/dist/Net-Riak/ PR: ports/152277 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net/p5-Net-Riak/Makefile')
-rw-r--r--net/p5-Net-Riak/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net/p5-Net-Riak/Makefile b/net/p5-Net-Riak/Makefile
new file mode 100644
index 000000000000..0e39711f59a9
--- /dev/null
+++ b/net/p5-Net-Riak/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Net-Riak
+# Date created: 2010-11-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Riak
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Interface to Riak
+
+RUN_DEPENDS= p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Riak.3 \
+ Net::Riak::Bucket.3 \
+ Net::Riak::Client.3 \
+ Net::Riak::Link.3 \
+ Net::Riak::LinkPhase.3 \
+ Net::Riak::MapReduce.3 \
+ Net::Riak::MapReducePhase.3 \
+ Net::Riak::Object.3 \
+ Net::Riak::Role::Base.3 \
+ Net::Riak::Role::Hosts.3 \
+ Net::Riak::Role::MapReduce.3 \
+ Net::Riak::Role::REST.3 \
+ Net::Riak::Role::Replica.3 \
+ Net::Riak::Role::UserAgent.3
+
+.include <bsd.port.mk>