aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2002-06-23 05:45:27 +0800
committerdougb <dougb@FreeBSD.org>2002-06-23 05:45:27 +0800
commitbf7c375c57834dc66782f14ccd2642cf85d573b0 (patch)
treec15e3a48fab304236f4e67dc76e17a85a34acb65 /net
parent512215f4a728f262f1c985f586ce6100c3a23615 (diff)
downloadfreebsd-ports-gnome-bf7c375c57834dc66782f14ccd2642cf85d573b0.tar.gz
freebsd-ports-gnome-bf7c375c57834dc66782f14ccd2642cf85d573b0.tar.zst
freebsd-ports-gnome-bf7c375c57834dc66782f14ccd2642cf85d573b0.zip
Upgrade to 8.3.2, the lastest release from ISC. Numerous bug fixes
include better EDNS support, the ability to turn EDNS probing off on a per-server basis, better TSIG support, better handling of IPv6, and various improvements to the CLI utilities like dig, host, etc. For other improvements see the CHANGES file. All users of BIND 8 are heavily encouraged to upgrade. Changes to the port: 1. My patch for gid_t handling in 5.x was included in the base. 2. Make use of the new and improved MANPREFIX handling in bsd.port.mk. 3. If the user defines REPLACE_SYSTEM_BIND, we do just that.
Diffstat (limited to 'net')
-rw-r--r--net/bind8/Makefile16
-rw-r--r--net/bind8/distinfo4
-rw-r--r--net/bind8/files/patch-aa8
-rw-r--r--net/bind8/files/patch-ab2
-rw-r--r--net/bind8/files/patch-port_freebsd_include_port_before.h25
5 files changed, 22 insertions, 33 deletions
diff --git a/net/bind8/Makefile b/net/bind8/Makefile
index 6ab10759a6f6..9d0ecb193109 100644
--- a/net/bind8/Makefile
+++ b/net/bind8/Makefile
@@ -11,7 +11,7 @@
# you can generally build it cleanly from the source. - Doug
PORTNAME= bind
-PORTVERSION= 8.3.1
+PORTVERSION= 8.3.2
CATEGORIES?= net
MASTER_SITES= ftp://ftp.isc.org/isc/bind/src/${PORTVERSION}/ \
ftp://ftp.epix.net/pub/isc/bind/src/${PORTVERSION}/ \
@@ -23,7 +23,12 @@ DIST_SUBDIR= bind-${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
+.if defined(REPLACE_SYSTEM_BIND)
+PREFIX= /usr
+.endif
+
WRKSRC= ${WRKDIR}/src
+MAKE_ENV+= MANPREFIX=${MANPREFIX}
MAN1= dig.1 dnskeygen.1 dnsquery.1 host.1
MAN3= getaddrinfo.3 gethostbyname.3 getipnodebyname.3 getnetent.3 \
@@ -36,6 +41,15 @@ MAN8= named-bootconf.8 named-xfer.8 named.8 ndc.8 nslookup.8 \
PATCH_ARGS= -s -d ${WRKDIR}
PATCH_DIST_ARGS= -s -d ${WRKDIR}
+post-patch:
+.if defined(REPLACE_SYSTEM_BIND)
+ @${SED} -e "s#\'DESTETC=.*#'DESTETC=/etc/namedb'#" \
+ ${WRKSRC}/port/freebsd/Makefile.set > \
+ ${WRKSRC}/port/freebsd/Makefile.set.sed
+ @${MV} ${WRKSRC}/port/freebsd/Makefile.set.sed \
+ ${WRKSRC}/port/freebsd/Makefile.set
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@(cd ${WRKDIR}/doc/man && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
diff --git a/net/bind8/distinfo b/net/bind8/distinfo
index f7bf0f579f90..94983afc328b 100644
--- a/net/bind8/distinfo
+++ b/net/bind8/distinfo
@@ -1,2 +1,2 @@
-MD5 (bind-8.3.1/bind-src.tar.gz) = ee0535239e3b254e98d7efe53f4d0fe7
-MD5 (bind-8.3.1/bind-doc.tar.gz) = 54c63ec52daf69d52668299ada2dac68
+MD5 (bind-8.3.2/bind-src.tar.gz) = 054ae0236322f1783d80350e7e63a4e8
+MD5 (bind-8.3.2/bind-doc.tar.gz) = eee00785019f507b5d15a3a4287ef53b
diff --git a/net/bind8/files/patch-aa b/net/bind8/files/patch-aa
index 7ed25b139ea2..431a7b682a27 100644
--- a/net/bind8/files/patch-aa
+++ b/net/bind8/files/patch-aa
@@ -1,15 +1,15 @@
---- src/port/freebsd/Makefile.set.orig Thu Aug 9 19:41:08 2001
-+++ src/port/freebsd/Makefile.set Mon Jan 21 01:24:25 2002
+--- src/port/freebsd/Makefile.set.orig Mon Feb 25 18:56:32 2002
++++ src/port/freebsd/Makefile.set Sat Jun 22 13:29:41 2002
@@ -1,12 +1,14 @@
'CC=cc'
--'CDEBUG=-O2 -g -W -Wall -Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat'
+-'CDEBUG=-O2 -g -W -Wall -Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat -DMEMCLUSTER_RECORD=1'
-'DESTBIN=/usr/bin'
-'DESTSBIN=/usr/sbin'
-'DESTEXEC=/usr/libexec'
-'DESTMAN=/usr/share/man'
-'DESTHELP=/usr/share/misc'
-'DESTETC=/etc'
-+'CDEBUG=${CFLAGS} -W -Wall -Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat'
++'CDEBUG=${CFLAGS} -W -Wall -Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat -DMEMCLUSTER_RECORD=1'
+'DESTBIN=${PREFIX}/bin'
+'DESTSBIN=${PREFIX}/sbin'
+'DESTEXEC=${PREFIX}/libexec'
diff --git a/net/bind8/files/patch-ab b/net/bind8/files/patch-ab
index 2666baa8847c..5a7d1aba50c2 100644
--- a/net/bind8/files/patch-ab
+++ b/net/bind8/files/patch-ab
@@ -5,7 +5,7 @@
# specify the path of an NFS-mounted directory for common files.
#
-DESTDIR=
-+DESTDIR= ${PREFIX}
++DESTDIR= ${MANPREFIX}
#
# Default location for manual section directories.
diff --git a/net/bind8/files/patch-port_freebsd_include_port_before.h b/net/bind8/files/patch-port_freebsd_include_port_before.h
deleted file mode 100644
index 59b9eac2a0bc..000000000000
--- a/net/bind8/files/patch-port_freebsd_include_port_before.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/port/freebsd/include/port_before.h.orig Wed Oct 31 23:29:21 2001
-+++ src/port/freebsd/include/port_before.h Tue Feb 26 21:50:52 2002
-@@ -15,6 +15,7 @@
- #define SETPWENT_VOID
- #endif
-
-+#include <sys/param.h>
- #include <sys/types.h>
-
- #define GROUP_R_RETURN struct group *
-@@ -26,8 +27,14 @@
- #define GROUP_R_ENT_ARGS void
- #define GROUP_R_OK gptr
- #define GROUP_R_BAD NULL
-+
-+#if defined(__FreeBSD_version) && __FreeBSD_version >= 500030
-+#define GETGROUPLIST_ARGS const char *name, gid_t basegid, gid_t *groups, \
-+ int *ngroups
-+#else
- #define GETGROUPLIST_ARGS const char *name, int basegid, int *groups, \
- int *ngroups
-+#endif
-
- #define HOST_R_RETURN struct hostent *
- #define HOST_R_SET_RETURN void