aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2002-09-11 06:18:46 +0800
committerobraun <obraun@FreeBSD.org>2002-09-11 06:18:46 +0800
commitbbf17f050388f812d3372c5da599de8736717cad (patch)
tree65bd77dae83493f48c2077fdd9d039becf7126de /shells
parent7d36ee569f37a98227c14242374029bae59c93d4 (diff)
downloadfreebsd-ports-gnome-bbf17f050388f812d3372c5da599de8736717cad.tar.gz
freebsd-ports-gnome-bbf17f050388f812d3372c5da599de8736717cad.tar.zst
freebsd-ports-gnome-bbf17f050388f812d3372c5da599de8736717cad.zip
Add scponly 2.4, a tiny shell which only permits scp and sftp.
PR: ports/40935 Submitted by: Ken McGlothlen <mcglk@artlogix.com>
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/scponly/Makefile21
-rw-r--r--shells/scponly/distinfo1
-rw-r--r--shells/scponly/pkg-comment1
-rw-r--r--shells/scponly/pkg-descr14
-rw-r--r--shells/scponly/pkg-plist1
6 files changed, 39 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 794e47deeb1a..3844de3432ce 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -17,6 +17,7 @@
SUBDIR += perlsh
SUBDIR += rc
SUBDIR += sash
+ SUBDIR += scponly
SUBDIR += tcsh
SUBDIR += vshnu
SUBDIR += wapsh
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
new file mode 100644
index 000000000000..abcc288d36ae
--- /dev/null
+++ b/shells/scponly/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: scponly
+# Date created: 2002/07/23
+# Whom: mcglk@artlogix.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= scponly
+PORTVERSION= 2.4
+CATEGORIES= shells
+MASTER_SITES= http://www.sublimation.org/scponly/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mcglk@artlogix.com
+
+MAN8= scponly.8
+
+post-install:
+ strip ${PREFIX}/sbin/scponly
+
+.include <bsd.port.mk>
diff --git a/shells/scponly/distinfo b/shells/scponly/distinfo
new file mode 100644
index 000000000000..2bb45c9de4b7
--- /dev/null
+++ b/shells/scponly/distinfo
@@ -0,0 +1 @@
+MD5 (scponly-2.4.tgz) = efd077b651d2186be5184ff94f33a9d9
diff --git a/shells/scponly/pkg-comment b/shells/scponly/pkg-comment
new file mode 100644
index 000000000000..7d4651a5cc3e
--- /dev/null
+++ b/shells/scponly/pkg-comment
@@ -0,0 +1 @@
+A tiny shell which only permits scp and sftp
diff --git a/shells/scponly/pkg-descr b/shells/scponly/pkg-descr
new file mode 100644
index 000000000000..7eee800677b0
--- /dev/null
+++ b/shells/scponly/pkg-descr
@@ -0,0 +1,14 @@
+[From the README:] "scponly" is an alternative 'shell' (of sorts) for system
+administrators who would like to provide access to remote users to both read
+and write local files without providing any remote execution priviledges.
+Functionally, it is best described as a wrapper to the "tried and true" ssh
+suite of applications.
+
+scponly validates remote requests by examining the third argument passed to the
+shell upon login. (The first argument is the shell itself, and the second is
+-c.) The only commands allowed are "scp" (for ssh1), "sftp-server" (for ssh2")
+and "ls". Arguments to these commands are passed along unmolested.
+
+WWW: http://www.sublimation.org/scponly/
+
+---Ken McGlothlen (mcglk@artlogix.com)
diff --git a/shells/scponly/pkg-plist b/shells/scponly/pkg-plist
new file mode 100644
index 000000000000..06ee17eaa8ce
--- /dev/null
+++ b/shells/scponly/pkg-plist
@@ -0,0 +1 @@
+sbin/scponly