aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cog/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-05-26 11:35:49 +0800
committermezz <mezz@FreeBSD.org>2004-05-26 11:35:49 +0800
commit513efe733ced21507e3aee7eb110c5e7e61028f2 (patch)
treef9b71f8dbf32147be3dc190069c851011fcb9713 /sysutils/cog/Makefile
parent287e2cf165366eb5659686ab05a1c52c808df4f0 (diff)
downloadfreebsd-ports-gnome-513efe733ced21507e3aee7eb110c5e7e61028f2.tar.gz
freebsd-ports-gnome-513efe733ced21507e3aee7eb110c5e7e61028f2.tar.zst
freebsd-ports-gnome-513efe733ced21507e3aee7eb110c5e7e61028f2.zip
Add icon image in the GNOME menu.
PR: ports/66674 Submitted by: ports@c0decafe.net <ports@c0decafe.net> Approved by: adamw (mentor)
Diffstat (limited to 'sysutils/cog/Makefile')
-rw-r--r--sysutils/cog/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysutils/cog/Makefile b/sysutils/cog/Makefile
index e210d2da9322..eb469aa9aef3 100644
--- a/sysutils/cog/Makefile
+++ b/sysutils/cog/Makefile
@@ -15,9 +15,18 @@ COMMENT= A program for editing advanced GNOME settings in an easy way
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|Icon=|Icon=cog-icon-2-48x48.png|g' \
+ ${WRKSRC}/cog.desktop
+
+post-install:
+ @${LN} -sf ${PREFIX}/share/gnome/cog/pixmaps/cog-icon-2-48x48.png \
+ ${PREFIX}/share/gnome/pixmaps/cog-icon-2-48x48.png
+
.include <bsd.port.mk>