aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-07-29 04:38:37 +0800
committermarcus <marcus@FreeBSD.org>2002-07-29 04:38:37 +0800
commit5be9714450f8d6d24537f8d4082b7039b2317431 (patch)
tree2670296bed8719a538c85f645ec09d88bb445f53 /x11-fm
parentf2a383307e02280a0d0cfda6db678de0fda227b0 (diff)
downloadfreebsd-ports-gnome-5be9714450f8d6d24537f8d4082b7039b2317431.tar.gz
freebsd-ports-gnome-5be9714450f8d6d24537f8d4082b7039b2317431.tar.zst
freebsd-ports-gnome-5be9714450f8d6d24537f8d4082b7039b2317431.zip
Use USE_GNOMENG.
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/gnome-commander/Makefile12
-rw-r--r--x11-fm/gnome-commander2/Makefile12
2 files changed, 8 insertions, 16 deletions
diff --git a/x11-fm/gnome-commander/Makefile b/x11-fm/gnome-commander/Makefile
index 7f97df8774d9..1f4ed2d2c2a3 100644
--- a/x11-fm/gnome-commander/Makefile
+++ b/x11-fm/gnome-commander/Makefile
@@ -21,22 +21,18 @@ BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomevfs gnomelibs
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
-pre-patch:
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
+post-patch:
.for AM in config.sub config.guess install-sh missing mkinstalldirs
${LN} -fs ${LOCALBASE}/share/automake14/automake/${AM} ${WRKSRC}/${AM}
.endfor
-
-post-patch:
- @${REINPLACE_CMD} -e 's|[%][%]X11BASE[%][%]|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/gnome-cmd-data.c
.include <bsd.port.mk>
diff --git a/x11-fm/gnome-commander2/Makefile b/x11-fm/gnome-commander2/Makefile
index 7f97df8774d9..1f4ed2d2c2a3 100644
--- a/x11-fm/gnome-commander2/Makefile
+++ b/x11-fm/gnome-commander2/Makefile
@@ -21,22 +21,18 @@ BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomevfs gnomelibs
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
-pre-patch:
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
+post-patch:
.for AM in config.sub config.guess install-sh missing mkinstalldirs
${LN} -fs ${LOCALBASE}/share/automake14/automake/${AM} ${WRKSRC}/${AM}
.endfor
-
-post-patch:
- @${REINPLACE_CMD} -e 's|[%][%]X11BASE[%][%]|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/gnome-cmd-data.c
.include <bsd.port.mk>