aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-25 04:04:28 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-25 04:04:28 +0800
commit7ca1cff514df56155c61e569c1f16c54f55083b5 (patch)
tree3a3685d8f01a31374a1cd6cea4fc0b19a2df3e1c /x11-fm
parentee9f366c070d8f6fff6232c8cff88c3f045f4214 (diff)
downloadfreebsd-ports-gnome-7ca1cff514df56155c61e569c1f16c54f55083b5.tar.gz
freebsd-ports-gnome-7ca1cff514df56155c61e569c1f16c54f55083b5.tar.zst
freebsd-ports-gnome-7ca1cff514df56155c61e569c1f16c54f55083b5.zip
Fix the problem with Nautilus not sensing available desktop area properly
and therefore allowing to place icons under the panel. This will go away when gnomepanel is teached to set _NET_WORKAREA properly (it doesn't do it yet). More details are on the very top of the patch. Bump PORTREVISION.
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/nautilus2/Makefile1
-rw-r--r--x11-fm/nautilus2/files/patch-temp121
2 files changed, 122 insertions, 0 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index 766316dbe736..aabdc80b2d30 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nautilus2
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= 2.0.0/sources/${PORTNAME:S/2$//}
diff --git a/x11-fm/nautilus2/files/patch-temp b/x11-fm/nautilus2/files/patch-temp
new file mode 100644
index 000000000000..35155bcfd86b
--- /dev/null
+++ b/x11-fm/nautilus2/files/patch-temp
@@ -0,0 +1,121 @@
+
+Fixes problem with Nautilus not sensing available desktop space and therefore
+placing icons under the panel. Reverses rev.179-1.180 of
+src/file-manager/fm-desktop-icon-view.c. Will go away when gnomepanel is
+teached to set _NET_WORKAREA properly.
+
+--- src/file-manager/fm-desktop-icon-view.c.orig Mon Jul 22 21:03:46 2002
++++ src/file-manager/fm-desktop-icon-view.c Wed Jul 24 22:47:32 2002
+@@ -148,39 +148,9 @@
+ }
+
+ static void
+-icon_container_set_workarea (NautilusIconContainer *icon_container,
+- long *workareas,
+- int n_items)
+-{
+- int left, right, top, bottom;
+- int screen_width, screen_height;
+- int i;
+-
+- left = right = top = bottom = 0;
+-
+- screen_width = gdk_screen_width ();
+- screen_height = gdk_screen_height ();
+-
+- for (i = 0; i < n_items; i += 4) {
+- int x = workareas [i];
+- int y = workareas [i + 1];
+- int width = workareas [i + 2];
+- int height = workareas [i + 3];
+-
+- left = MAX (left, x);
+- right = MAX (right, screen_width - width - x);
+- top = MAX (top, y);
+- bottom = MAX (bottom, screen_height - height - y);
+- }
+-
+- nautilus_icon_container_set_margins (icon_container,
+- left, right, top, bottom);
+-}
+-
+-static void
+ net_workarea_changed (FMDesktopIconView *icon_view)
+ {
+- long *workareas = NULL;
++ long *borders = NULL;
+ Atom type_returned;
+ int format_returned;
+ unsigned long items_returned;
+@@ -194,33 +164,38 @@
+ gdk_error_trap_push ();
+ if (XGetWindowProperty (GDK_DISPLAY (),
+ GDK_ROOT_WINDOW (),
+- gdk_x11_get_xatom_by_name ("_NET_WORKAREA"),
+- 0, G_MAXLONG, False,
++ gdk_x11_get_xatom_by_name ("GNOME_PANEL_DESKTOP_AREA"),
++ 0 /* long_offset */,
++ 4 /* long_length */,
++ False /* delete */,
+ XA_CARDINAL,
+ &type_returned,
+ &format_returned,
+ &items_returned,
+ &bytes_after_return,
+- (unsigned char **)&workareas) != Success) {
+- if (workareas != NULL)
+- XFree (workareas);
+- workareas = NULL;
++ (unsigned char **)&borders) != Success) {
++ if (borders != NULL)
++ XFree (borders);
++ borders = NULL;
+ }
+
+ if (gdk_error_trap_pop ()
+- || workareas == NULL
++ || borders == NULL
+ || type_returned != XA_CARDINAL
+- || (items_returned % 4) != 0
++ || items_returned != 4
+ || format_returned != 32) {
+ nautilus_icon_container_set_margins (icon_container,
+ 0, 0, 0, 0);
+ } else {
+- icon_container_set_workarea (
+- icon_container, workareas, items_returned);
++ nautilus_icon_container_set_margins (icon_container,
++ borders[0 /* left */],
++ borders[1 /* right */],
++ borders[2 /* top */],
++ borders[3 /* bottom */]);
+ }
+
+- if (workareas != NULL)
+- XFree (workareas);
++ if (borders != NULL)
++ XFree (borders);
+ }
+
+ static GdkFilterReturn
+@@ -235,8 +210,9 @@
+
+ switch (xevent->type) {
+ case PropertyNotify:
+- if (xevent->xproperty.atom == gdk_x11_get_xatom_by_name ("_NET_WORKAREA"))
++ if (xevent->xproperty.atom == gdk_x11_get_xatom_by_name ("GNOME_PANEL_DESKTOP_AREA")) {
+ net_workarea_changed (icon_view);
++ }
+ break;
+ default:
+ break;
+@@ -708,7 +684,8 @@
+ default_zoom_level_changed (desktop_icon_view);
+ fm_desktop_icon_view_update_icon_container_fonts (desktop_icon_view);
+
+- /* Read out the workarea geometry and update the icon container accordingly */
++ /* Read out the panel desktop area and update the icon container
++ * accordingly */
+ net_workarea_changed (desktop_icon_view);
+
+ /* Setup the property filter */
9fa51fe'>remove elliptic.P224 usagePavol Rusnak2015-07-302-14/+1 * FreeBSD supportFynn2015-07-291-0/+2 * Merge pull request #1515 from fjl/license-fixesJeffrey Wilcke2015-07-2817-19/+67 |\ | * crypto/sha3: add full license headersFelix Lange2015-07-242-4/+52 | * all: fix license headers one more timeFelix Lange2015-07-2415-15/+15 * | crypto: fix build with Go 1.5Felix Lange2015-07-281-1/+8 |/ * all: update license headers to distiguish GPL/LGPLFelix Lange2015-07-2315-60/+60 * crypto: fix license of curve.goFelix Lange2015-07-231-27/+38 * crypto: remove debug print call after decrypting a key from diskFelix Lange2015-07-211-1/+0 * : colon => dash - in keyfile name - slight deviation from ISO8601 for WIN FS...zelig2015-07-091-1/+1 * all: goimports -wFelix Lange2015-07-071-1/+2 * all: remove @author commentsFelix Lange2015-07-073-21/+0 * all: update license informationFelix Lange2015-07-0720-47/+371 * account update: migrate or change passwordzelig2015-07-032-18/+60 * fix account orderingzelig2015-07-033-73/+96 * accounts order by keyfile ctimezelig2015-07-031-2/+25 * Change keystore to version 3Gustav Simonsson2015-06-247-91/+344 * crypto: return common.Address rather than raw bytesobscuren2015-06-052-5/+5 * Merge pull request #1166 from Gustav-Simonsson/add_ec_sig_validationsJeffrey Wilcke2015-06-031-0/+16 |\ | * Initialise curve N value in package initGustav Simonsson2015-06-031-1/+3 | * Add EC signature validations before call to libsecp256k1Gustav Simonsson2015-06-021-0/+14 * | crypto/sha3: pull in latest keccak from go crypto (45% speed increase)Péter Szilágyi2015-06-032-173/+409 |/ * Update keystore code commentsGustav Simonsson2015-05-141-6/+7 * Change default keystore dirGustav Simonsson2015-05-131-1/+1 * Update key store to new spec but keep address field for nowGustav Simonsson2015-05-123-68/+55 * Address pull request comments; key header and hex encodingGustav Simonsson2015-05-123-31/+67 * Revert "Add key header to unencrypted key file"Gustav Simonsson2015-05-122-16/+8 * Add key header to unencrypted key fileGustav Simonsson2015-05-122-8/+16 * Add key header to encrypted keysGustav Simonsson2015-05-122-7/+57 * Use common.Address type for accounts.AddressGustav Simonsson2015-05-124-28/+30 * Improve key store passphrase cryptoGustav Simonsson2015-05-124-23/+31 * Remove the awesome, ever misunderstood entropy mixingGustav Simonsson2015-05-124-64/+15 * replaced several path.* with filepath.* which is platform independentBas van Kervel2015-05-122-7/+7 * Add loading of block test privkey if presentGustav Simonsson2015-04-281-0/+13 * Remove unneeded allocationGustav Simonsson2015-04-251-1/+0 * Use make instead of new for allocationGustav Simonsson2015-04-241-1/+1 * Fix ignore of unexpected files in key dirGustav Simonsson2015-04-231-3/+3 * doc: crypto/secp256k1 GMP dependency package name.Noel Maersk2015-04-231-1/+4 * Adding flags to facilitate cross compiling to ARMMaran2015-04-221-0/+2 * crypto: update {Load,Save}ECDSA comments to mention hex encodingFelix Lange2015-04-191-2/+3 * removed utility function and implemented hex conversation in crypto functionsBas van Kervel2015-04-091-2/+9 * Support for import/export hex encoded keys, closes #635Bas van Kervel2015-04-091-3/+3 * Add IsOnCurve check to EC unmarshalling in ECIES decryptionGustav Simonsson2015-04-081-0/+4 * Merge pull request #648 from Gustav-Simonsson/forward_ecrecover_err_and_remov...Jeffrey Wilcke2015-04-081-9/+7 |\ | * Forward and log EC recover err and remove dup pubkey len checkGustav Simonsson2015-04-071-9/+7 * | libsecp256k1 #define NDEBUGGustav Simonsson2015-04-081-0/+1 * | Link GMPobscuren2015-04-071-0/+3 * | Update Go wrapper around libbsecp256k1Gustav Simonsson2015-04-071-89/+25 * | Update bitcoin secp256k1 libGustav Simonsson2015-04-0774-4960/+10508 |/ * Cleanup.obscuren2015-03-291-9/+7 * common: remove WriteFile and ReadAllFile (use ioutil instead)zelig2015-03-271-2/+4 * import/export accountszelig2015-03-272-7/+16 * crypto: remove use of common.Value.EncodeFelix Lange2015-03-201-9/+1 * Merge remote-tracking branch 'ethereum/conversion' into conversionFelix Lange2015-03-171-2/+5 |\ | *