aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/libbonoboui/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-04-09 05:01:48 +0800
committermarcus <marcus@FreeBSD.org>2002-04-09 05:01:48 +0800
commit3eb8af00ef13e2e568d30d0ec0840b97ea96cee2 (patch)
tree60a50a32493eafce58429f2cdd81b39ead5aec39 /x11-toolkits/libbonoboui/Makefile
parent8175b10653261ab43f647148296e2255213d72d0 (diff)
downloadfreebsd-ports-gnome-3eb8af00ef13e2e568d30d0ec0840b97ea96cee2.tar.gz
freebsd-ports-gnome-3eb8af00ef13e2e568d30d0ec0840b97ea96cee2.tar.zst
freebsd-ports-gnome-3eb8af00ef13e2e568d30d0ec0840b97ea96cee2.zip
Add libbonoboui, the GUI components for GOME 2.0 bonobo component.
Reviewed by: sobomax Approved by: sobomax
Diffstat (limited to 'x11-toolkits/libbonoboui/Makefile')
-rw-r--r--x11-toolkits/libbonoboui/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-toolkits/libbonoboui/Makefile b/x11-toolkits/libbonoboui/Makefile
new file mode 100644
index 000000000000..e3c79e43f071
--- /dev/null
+++ b/x11-toolkits/libbonoboui/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libbonoboui
+# Date created: 04 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbonoboui
+PORTVERSION= 1.113.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas \
+ gnome-2.0:${PORTSDIR}/x11/libgnome
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+
+.include <bsd.port.mk>