aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-08-30 21:52:25 +0800
committeralane <alane@FreeBSD.org>2002-08-30 21:52:25 +0800
commit1bed84dc73dc3e84814ad7c81495a9e8afaf13df (patch)
tree35c29a902ff258622afe03eacdeadf6329d286db /x11-toolkits
parent84bd01cb88bc96a6856a9de283ba86c352a26c71 (diff)
downloadfreebsd-ports-gnome-1bed84dc73dc3e84814ad7c81495a9e8afaf13df.tar.gz
freebsd-ports-gnome-1bed84dc73dc3e84814ad7c81495a9e8afaf13df.tar.zst
freebsd-ports-gnome-1bed84dc73dc3e84814ad7c81495a9e8afaf13df.zip
Added "threads" to the qmake.conf file. From this message on the list:
FreeBSD port installs threaded version of qt (qt-mt), but qmake.conf is installed withouth thread in the CONFIG variable. Because of that, qmake tried to link with -lqt instead of -lqt-mt -pthread and fails. With thread in the CONFIG everything works. This affects all ports that use qmake. Folks, please test this (especially on current). It seems reasonable, is easy to back out, I'm running a qt built with it right now. Submitted by: Tilman Linneweh <tilman@arved.de>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt30/Makefile2
-rw-r--r--x11-toolkits/qt31/Makefile2
-rw-r--r--x11-toolkits/qt32/Makefile2
-rw-r--r--x11-toolkits/qt33/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index cd939272c586..550ae714e8da 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -105,6 +105,8 @@ post-patch:
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
@${REINPLACE_CMD} -e 's,g++,${CXX},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,release,release thread,' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install:
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index cd939272c586..550ae714e8da 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -105,6 +105,8 @@ post-patch:
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
@${REINPLACE_CMD} -e 's,g++,${CXX},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,release,release thread,' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install:
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index cd939272c586..550ae714e8da 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -105,6 +105,8 @@ post-patch:
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
@${REINPLACE_CMD} -e 's,g++,${CXX},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,release,release thread,' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install:
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index cd939272c586..550ae714e8da 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -105,6 +105,8 @@ post-patch:
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
@${REINPLACE_CMD} -e 's,g++,${CXX},' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,release,release thread,' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
# Work around qmake generated dependencies
pre-install: