aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-08-11 16:37:44 +0800
committertg <tg@FreeBSD.org>1998-08-11 16:37:44 +0800
commita9472bcaa0c3cf7767783ba79cbdb81937815c1e (patch)
tree40453067e5d093484c6fcef3a33d0cd0c1e65b31 /x11-wm
parentec8a52366fb5043047c105f9ec87362ee4d7995d (diff)
downloadfreebsd-ports-gnome-a9472bcaa0c3cf7767783ba79cbdb81937815c1e.tar.gz
freebsd-ports-gnome-a9472bcaa0c3cf7767783ba79cbdb81937815c1e.tar.zst
freebsd-ports-gnome-a9472bcaa0c3cf7767783ba79cbdb81937815c1e.zip
(1) Configure looks first for tiff, then tiff34...so if you have an old
version of tiff, it never finds the first one. "Anthony C. Chavez" <magus@xmission.com> (2) dockit calls out wish in the first line. moro <moro@remus.dti.ne.jp> Submitted by: Brian Handy <handy@physics.montana.edu>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker-i18n/Makefile5
-rw-r--r--x11-wm/windowmaker-i18n/files/patch-ad56
-rw-r--r--x11-wm/windowmaker/Makefile5
3 files changed, 62 insertions, 4 deletions
diff --git a/x11-wm/windowmaker-i18n/Makefile b/x11-wm/windowmaker-i18n/Makefile
index 14c462cab501..f68f076e1d78 100644
--- a/x11-wm/windowmaker-i18n/Makefile
+++ b/x11-wm/windowmaker-i18n/Makefile
@@ -3,7 +3,7 @@
# Date created: August 13, 1997
# Whom: handy@physics.montana.edu
#
-# $Id: Makefile,v 1.18 1998/08/05 09:31:49 asami Exp $
+# $Id: Makefile,v 1.19 1998/08/07 23:01:40 asami Exp $
DISTNAME= WindowMaker-0.17.5
PKGNAME= windowmaker-0.17.5
@@ -14,6 +14,7 @@ MASTER_SITES= ftp://ftp.windowmaker.org/pub/beta/srcs/ \
MAINTAINER= handy@physics.montana.edu
+RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
png\\.2\\.:${PORTSDIR}/graphics/png \
@@ -24,7 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= X11BASE=${X11BASE}
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${LOCALBASE}/lib/locale \
- --with-gfx-libs="-L${LOCALBASE}/lib -ltiff34" \
+ --with-gfx-libs="-L${LOCALBASE}/lib" \
--with-gfx-incs="-I${LOCALBASE}/include/tiff34 -I${LOCALBASE}/include"
post-extract:
diff --git a/x11-wm/windowmaker-i18n/files/patch-ad b/x11-wm/windowmaker-i18n/files/patch-ad
new file mode 100644
index 000000000000..3ddedd1ef8af
--- /dev/null
+++ b/x11-wm/windowmaker-i18n/files/patch-ad
@@ -0,0 +1,56 @@
+--- configure.orig Sun Jul 26 07:22:23 1998
++++ configure Sun Aug 9 02:12:31 1998
+@@ -3576,44 +3576,6 @@
+ ICONEXT="xpm"
+ #
+ if test "$tif" = yes; then
+- echo $ac_n "checking for TIFFGetVersion in -ltiff""... $ac_c" 1>&6
+-echo "configure:3581: checking for TIFFGetVersion in -ltiff" >&5
+-ac_lib_var=`echo tiff'_'TIFFGetVersion | sed 'y%./+-%__p_%'`
+-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+- echo $ac_n "(cached) $ac_c" 1>&6
+-else
+- ac_save_LIBS="$LIBS"
+-LIBS="-ltiff $GFX_INC_PATH $GFX_LIB_PATH $XLFLAGS $XLIBS $GFXLIBS -lm $LIBS"
+-cat > conftest.$ac_ext <<EOF
+-#line 3589 "configure"
+-#include "confdefs.h"
+-/* Override any gcc2 internal prototype to avoid an error. */
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char TIFFGetVersion();
+-
+-int main() {
+-TIFFGetVersion()
+-; return 0; }
+-EOF
+-if { (eval echo configure:3600: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+- rm -rf conftest*
+- eval "ac_cv_lib_$ac_lib_var=yes"
+-else
+- echo "configure: failed program was:" >&5
+- cat conftest.$ac_ext >&5
+- rm -rf conftest*
+- eval "ac_cv_lib_$ac_lib_var=no"
+-fi
+-rm -f conftest*
+-LIBS="$ac_save_LIBS"
+-
+-fi
+-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+- echo "$ac_t""yes" 1>&6
+- GFXFLAGS="$GFXFLAGS -DUSE_TIFF" GFXLIBS="-ltiff $GFXLIBS" ICONEXT="tiff"
+-else
+- echo "$ac_t""no" 1>&6
+ echo $ac_n "checking for TIFFGetVersion in -ltiff34""... $ac_c" 1>&6
+ echo "configure:3619: checking for TIFFGetVersion in -ltiff34" >&5
+ ac_lib_var=`echo tiff34'_'TIFFGetVersion | sed 'y%./+-%__p_%'`
+@@ -3652,8 +3614,6 @@
+ GFXFLAGS="$GFXFLAGS -DUSE_TIFF" GFXLIBS="-ltiff34 $GFXLIBS" ICONEXT="tiff"
+ else
+ echo "$ac_t""no" 1>&6
+-fi
+-
+ fi
+
+ fi
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 14c462cab501..f68f076e1d78 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -3,7 +3,7 @@
# Date created: August 13, 1997
# Whom: handy@physics.montana.edu
#
-# $Id: Makefile,v 1.18 1998/08/05 09:31:49 asami Exp $
+# $Id: Makefile,v 1.19 1998/08/07 23:01:40 asami Exp $
DISTNAME= WindowMaker-0.17.5
PKGNAME= windowmaker-0.17.5
@@ -14,6 +14,7 @@ MASTER_SITES= ftp://ftp.windowmaker.org/pub/beta/srcs/ \
MAINTAINER= handy@physics.montana.edu
+RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
png\\.2\\.:${PORTSDIR}/graphics/png \
@@ -24,7 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= X11BASE=${X11BASE}
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${LOCALBASE}/lib/locale \
- --with-gfx-libs="-L${LOCALBASE}/lib -ltiff34" \
+ --with-gfx-libs="-L${LOCALBASE}/lib" \
--with-gfx-incs="-I${LOCALBASE}/include/tiff34 -I${LOCALBASE}/include"
post-extract: