aboutsummaryrefslogtreecommitdiffstats
path: root/x11/eterm
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-09-08 03:59:57 +0800
committerolgeni <olgeni@FreeBSD.org>2001-09-08 03:59:57 +0800
commit1f6ee290fa4028e19111dc2b06cb7677a7297470 (patch)
tree8adb15ef17d4c85480ae750815b503574d44c7ed /x11/eterm
parent0d8ee307c22e51eabc404c7a5b59db4f8745b199 (diff)
downloadfreebsd-ports-gnome-1f6ee290fa4028e19111dc2b06cb7677a7297470.tar.gz
freebsd-ports-gnome-1f6ee290fa4028e19111dc2b06cb7677a7297470.tar.zst
freebsd-ports-gnome-1f6ee290fa4028e19111dc2b06cb7677a7297470.zip
Update port to version 0.9.1, plus a couple of patches from CVS to fix some
bugs. Submitted by: Jeremy Norris <ishmael27@home.com>
Diffstat (limited to 'x11/eterm')
-rw-r--r--x11/eterm/Makefile26
-rw-r--r--x11/eterm/distinfo2
-rw-r--r--x11/eterm/files/patch-default_font_index33
-rw-r--r--x11/eterm/files/patch-doc:Makefile.in25
-rw-r--r--x11/eterm/files/patch-libmej:Makefile.in11
-rw-r--r--x11/eterm/files/patch-src:Makefile.in14
-rw-r--r--x11/eterm/files/patch-themes:Makefile.in10
-rw-r--r--x11/eterm/files/patch-vim_escape_handling77
-rw-r--r--x11/eterm/pkg-plist75
9 files changed, 180 insertions, 93 deletions
diff --git a/x11/eterm/Makefile b/x11/eterm/Makefile
index a2feefd95e6d..f1f12b6afb3c 100644
--- a/x11/eterm/Makefile
+++ b/x11/eterm/Makefile
@@ -6,29 +6,35 @@
#
PORTNAME= eterm
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= eterm
+MASTER_SITES= http://www.eterm.org/download/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= Eterm-${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
BUILD_DEPENDS= man2html:${PORTSDIR}/textproc/man2html
-USE_GMAKE= yes
+LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2 \
+ ast.1:${PORTSDIR}/devel/libast
+
USE_X_PREFIX= yes
-USE_IMLIB= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --enable-trans=imlib --enable-utmp \
+CONFIGURE_ARGS= --enable-trans --enable-utmp \
--enable-xim --with-theme-update \
- --with-backspace=bs
-CONFIGURE_ENV= LIBS="-lxpg4"
+ --with-backspace=bs --without-terminfo
MAN1= Eterm.1
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MMX) && (${ARCH} == "i386")
+CONFIGURE_ARGS+=--enable-mmx
+.endif
+
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/Eterm
.if !defined(NOPORTDOCS)
@@ -40,4 +46,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ti ${PREFIX}/share/doc/Eterm
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/eterm/distinfo b/x11/eterm/distinfo
index 8a70d6d77521..e8471b318bea 100644
--- a/x11/eterm/distinfo
+++ b/x11/eterm/distinfo
@@ -1 +1 @@
-MD5 (Eterm-0.9.tar.gz) = 0da2a2c9a5d9e9f698d7f89ccb2f9f38
+MD5 (Eterm-0.9.1.tar.gz) = a3b767d29b82fc7541c9ba65931e5d37
diff --git a/x11/eterm/files/patch-default_font_index b/x11/eterm/files/patch-default_font_index
new file mode 100644
index 000000000000..da07f08e6e36
--- /dev/null
+++ b/x11/eterm/files/patch-default_font_index
@@ -0,0 +1,33 @@
+--- src/font.c.orig Sat Jul 21 22:25:23 2001
++++ src/font.c Fri Sep 7 01:11:47 2001
+@@ -21,7 +21,7 @@
+ * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+-static const char cvs_ident[] = "$Id: font.c,v 1.28 2001/07/22 03:25:23 mej Exp $";
++static const char cvs_ident[] = "$Id: font.c,v 1.29 2001/09/06 22:26:20 mej Exp $";
+
+ #include "config.h"
+ #include "feature.h"
+@@ -41,7 +41,8 @@
+ #include "windows.h"
+
+ char **etfonts = NULL;
+-unsigned char font_idx = DEF_FONT_IDX, def_font_idx = DEF_FONT_IDX, font_cnt = 0;
++unsigned char font_idx = DEF_FONT_IDX, font_cnt = 0;
++int def_font_idx = DEF_FONT_IDX;
+ char *rs_font[NFONTS];
+ #ifdef MULTI_CHARSET
+ char *rs_mfont[NFONTS];
+--- src/font.h.orig Thu Jun 14 00:31:08 2001
++++ src/font.h Fri Sep 7 01:11:47 2001
+@@ -73,7 +73,8 @@
+ } fontshadow_t;
+
+ /************ Variables ************/
+-extern unsigned char font_idx, def_font_idx, font_cnt, font_chg;
++extern unsigned char font_idx, font_cnt, font_chg;
++extern int def_font_idx;
+ extern const char *def_fontName[];
+ extern char *rs_font[NFONTS];
+ extern char **etfonts, **etmfonts;
diff --git a/x11/eterm/files/patch-doc:Makefile.in b/x11/eterm/files/patch-doc:Makefile.in
new file mode 100644
index 000000000000..6ebfc8c1596d
--- /dev/null
+++ b/x11/eterm/files/patch-doc:Makefile.in
@@ -0,0 +1,25 @@
+--- doc/Makefile.in.orig Wed Aug 29 03:23:41 2001
++++ doc/Makefile.in Fri Sep 7 01:40:20 2001
+@@ -267,15 +267,15 @@
+ $(SED) -e 's%@''VERSION''@%$(VERSION)%g' -e 's%@''DATE''@%$(DATE)%g' -e 's%@THEMEDIR@%$(pkgdatadir)/themes%g' $(top_srcdir)/doc/$@.in > $@
+
+ Eterm.1.html: Eterm.1
+- (nroff -man $< | man2html -title Eterm > $@) || :
++ (nroff -man Eterm.1 | man2html -title Eterm > $@) || :
+
+ install-data-hook:
+- $(TIC) Eterm.ti || (mkinstalldirs $(HOME)/.terminfo && $(TIC) -o$(HOME)/.terminfo Eterm.ti) || :
+- -infocmp -C -sc Eterm | sed -e '/Reconstructed/d' -e '/\.\.sa=/d' > Eterm.tcap.new && mv Eterm.tcap.new Eterm.tcap || rm -f Eterm.tcap.new
+- -if test -f /usr/share/misc/termcap && test -f Eterm.tcap ; then \
+- grep 'Eterm-color' /usr/share/misc/termcap || cat Eterm.tcap >> /usr/share/misc/termcap ; \
+- cap_mkdb termcap ; \
+- fi || :
++# $(TIC) Eterm.ti || (mkinstalldirs $(HOME)/.terminfo && $(TIC) -o$(HOME)/.terminfo Eterm.ti) || :
++# -infocmp -C -sc Eterm | sed -e '/Reconstructed/d' -e '/\.\.sa=/d' > Eterm.tcap.new && mv Eterm.tcap.new Eterm.tcap || rm -f Eterm.tcap.new
++# -if test -f /usr/share/misc/termcap && test -f Eterm.tcap ; then \
++# grep 'Eterm-color' /usr/share/misc/termcap || cat Eterm.tcap >> /usr/share/misc/termcap ; \
++# cap_mkdb termcap ; \
++# fi || :
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/x11/eterm/files/patch-libmej:Makefile.in b/x11/eterm/files/patch-libmej:Makefile.in
deleted file mode 100644
index d76485d51e06..000000000000
--- a/x11/eterm/files/patch-libmej:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libmej/Makefile.in.orig Mon Feb 7 21:52:12 2000
-+++ libmej/Makefile.in Mon Feb 7 21:52:44 2000
-@@ -120,7 +120,7 @@
-
- INCLUDES = -I. -I.. -I$(includedir) -I$(prefix)/include
-
--libmej_la_LDFLAGS = -release $(VERSION)
-+libmej_la_LDFLAGS = -version-info 9:9:9
-
- EXTRA_DIST = debug.h global.h mem.h strings.h strptime.h strptime.c
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/x11/eterm/files/patch-src:Makefile.in b/x11/eterm/files/patch-src:Makefile.in
index 4b361a26877e..e8d99db3efe7 100644
--- a/x11/eterm/files/patch-src:Makefile.in
+++ b/x11/eterm/files/patch-src:Makefile.in
@@ -1,11 +1,11 @@
---- src/Makefile.in.orig Mon Feb 7 21:50:25 2000
-+++ src/Makefile.in Mon Feb 7 21:51:29 2000
-@@ -120,7 +120,7 @@
+--- src/Makefile.in.orig Wed Aug 29 03:23:38 2001
++++ src/Makefile.in Fri Sep 7 00:29:05 2001
+@@ -123,7 +123,7 @@
+ EXTRA_libEterm_la_SOURCES = $(MMX_SRCS)
- libEterm_la_DEPENDENCIES = $(top_builddir)/libmej/libmej.la feature.h
-libEterm_la_LDFLAGS = -release $(VERSION)
+libEterm_la_LDFLAGS = -version-info 9:9:9
-
- bin_PROGRAMS = Eterm
- Eterm_SOURCES = main.c
+ @HAVE_MMX_TRUE@libEterm_la_DEPENDENCIES = feature.h $(MMX_OBJS)
+ @HAVE_MMX_FALSE@libEterm_la_DEPENDENCIES = feature.h
+ @HAVE_MMX_TRUE@libEterm_la_LIBADD = $(MMX_OBJS)
diff --git a/x11/eterm/files/patch-themes:Makefile.in b/x11/eterm/files/patch-themes:Makefile.in
deleted file mode 100644
index df28d12363df..000000000000
--- a/x11/eterm/files/patch-themes:Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- themes/Makefile.in.orig Wed Feb 2 05:36:43 2000
-+++ themes/Makefile.in Wed Feb 9 03:46:59 2000
-@@ -239,6 +239,7 @@
- $(CHMOD) 755 $(DESTDIR)$(pkgdatadir)/themes/$$i ; \
- $(CHMOD) 644 $(DESTDIR)$(pkgdatadir)/themes/$$i/???* ; \
- rm -f $(DESTDIR)$(pkgdatadir)/themes/$$i/theme.cfg.in ; \
-+ rm -f $(DESTDIR)$(pkgdatadir)/themes/$$i/theme.cfg.in.orig ; \
- else \
- echo "ALERT! Not overwriting $$i theme in $(DESTDIR)$(pkgdatadir)/themes. You will need to update this theme manually." ; \
- fi ; \
diff --git a/x11/eterm/files/patch-vim_escape_handling b/x11/eterm/files/patch-vim_escape_handling
new file mode 100644
index 000000000000..6a5ff9d270c4
--- /dev/null
+++ b/x11/eterm/files/patch-vim_escape_handling
@@ -0,0 +1,77 @@
+--- src/term.c.orig Thu Aug 23 19:22:55 2001
++++ src/term.c Fri Sep 7 01:13:07 2001
+@@ -21,7 +21,7 @@
+ * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+-static const char cvs_ident[] = "$Id: term.c,v 1.68 2001/08/23 21:04:36 mej Exp $";
++static const char cvs_ident[] = "$Id: term.c,v 1.69 2001/09/06 22:38:21 mej Exp $";
+
+ #include "config.h"
+ #include "feature.h"
+@@ -945,15 +945,12 @@
+ process_csi_seq(void)
+ {
+
+- unsigned char ch, priv;
+- unsigned int nargs;
+- int arg[ESC_ARGS];
+-
+- nargs = 0;
+- arg[0] = 0;
+- arg[1] = 0;
++ unsigned char ch;
++ unsigned char priv = 0;
++ unsigned int nargs = 0;
++ int arg[ESC_ARGS] = {0, 0};
++ int ignore = 0;
+
+- priv = 0;
+ ch = cmd_getc(); /* Get the next character */
+ if (ch >= '<' && ch <= '?') {
+ priv = ch; /* DEC private mode sequence. Get next character. */
+@@ -977,6 +974,8 @@
+ scr_add_lines(&ch, 0, 1); /* Insert verbatim non-printable character (NPC) */
+ return;
+ }
++ if (ch == '-') /* HACK: Ignore this sequence, but finish reading */
++ ignore = 1; /* xterm ignores more than this, but we need this for vim */
+ if (ch < '@')
+ ch = cmd_getc(); /* Separator. Go to next digit or operation. */
+ } while (ch >= ' ' && ch < '@');
+@@ -986,6 +985,9 @@
+ } else if (ch < ' ')
+ return; /* An NPC. Punt. */
+
++ if(ignore)
++ return;
++
+ switch (ch) {
+ case '@':
+ scr_insdel_chars((arg[0] ? arg[0] : 1), INSERT);
+@@ -1067,6 +1069,8 @@
+ break;
+
+ case 'c':
++ /* TODO: A different response should be sent depending on the value of
++ priv and of arg[0], but what should those reponses be? */
+ #ifndef NO_VT100_ANS
+ tt_printf(VT100_ANS);
+ #endif
+@@ -1403,7 +1407,7 @@
+ process_terminal_mode(int mode, int priv, unsigned int nargs, int arg[])
+ {
+ unsigned int i;
+- int state;
++ int state; /* This gets set by the PrivCases macro */
+
+ if (nargs == 0)
+ return;
+@@ -1526,6 +1530,7 @@
+ else
+ Options |= Opt_home_on_input;
+ break;
++
+ case 1047: /* Alternate screen & clear */
+ PrivCases(PrivMode_Screen);
+ scr_change_screen(state);
diff --git a/x11/eterm/pkg-plist b/x11/eterm/pkg-plist
index f56fd02b387d..ad42ff59b256 100644
--- a/x11/eterm/pkg-plist
+++ b/x11/eterm/pkg-plist
@@ -1,98 +1,65 @@
bin/Esetroot
bin/Etbg
+bin/Etbg_update_list
bin/Etcolors
bin/Eterm
-@exec chmod 4711 %D/bin/Eterm
+bin/Etsearch
bin/Ettable
-bin/Etwinop
+bin/kEsetroot
lib/libEterm.a
lib/libEterm.so
lib/libEterm.so.9
-lib/libmej.a
-lib/libmej.so
-lib/libmej.so.9
-share/Eterm/pix/014.jpg
-share/Eterm/pix/40.jpg
-share/Eterm/pix/backwave.jpg
share/Eterm/pix/bar_horizontal_1.png
share/Eterm/pix/bar_horizontal_2.png
share/Eterm/pix/bar_horizontal_3.png
share/Eterm/pix/bar_vertical_1.png
share/Eterm/pix/bar_vertical_2.png
share/Eterm/pix/bar_vertical_3.png
-share/Eterm/pix/blackstone.jpg
share/Eterm/pix/button_arrow_down_1.png
share/Eterm/pix/button_arrow_down_2.png
share/Eterm/pix/button_arrow_down_3.png
share/Eterm/pix/button_arrow_up_1.png
share/Eterm/pix/button_arrow_up_2.png
share/Eterm/pix/button_arrow_up_3.png
-share/Eterm/pix/circuit.jpg
-share/Eterm/pix/fourthday.jpg
-share/Eterm/pix/gaia.jpg
-share/Eterm/pix/galleon.jpg
+share/Eterm/pix/exit.png
+share/Eterm/pix/help.png
share/Eterm/pix/menu1.png
share/Eterm/pix/menu2.png
share/Eterm/pix/menu3.png
-share/Eterm/pix/nebula.jpg
-share/Eterm/pix/night_of_the_dragon.jpg
share/Eterm/pix/pixmaps.list
-share/Eterm/pix/scaled-pixmaps.list
-share/Eterm/pix/tiled-pixmaps.list
+share/Eterm/pix/scale/Neopolis-horizon.jpg
+share/Eterm/pix/thumb_1.png
+share/Eterm/pix/thumb_2.png
+share/Eterm/pix/tile/014.jpg
+share/Eterm/pix/tile/40.jpg
+share/Eterm/pix/tile/blackstone.jpg
+share/Eterm/pix/tile/circuit.jpg
+share/Eterm/pix/tile/giger1.jpg
+share/Eterm/pix/tile/nebula.jpg
share/Eterm/themes/Eterm/menus.cfg
share/Eterm/themes/Eterm/pixmaps.list
-share/Eterm/themes/Eterm/scaled-pixmaps.list
share/Eterm/themes/Eterm/theme.cfg
-share/Eterm/themes/Eterm/tiled-pixmaps.list
share/Eterm/themes/auto/menus.cfg
share/Eterm/themes/auto/pixmaps.list
-share/Eterm/themes/auto/scaled-pixmaps.list
share/Eterm/themes/auto/theme.cfg
-share/Eterm/themes/auto/tiled-pixmaps.list
-share/Eterm/themes/cEterm/menus.cfg
-share/Eterm/themes/cEterm/pixmaps.list
-share/Eterm/themes/cEterm/scaled-pixmaps.list
-share/Eterm/themes/cEterm/theme.cfg
-share/Eterm/themes/cEterm/tiled-pixmaps.list
share/Eterm/themes/chooser/menus.cfg
share/Eterm/themes/chooser/pixmaps.list
-share/Eterm/themes/chooser/scaled-pixmaps.list
share/Eterm/themes/chooser/theme.cfg
-share/Eterm/themes/chooser/tiled-pixmaps.list
-share/Eterm/themes/emacs/menus.cfg
-share/Eterm/themes/emacs/pixmaps.list
-share/Eterm/themes/emacs/scaled-pixmaps.list
-share/Eterm/themes/emacs/theme.cfg
-share/Eterm/themes/emacs/tiled-pixmaps.list
-share/Eterm/themes/irc/menus.cfg
-share/Eterm/themes/irc/pixmaps.list
-share/Eterm/themes/irc/scaled-pixmaps.list
-share/Eterm/themes/irc/theme.cfg
-share/Eterm/themes/irc/tiled-pixmaps.list
-share/Eterm/themes/mutt/menus.cfg
-share/Eterm/themes/mutt/pixmaps.list
-share/Eterm/themes/mutt/scaled-pixmaps.list
-share/Eterm/themes/mutt/theme.cfg
-share/Eterm/themes/mutt/tiled-pixmaps.list
share/Eterm/themes/trans/menus.cfg
share/Eterm/themes/trans/pixmaps.list
-share/Eterm/themes/trans/scaled-pixmaps.list
share/Eterm/themes/trans/theme.cfg
-share/Eterm/themes/trans/tiled-pixmaps.list
%%PORTDOCS%%share/doc/Eterm/Eterm.1.html
%%PORTDOCS%%share/doc/Eterm/Eterm.tcap
%%PORTDOCS%%share/doc/Eterm/Eterm.ti
%%PORTDOCS%%share/doc/Eterm/Eterm_reference.html
%%PORTDOCS%%share/doc/Eterm/ReleaseNotes
-@dirrm share/Eterm/themes/trans
-@dirrm share/Eterm/themes/mutt
-@dirrm share/Eterm/themes/irc
-@dirrm share/Eterm/themes/emacs
-@dirrm share/Eterm/themes/chooser
-@dirrm share/Eterm/themes/cEterm
-@dirrm share/Eterm/themes/auto
-@dirrm share/Eterm/themes/Eterm
+@dirrm share/Eterm/pix/scale
+@dirrm share/Eterm/pix/tile
@dirrm share/Eterm/pix
+@dirrm share/Eterm/themes/Eterm
+@dirrm share/Eterm/themes/auto
+@dirrm share/Eterm/themes/chooser
+@dirrm share/Eterm/themes/trans
@dirrm share/Eterm/themes
-%%PORTDOCS%%@dirrm share/doc/Eterm
@dirrm share/Eterm
+%%PORTDOCS%%@dirrm share/doc/Eterm