aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnomelibs
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-17 02:24:39 +0800
committerade <ade@FreeBSD.org>2000-09-17 02:24:39 +0800
commit896b15f222afc0b4d5879f4c0332397ac2866272 (patch)
tree6e7409025a1fc76e319d04c7d4eb1e8e5bfc2f52 /x11/gnomelibs
parent1bda467d86b43e7c35c14876c0a527414593bb03 (diff)
downloadfreebsd-ports-gnome-896b15f222afc0b4d5879f4c0332397ac2866272.tar.gz
freebsd-ports-gnome-896b15f222afc0b4d5879f4c0332397ac2866272.tar.zst
freebsd-ports-gnome-896b15f222afc0b4d5879f4c0332397ac2866272.zip
Add fix for GNOME forcibly trying to set the locale to en_US
under certain circumstances. PORTREVISION bumped to 1 to reflect this
Diffstat (limited to 'x11/gnomelibs')
-rw-r--r--x11/gnomelibs/Makefile1
-rw-r--r--x11/gnomelibs/files/patch-bl35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11/gnomelibs/Makefile b/x11/gnomelibs/Makefile
index 73a594b5e2d3..7f67247a395a 100644
--- a/x11/gnomelibs/Makefile
+++ b/x11/gnomelibs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomelibs
PORTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-libs
diff --git a/x11/gnomelibs/files/patch-bl b/x11/gnomelibs/files/patch-bl
new file mode 100644
index 000000000000..a16b56bc3a8b
--- /dev/null
+++ b/x11/gnomelibs/files/patch-bl
@@ -0,0 +1,35 @@
+--- libgnomeui/gnome-init.c.orig Sat May 6 10:30:31 2000
++++ libgnomeui/gnome-init.c Tue Sep 12 11:34:20 2000
+@@ -200,32 +200,8 @@
+ switch(reason) {
+ case POPT_CALLBACK_REASON_PRE:
+ {
+- char *ctype, *old_ctype = NULL;
+- gboolean ctype_set;
+-
+ gnome_segv_setup (FALSE);
+- ctype = setlocale (LC_CTYPE, NULL);
+-
+- if (!strcmp(ctype, "C")) {
+- old_ctype = g_strdup (getenv ("LC_CTYPE"));
+- putenv ("LC_CTYPE=en_US");
+- ctype_set = TRUE;
+- } else
+- ctype_set = FALSE;
+-
+ gtk_set_locale ();
+-
+- if (ctype_set) {
+- char *setme;
+-
+- if (old_ctype) {
+- setme = g_strconcat ("LC_CTYPE=", old_ctype, NULL);
+- g_free(old_ctype);
+- } else
+- setme = "LC_CTYPE";
+-
+- putenv (setme);
+- }
+ client = gnome_master_client();
+ }
+ break;