aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/mird/Makefile5
-rw-r--r--devel/apr/Makefile1
-rw-r--r--devel/apr0/Makefile1
-rw-r--r--devel/apr1/Makefile1
-rw-r--r--devel/apr2/Makefile1
-rw-r--r--irc/bitchx/Makefile1
-rw-r--r--japanese/eb/Makefile1
-rw-r--r--japanese/eb3/Makefile1
-rw-r--r--print/cups/Makefile1
-rw-r--r--security/libgcrypt-devel/Makefile1
-rw-r--r--security/libgcrypt/Makefile1
-rw-r--r--security/libmcrypt/Makefile1
12 files changed, 14 insertions, 2 deletions
diff --git a/databases/mird/Makefile b/databases/mird/Makefile
index 042935f35b2b..1e02f7888f19 100644
--- a/databases/mird/Makefile
+++ b/databases/mird/Makefile
@@ -20,14 +20,15 @@ BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-debug
INSTALLS_SHLIB= yes
post-patch:
- @${PERL} -pi -e 's,CFLAGS=,CFLAGS+=,' ${WRKSRC}/src/Makefile.in
- @${PERL} -pi -e 's,-O,,g' ${WRKSRC}/src/configure
+ @${REINPLACE_CMD} -e 's,CFLAGS=,CFLAGS+=,' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's,-O,,g' ${WRKSRC}/src/configure
post-install:
${STRIP_CMD} ${PREFIX}/lib/libmird.so.1
diff --git a/devel/apr/Makefile b/devel/apr/Makefile
index 8ce66d52cb00..6287425b049a 100644
--- a/devel/apr/Makefile
+++ b/devel/apr/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2 \
GNU_CONFIGURE= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}
pre-fetch:
diff --git a/devel/apr0/Makefile b/devel/apr0/Makefile
index 8ce66d52cb00..6287425b049a 100644
--- a/devel/apr0/Makefile
+++ b/devel/apr0/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2 \
GNU_CONFIGURE= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}
pre-fetch:
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 8ce66d52cb00..6287425b049a 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2 \
GNU_CONFIGURE= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}
pre-fetch:
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 8ce66d52cb00..6287425b049a 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2 \
GNU_CONFIGURE= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}
pre-fetch:
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 9206efbae6e7..5a89b3123bb3 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -29,6 +29,7 @@ LIB_DEPENDS+= xmms.3:${PORTSDIR}/audio/xmms
.endif
WRKSRC= ${WRKDIR}/BitchX
+USE_PERL5= yes
USE_REINPLACE= yes
AUTOCONF= ${LOCALBASE}/bin/autoconf
GNU_CONFIGURE= yes
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 8061560ff1a0..2d789d1ad4f0 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -55,6 +55,7 @@ APPENDIXFILES= appendix/cencro-1.0.tar.gz \
DIST_SUBDIR= eb
+USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-nls \
--with-gettext-includes=${PREFIX}/include \
diff --git a/japanese/eb3/Makefile b/japanese/eb3/Makefile
index 8061560ff1a0..2d789d1ad4f0 100644
--- a/japanese/eb3/Makefile
+++ b/japanese/eb3/Makefile
@@ -55,6 +55,7 @@ APPENDIXFILES= appendix/cencro-1.0.tar.gz \
DIST_SUBDIR= eb
+USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-nls \
--with-gettext-includes=${PREFIX}/include \
diff --git a/print/cups/Makefile b/print/cups/Makefile
index 6135cc2a2a4e..b17bc4d6582b 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS?= espgs:${.CURDIR}/../../print/cups-pstoraster \
DEPENDS_TARGET="package"
.endif
+USE_PERL5= yes
NO_BUILD= true
do-install: # empty
do-patch: # empty
diff --git a/security/libgcrypt-devel/Makefile b/security/libgcrypt-devel/Makefile
index 799de43bfbfd..87016b9f8670 100644
--- a/security/libgcrypt-devel/Makefile
+++ b/security/libgcrypt-devel/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= freebsdports@arved.de
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
USE_REINPLACE= yes
+USE_PERL5= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index 799de43bfbfd..87016b9f8670 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= freebsdports@arved.de
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
USE_REINPLACE= yes
+USE_PERL5= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/security/libmcrypt/Makefile b/security/libmcrypt/Makefile
index ba971e8432c0..d4e0fc36bb5a 100644
--- a/security/libmcrypt/Makefile
+++ b/security/libmcrypt/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= ltdl.1:${PORTSDIR}/devel/libtool
RESTRICTED= "yes - cryptography"
+USE_PERL5= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}