aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--finance/p5-Finance-QuoteHist/Makefile33
-rw-r--r--finance/p5-Finance-QuoteHist/distinfo1
-rw-r--r--finance/p5-Finance-QuoteHist/pkg-comment1
-rw-r--r--finance/p5-Finance-QuoteHist/pkg-descr9
-rw-r--r--finance/p5-Finance-QuoteHist/pkg-plist10
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Finance-QuoteHist/Makefile33
-rw-r--r--misc/p5-Finance-QuoteHist/distinfo1
-rw-r--r--misc/p5-Finance-QuoteHist/pkg-comment1
-rw-r--r--misc/p5-Finance-QuoteHist/pkg-descr9
-rw-r--r--misc/p5-Finance-QuoteHist/pkg-plist10
11 files changed, 109 insertions, 0 deletions
diff --git a/finance/p5-Finance-QuoteHist/Makefile b/finance/p5-Finance-QuoteHist/Makefile
new file mode 100644
index 000000000000..22f8ac00c782
--- /dev/null
+++ b/finance/p5-Finance-QuoteHist/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Finance::QuoteHist
+# Date created: 25 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-QuoteHist
+PORTVERSION= 0.25
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Finance
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Finance::QuoteHist::Yahoo.3 \
+ Finance::QuoteHist.3 \
+ Finance::QuoteHist::MotleyFool.3 \
+ Finance::QuoteHist::SiliconInvestor.3 \
+ Finance::QuoteHist::FinancialWeb.3 \
+ Finance::QuoteHist::Generic.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Finance-QuoteHist/distinfo b/finance/p5-Finance-QuoteHist/distinfo
new file mode 100644
index 000000000000..ece78cf08f8f
--- /dev/null
+++ b/finance/p5-Finance-QuoteHist/distinfo
@@ -0,0 +1 @@
+MD5 (Finance-QuoteHist-0.25.tar.gz) = 3d9ddc60207166a81c8993b24cc26efa
diff --git a/finance/p5-Finance-QuoteHist/pkg-comment b/finance/p5-Finance-QuoteHist/pkg-comment
new file mode 100644
index 000000000000..72b6add79401
--- /dev/null
+++ b/finance/p5-Finance-QuoteHist/pkg-comment
@@ -0,0 +1 @@
+Perl module for fetching historical stock quotes
diff --git a/finance/p5-Finance-QuoteHist/pkg-descr b/finance/p5-Finance-QuoteHist/pkg-descr
new file mode 100644
index 000000000000..a27f7be262b7
--- /dev/null
+++ b/finance/p5-Finance-QuoteHist/pkg-descr
@@ -0,0 +1,9 @@
+Top level aggregator that will select a default lineup of
+site instances from which to retrieve quotes. Other
+than the default lineup, this module behaves identically
+to whichever site-specific module is first in the lineup.
+See below for site-specific modules.
+
+WWW: http://search.cpan.org/search?dist=Finance-QuoteHist
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/finance/p5-Finance-QuoteHist/pkg-plist b/finance/p5-Finance-QuoteHist/pkg-plist
new file mode 100644
index 000000000000..cf6db2ff9ac9
--- /dev/null
+++ b/finance/p5-Finance-QuoteHist/pkg-plist
@@ -0,0 +1,10 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Finance-QuoteHist/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/FinancialWeb.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/Generic.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/MotleyFool.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/SiliconInvestor.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/Yahoo.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Finance 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Finance-QuoteHist 2>/dev/null || true
diff --git a/misc/Makefile b/misc/Makefile
index b238bd087681..8ea090314175 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -217,6 +217,7 @@
SUBDIR += p5-File-Sort
SUBDIR += p5-Finance-Currency-Convert
SUBDIR += p5-Finance-Quote
+ SUBDIR += p5-Finance-QuoteHist
SUBDIR += p5-Geo-Weather
SUBDIR += p5-I18N-Charset
SUBDIR += p5-I18N-LangTags
diff --git a/misc/p5-Finance-QuoteHist/Makefile b/misc/p5-Finance-QuoteHist/Makefile
new file mode 100644
index 000000000000..22f8ac00c782
--- /dev/null
+++ b/misc/p5-Finance-QuoteHist/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Finance::QuoteHist
+# Date created: 25 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-QuoteHist
+PORTVERSION= 0.25
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Finance
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Finance::QuoteHist::Yahoo.3 \
+ Finance::QuoteHist.3 \
+ Finance::QuoteHist::MotleyFool.3 \
+ Finance::QuoteHist::SiliconInvestor.3 \
+ Finance::QuoteHist::FinancialWeb.3 \
+ Finance::QuoteHist::Generic.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Finance-QuoteHist/distinfo b/misc/p5-Finance-QuoteHist/distinfo
new file mode 100644
index 000000000000..ece78cf08f8f
--- /dev/null
+++ b/misc/p5-Finance-QuoteHist/distinfo
@@ -0,0 +1 @@
+MD5 (Finance-QuoteHist-0.25.tar.gz) = 3d9ddc60207166a81c8993b24cc26efa
diff --git a/misc/p5-Finance-QuoteHist/pkg-comment b/misc/p5-Finance-QuoteHist/pkg-comment
new file mode 100644
index 000000000000..72b6add79401
--- /dev/null
+++ b/misc/p5-Finance-QuoteHist/pkg-comment
@@ -0,0 +1 @@
+Perl module for fetching historical stock quotes
diff --git a/misc/p5-Finance-QuoteHist/pkg-descr b/misc/p5-Finance-QuoteHist/pkg-descr
new file mode 100644
index 000000000000..a27f7be262b7
--- /dev/null
+++ b/misc/p5-Finance-QuoteHist/pkg-descr
@@ -0,0 +1,9 @@
+Top level aggregator that will select a default lineup of
+site instances from which to retrieve quotes. Other
+than the default lineup, this module behaves identically
+to whichever site-specific module is first in the lineup.
+See below for site-specific modules.
+
+WWW: http://search.cpan.org/search?dist=Finance-QuoteHist
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/misc/p5-Finance-QuoteHist/pkg-plist b/misc/p5-Finance-QuoteHist/pkg-plist
new file mode 100644
index 000000000000..cf6db2ff9ac9
--- /dev/null
+++ b/misc/p5-Finance-QuoteHist/pkg-plist
@@ -0,0 +1,10 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Finance-QuoteHist/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/FinancialWeb.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/Generic.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/MotleyFool.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/SiliconInvestor.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist/Yahoo.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Finance/QuoteHist 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Finance 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Finance-QuoteHist 2>/dev/null || true