aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/mico/Makefile10
-rw-r--r--devel/mico/pkg-plist2
2 files changed, 7 insertions, 5 deletions
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 29c21be411b7..c3c73cf49cc0 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 July 1998
# Whom: Marc G. Fournier <scrappy@freebsd.org>
#
-# $Id: Makefile,v 1.13 1998/11/05 03:13:23 scrappy Exp $
+# $Id: Makefile,v 1.16 1998/11/11 19:59:34 scrappy Exp $
#
DISTNAME= mico-2.2.3
@@ -13,7 +13,11 @@ MASTER_SITES= http://diamant-atm.vsb.cs.uni-frankfurt.de/~mico/
MAINTAINER= scrappy@freebsd.org
LIB_DEPENDS= gtk.1:${PORTSDIR}/x11-toolkits/gtk \
- tcl80.1:${PORTSDIR}/lang/tcl80
+ tcl80.1:${PORTSDIR}/lang/tcl80 \
+BUILD_DEPENDS= g++28:${PORTSDIR}/lang/gcc28
+
+CC= gcc28
+CXX= g++28
USE_QT= yes
GNU_CONFIGURE= yes
@@ -22,7 +26,7 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/mico
CONFIGURE_ARGS= --with-qt --with-gtk --with-tcl \
- --disable-optimize --disable-shared
+ --disable-optimize --disable-shared --disable-mini-stl
MAN1= idl.1 imr.1 nsadmin.1
MAN5= micorc.5
diff --git a/devel/mico/pkg-plist b/devel/mico/pkg-plist
index ed0229d33941..64876ca99355 100644
--- a/devel/mico/pkg-plist
+++ b/devel/mico/pkg-plist
@@ -6,8 +6,6 @@ bin/mico-ar
bin/mico-c++
bin/mico-cpp
bin/mico-ld
-bin/mico-shc++
-bin/mico-shld
bin/micod
bin/nsadmin
bin/nsd