aboutsummaryrefslogtreecommitdiffstats
path: root/editors/manedit
diff options
context:
space:
mode:
Diffstat (limited to 'editors/manedit')
-rw-r--r--editors/manedit/Makefile9
-rw-r--r--editors/manedit/distinfo2
-rw-r--r--editors/manedit/files/patch-Makefile.FreeBSD (renamed from editors/manedit/files/patch-Makefile)4
-rw-r--r--editors/manedit/files/patch-maneditop.c16
4 files changed, 24 insertions, 7 deletions
diff --git a/editors/manedit/Makefile b/editors/manedit/Makefile
index 588d1fa8731d..9e9afe30851c 100644
--- a/editors/manedit/Makefile
+++ b/editors/manedit/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= manedit
-PORTVERSION= 0.4.j
+PORTVERSION= 0.4.1
CATEGORIES= editors
-MASTER_SITES= ftp://fox.mit.edu/pub/xsw/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.j/j/}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ftp://wolfpack.twu.net/users/wolfpack/ \
+ ftp://fox.mit.edu/pub/xsw/
MAINTAINER= sobomax@FreeBSD.org
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GTK= yes
+MAKEFILE= Makefile.FreeBSD
MAN1= manedit.1
diff --git a/editors/manedit/distinfo b/editors/manedit/distinfo
index 01e457a1fa7f..940562dc5443 100644
--- a/editors/manedit/distinfo
+++ b/editors/manedit/distinfo
@@ -1 +1 @@
-MD5 (manedit0.4j.tgz) = dbd53ee37fcbaa7584d5e8d5abb55973
+MD5 (manedit-0.4.1.tar.bz2) = a5c8abe4edfcaa123fb09b994e3b7583
diff --git a/editors/manedit/files/patch-Makefile b/editors/manedit/files/patch-Makefile.FreeBSD
index 5d30fbe97b91..97aab067067b 100644
--- a/editors/manedit/files/patch-Makefile
+++ b/editors/manedit/files/patch-Makefile.FreeBSD
@@ -1,8 +1,8 @@
$FreeBSD$
---- Makefile 2001/03/20 16:46:26 1.1
-+++ Makefile 2001/03/20 16:46:37
+--- Makefile.FreeBSD 2001/07/17 15:05:11 1.1
++++ Makefile.FreeBSD 2001/07/17 15:05:23
@@ -52,7 +52,7 @@
#
GTK_CONFIG ?= gtk-config
diff --git a/editors/manedit/files/patch-maneditop.c b/editors/manedit/files/patch-maneditop.c
new file mode 100644
index 000000000000..d4b5daedf6d5
--- /dev/null
+++ b/editors/manedit/files/patch-maneditop.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- maneditop.c 2001/07/17 15:14:39 1.1
++++ maneditop.c 2001/07/17 15:16:23
+@@ -242,9 +242,7 @@
+ /* Not exist, so need to create a new one. */
+ rmkdir(
+ tmp_dir_rtn,
+- S_IRUSR | S_IWUSR | S_IXUSR |
+- S_IRGRP | S_IXGRP |
+- S_IROTH | S_IXOTH
++ S_IRUSR | S_IWUSR | S_IXUSR
+ );
+ }
+ }