aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/rtorrent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/rtorrent/Makefile')
-rw-r--r--net-p2p/rtorrent/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index cc80e22b9f51..d2958a2a7341 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -2,15 +2,15 @@
PORTNAME?= rtorrent
PORTVERSION= 0.9.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= BitTorrent Client written in C++
-BUILD_DEPENDS= libtorrent=0.13.2_2:${PORTSDIR}/net-p2p/libtorrent
-RUN_DEPENDS= libtorrent=0.13.2_2:${PORTSDIR}/net-p2p/libtorrent
+BUILD_DEPENDS= libtorrent=0.13.2_3:${PORTSDIR}/net-p2p/libtorrent
+RUN_DEPENDS= libtorrent=0.13.2_3:${PORTSDIR}/net-p2p/libtorrent
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
CONFLICTS= rtorrent-devel-[0-9]*
@@ -34,10 +34,10 @@ XMLRPC_DESC= Compile with xmlrpc-c support
BROKEN= Does not configure on arm
.endif
-# Workaround to build and segfault on > 10.x
+# Workaround to build on >= 10.x
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
-USE_GCC= yes
-LDFLAGS+= -lc++
+CXXFLAGS+= -std=c++11
+EXTRA_PATCHES+= ${FILESDIR}/extra-clang
.endif
.if ${PORT_OPTIONS:MXMLRPC}
@@ -53,6 +53,13 @@ CONFIGURE_ARGS+= --enable-ipv6
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+ @${FIND} ${WRKSRC} \( -name '*.h' -o -name '*.cc' \) -type f \
+ -exec ${REINPLACE_CMD} -e 's/tr1::/std::/g' {} \; \
+ -exec ${REINPLACE_CMD} -e 's/std::std::/std::/g' {} \; \
+ -exec ${REINPLACE_CMD} -e '/namespace tr1/d' {} \; \
+ -exec ${REINPLACE_CMD} -e '/include/s,tr1/,,' {} \;
+.endif
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}