aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile9
-rw-r--r--net-p2p/bitcoin/distinfo4
-rw-r--r--net-p2p/bitcoin/files/patch-Makefile_include_editSedCommands.patch29
-rw-r--r--net-p2p/bitcoin/files/patch-compat-h.patch18
-rw-r--r--net-p2p/bitcoin/files/patch-qt_makefile_am_editSedCommands.patch14
5 files changed, 50 insertions, 24 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 5b20f60b5a7b..becb9f34cdac 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= bitcoin
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.2
CATEGORIES= net-p2p finance
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
+MASTER_SITES= http://vps.robbak.com/distfiles/ \
+ ${MASTER_SITE_LOCAL} \
http://people.freebsd.org/~swills/ \
GH
@@ -21,7 +22,7 @@ OPTIONS_DEFINE= GUI WALLET UPNP QRCODES
OPTIONS_DEFAULT= GUI WALLET QRCODES
GUI_DESC= Build and install the QT4 binary
-WALLET_DESC= Build the binaries with support to create and manage a wallet.
+WALLET_DESC= Build with support to create and manage a wallet
UPNP_DESC= Build with UPNP support
QRCODES_DESC= Build with QR code display
@@ -33,7 +34,7 @@ CONFIGURE_ENV= SSL_LIBS="-lssl" CRYPTO_LIBS="-lcrypto" SSL_CFLAGS="-I/usr/includ
USE_GITHUB= yes
GH_ACCOUNT= bitcoin
GH_PROJECT= bitcoin
-GH_COMMIT= 66a2ae9
+GH_COMMIT= 30a7357
GH_TAGNAME= v${PORTVERSION}
USES= gmake
diff --git a/net-p2p/bitcoin/distinfo b/net-p2p/bitcoin/distinfo
index dd40421b9776..cb8c3813d216 100644
--- a/net-p2p/bitcoin/distinfo
+++ b/net-p2p/bitcoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bitcoin-0.9.1.tar.gz) = aad8a764c0dbfa716437a6a61ac5bf33ba9d210652d3c08b1eb460e3eb76a08a
-SIZE (bitcoin-0.9.1.tar.gz) = 4022647
+SHA256 (bitcoin-0.9.2.tar.gz) = bb54f72f53498883ea9c8bdb9ae340c45fea8d4530f12fbaf34225839c439915
+SIZE (bitcoin-0.9.2.tar.gz) = 5242752
diff --git a/net-p2p/bitcoin/files/patch-Makefile_include_editSedCommands.patch b/net-p2p/bitcoin/files/patch-Makefile_include_editSedCommands.patch
new file mode 100644
index 000000000000..4727e95faeef
--- /dev/null
+++ b/net-p2p/bitcoin/files/patch-Makefile_include_editSedCommands.patch
@@ -0,0 +1,29 @@
+diff --git a/src/Makefile.include b/src/Makefile.include
+index 2fc6cd7..cdd16f5 100644
+--- a/src/Makefile.include
++++ src/Makefile.include
+@@ -40,18 +40,18 @@ $(LIBBITCOINQT):
+ ui_%.h: %.ui
+ @test -d $(abs_builddir)/$(@D) || $(MKDIR_P) $(abs_builddir)/$(@D)
+ @test -f $(UIC) && QT_SELECT=$(QT_SELECT) $(UIC) -o $(abs_builddir)/$@ $(abs_srcdir)/$< || echo error: could not build $(abs_builddir)/$@
+- $(SED) -e '/^\*\*.*Created:/d' $(abs_builddir)/$@ > $(abs_builddir)/$@.n && mv $(abs_builddir)/$@{.n,}
+- $(SED) -e '/^\*\*.*by:/d' $(abs_builddir)/$@ > $(abs_builddir)/$@.n && mv $(abs_builddir)/$@{.n,}
++ $(SED) -e '/^\*\*.*Created:/d' $(abs_builddir)/$@ > $(abs_builddir)/$@.n && mv $(abs_builddir)/$@.n $(abs_builddir)/$@
++ $(SED) -e '/^\*\*.*by:/d' $(abs_builddir)/$@ > $(abs_builddir)/$@.n && mv $(abs_builddir)/$@.n $(abs_builddir)/$@
+
+ %.moc: %.cpp
+ QT_SELECT=$(QT_SELECT) $(MOC) $(QT_INCLUDES) $(MOC_DEFS) -o $@ $<
+- $(SED) -e '/^\*\*.*Created:/d' $@ > $@.n && mv $@{.n,}
+- $(SED) -e '/^\*\*.*by:/d' $@ > $@.n && mv $@{.n,}
++ $(SED) -e '/^\*\*.*Created:/d' $@ > $@.n && mv $@.n $(abs_builddir)/$@
++ $(SED) -e '/^\*\*.*by:/d' $@ > $@.n && mv $@.n $(abs_builddir)/$@
+
+ moc_%.cpp: %.h
+ QT_SELECT=$(QT_SELECT) $(MOC) $(QT_INCLUDES) $(MOC_DEFS) -o $@ $<
+- $(SED) -e '/^\*\*.*Created:/d' $@ > $@.n && mv $@{.n,}
+- $(SED) -e '/^\*\*.*by:/d' $@ > $@.n && mv $@{.n,}
++ $(SED) -e '/^\*\*.*Created:/d' $@ > $@.n && mv $@.n $(abs_builddir)/$@
++ $(SED) -e '/^\*\*.*by:/d' $@ > $@.n && mv $@.n $(abs_builddir)/$@
+
+ %.qm: %.ts
+ @test -d $(abs_builddir)/$(@D) || $(MKDIR_P) $(abs_builddir)/$(@D)
diff --git a/net-p2p/bitcoin/files/patch-compat-h.patch b/net-p2p/bitcoin/files/patch-compat-h.patch
deleted file mode 100644
index 101a8abcdb15..000000000000
--- a/net-p2p/bitcoin/files/patch-compat-h.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/compat.h.orig 2014-03-31 19:12:15.000000000 +1000
-+++ src/compat.h 2014-03-31 19:12:39.000000000 +1000
-@@ -30,6 +30,7 @@
- #else
- #include <sys/types.h>
- #include <arpa/inet.h>
-+#include <sys/socket.h>
- #include <ifaddrs.h>
- #include <limits.h>
- #include <net/if.h>
-@@ -37,7 +38,6 @@
- #include <netinet/in.h>
- #include <sys/fcntl.h>
- #include <sys/mman.h>
--#include <sys/socket.h>
- #include <unistd.h>
- #endif
-
diff --git a/net-p2p/bitcoin/files/patch-qt_makefile_am_editSedCommands.patch b/net-p2p/bitcoin/files/patch-qt_makefile_am_editSedCommands.patch
new file mode 100644
index 000000000000..8a72618f8aec
--- /dev/null
+++ b/net-p2p/bitcoin/files/patch-qt_makefile_am_editSedCommands.patch
@@ -0,0 +1,14 @@
+diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
+index 648971b..97b2ec4 100644
+--- a/src/qt/Makefile.am
++++ src/qt/Makefile.am
+@@ -373,7 +373,7 @@ translate: bitcoinstrings.cpp $(QT_FORMS_UI) $(QT_FORMS_UI) $(BITCOIN_QT_CPP) $(
+ $(QT_QRC_CPP): $(QT_QRC) $(QT_QM) $(QT_FORMS_H) $(RES_ICONS) $(RES_IMAGES) $(RES_MOVIES) $(PROTOBUF_H)
+ @cd $(abs_srcdir); test -f $(RCC) && QT_SELECT=$(QT_SELECT) $(RCC) -name bitcoin -o $(abs_builddir)/$@ $< || \
+ echo error: could not build $@
+- $(SED) -e '/^\*\*.*Created:/d' $@ > $@.n && mv $@{.n,}
+- $(SED) -e '/^\*\*.*by:/d' $@ > $@.n && mv $@{.n,}
++ $(SED) -e '/^\*\*.*Created:/d' $@ > $@.n && mv $@.n $@
++ $(SED) -e '/^\*\*.*by:/d' $@ > $@.n && mv $@.n $@
+
+ CLEANFILES = $(BUILT_SOURCES) $(QT_QM) $(QT_FORMS_H) *.gcda *.gcno