aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-transifex-client/Makefile9
-rw-r--r--textproc/py-transifex-client/distinfo5
-rw-r--r--textproc/py-transifex-client/files/patch-requirements.txt11
3 files changed, 20 insertions, 5 deletions
diff --git a/textproc/py-transifex-client/Makefile b/textproc/py-transifex-client/Makefile
index ce4845ebd26c..d5b98cb234de 100644
--- a/textproc/py-transifex-client/Makefile
+++ b/textproc/py-transifex-client/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= transifex-client
-PORTVERSION= 0.11
-PORTREVISION= 1
+PORTVERSION= 0.13.6
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +13,11 @@ COMMENT= Command line interface for Transifex
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${PY_FLAVOR} # <1.25
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}requests>=2.19.1:www/py-requests@${PY_FLAVOR} # <3.0.0
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-slugify>=1.26.0:textproc/py-python-slugify@${PY_FLAVOR}
+
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
USES= python
diff --git a/textproc/py-transifex-client/distinfo b/textproc/py-transifex-client/distinfo
index 0048e54f5ac5..b5a19f753d86 100644
--- a/textproc/py-transifex-client/distinfo
+++ b/textproc/py-transifex-client/distinfo
@@ -1,2 +1,3 @@
-SHA256 (transifex-client-0.11.tar.gz) = d17abe4aee1fe45240a57ed43dc6e2f170c4e7f3037d410cfd4860402af2264d
-SIZE (transifex-client-0.11.tar.gz) = 181130
+TIMESTAMP = 1556208168
+SHA256 (transifex-client-0.13.6.tar.gz) = 88072f466627aabc55ae058314c70547e111d2d2e0cc91b1e327d65969bed778
+SIZE (transifex-client-0.13.6.tar.gz) = 259444
diff --git a/textproc/py-transifex-client/files/patch-requirements.txt b/textproc/py-transifex-client/files/patch-requirements.txt
new file mode 100644
index 000000000000..c5a44743f11c
--- /dev/null
+++ b/textproc/py-transifex-client/files/patch-requirements.txt
@@ -0,0 +1,11 @@
+--- requirements.txt.orig 2019-04-25 16:11:57 UTC
++++ requirements.txt
+@@ -1,4 +1,4 @@
+-urllib3<1.24
+-six==1.11.0
+-requests>=2.19.1,<3.0.0
+-python-slugify==1.2.6
++urllib3<1.25
++six>=1.11.0
++requests>=2.19.1
++python-slugify>=1.2.6