aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/galeon2/Makefile')
-rw-r--r--www/galeon2/Makefile47
1 files changed, 25 insertions, 22 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index d1bf64c38695..aa04675b5066 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= galeon2
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 1.3.2
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
@@ -20,26 +19,30 @@ BUILD_DEPENDS= ${X11BASE}/include/mozilla${HEADERS_SUFX}/gtkembedmoz/gtkmozembed
LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.2"
+MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.3b"
-.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla-gtk2
-HEADERS_SUFX=
-.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
-MOZILLA= ${WITH_MOZILLA}
+MOZILLA= mozilla-devel-gtk2
HEADERS_SUFX= -devel
-MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
-.else
-MOZILLA= mozilla
-HEADERS_SUFX=
-.endif
-.endif
+
+#.if !defined(WITH_MOZILLA)
+#MOZILLA= mozilla-gtk2
+#HEADERS_SUFX=
+#.else
+#.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+#MOZILLA= ${WITH_MOZILLA}
+#HEADERS_SUFX= -devel
+#MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
+#.else
+#MOZILLA= mozilla
+#HEADERS_SUFX=
+#.endif
+#.endif
USE_X_PREFIX= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack
USE_LIBTOOL= yes
+USE_GMAKE= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUFX}" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}" \
@@ -59,13 +62,13 @@ MAN1= galeon.1
CONFIGURE_ARGS+= --disable-werror
.endif
-post-extract:
- @${ECHO_MSG}
- @${ECHO_MSG} " By default the port uses www/mozilla-gtk2 for html rendering, but you can"
- @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
- @${ECHO_MSG}
- @${ECHO_MSG} " mozilla-devel-gtk2 "
- @${ECHO_MSG}
+#post-extract:
+# @${ECHO_MSG}
+# @${ECHO_MSG} " By default the port uses www/mozilla-gtk2 for html rendering, but you can"
+# @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+# @${ECHO_MSG}
+# @${ECHO_MSG} " mozilla-devel-gtk2 "
+# @${ECHO_MSG}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \