aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql80-server/Makefile
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>1997-04-09 23:30:55 +0800
committerpeter <peter@FreeBSD.org>1997-04-09 23:30:55 +0800
commit68cf7d61c47d67134a99e4829c93760d25660cce (patch)
tree7ca923fe6ce57c5f5bbe2226137564dec12e34bd /databases/postgresql80-server/Makefile
parent48ab14a7fb9f6119aeba57a860dc02363049e1a7 (diff)
downloadfreebsd-ports-graphics-68cf7d61c47d67134a99e4829c93760d25660cce.tar.gz
freebsd-ports-graphics-68cf7d61c47d67134a99e4829c93760d25660cce.tar.zst
freebsd-ports-graphics-68cf7d61c47d67134a99e4829c93760d25660cce.zip
revive postgres95 as postgresql with full history as requested by Satoshi.
Diffstat (limited to 'databases/postgresql80-server/Makefile')
-rw-r--r--databases/postgresql80-server/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/databases/postgresql80-server/Makefile b/databases/postgresql80-server/Makefile
new file mode 100644
index 00000000000..8fe4bc783e4
--- /dev/null
+++ b/databases/postgresql80-server/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: postgres95
+# Version required: 1.08
+# Date created: Oct 9 1996
+# Whom: Matthew Stein <matt@bdd.net>
+#
+# $Id: Makefile,v 1.7 1997/04/02 09:15:26 scrappy Exp $
+
+PKGNAME= postgres95-1.08
+CATEGORIES= databases
+MASTER_SITES= ftp://ftp.PostgreSQL.org/pub/oldstuff/ \
+ ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/oldstuff/ \
+ ftp://postgres95.vnet.net:/pub/postgres95/oldstuff/ \
+ ftp://ftp.itm.tu-clausthal.de/pub/mirrors/postgres95/oldstuff/ \
+ ftp://rocker.sch.bme.hu/pub/mirrors/postgreSQL/oldstuff/ \
+ ftp://ftp.luga.or.at/pub/postgres95/
+
+DISTFILES= postgres95-1.08.tar.gz \
+ flex-2.5.2.tgz
+
+MAINTAINER= matt@bdd.net
+
+NO_PACKAGE= "Requires postgres uid"
+WRKSRC= ${WRKDIR}/postgres95/src/
+MAKE_ENV+= WRKSRC=${WRKSRC} WRKDIR=${WRKDIR}
+USE_GMAKE= yes
+
+pre-fetch:
+.if exists(/usr/lib/libc.so.3.0)
+ @ ${CAT} ${FILESDIR}/md5.libc30 ${FILESDIR}/md5.all > ${FILESDIR}/md5
+MASTER_SITES+= ftp://eddie.cis.uoguelph.ca/pub/flex/ \
+ ftp://ftp.teamos2.org/pub/flex/ \
+ ftp://ftp.bdd.net/pub/flex/
+.else
+ @ ${CAT} ${FILESDIR}/md5.libc22 ${FILESDIR}/md5.all > ${FILESDIR}/md5
+MASTER_SITES+= ftp://ftp.freebsd.org/pub/FreeBSD/packages-2.1.5/All/
+.endif
+
+pre-install:
+ @ ${MKDIR} ${PREFIX}/postgres95
+ @ ${SETENV} ${MAKE_ENV} /usr/bin/perl ${SCRIPTDIR}/createuser
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in ${PREFIX}/postgres95/man/man[135l]/*; do \
+ gzip -9nf $$file ; \
+ done
+.endif
+ @ chown -R postgres:postgres ${PREFIX}/postgres95
+ @ echo 'Initializing Postgres95 Databases - this may take a few minutes...'
+ @ su -l postgres -c ${PREFIX}/postgres95/bin/initdb
+ @ ${MKDIR} ${PREFIX}/etc/rc.d
+ @ if [ ! -f ${PREFIX}/etc/rc.d/postgres95.sh ]; then \
+ echo "Installing ${PREFIX}/etc/rc.d/postgres95.sh startup file."; \
+ echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/postgres95.sh; \
+ echo "[ -x ${PREFIX}/postgres95/bin/postmaster ] && su -l postgres -c ${PREFIX}/postgres95/bin/postmaster & && echo -n ' postgres95'" >> ${PREFIX}/etc/rc.d/postgres95.sh; \
+ chmod 751 ${PREFIX}/etc/rc.d/postgres95.sh; \
+ fi
+ @ ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/postgres95
+.ifndef(BATCH)
+ @ more -e ${FILESDIR}/post-install-notes
+.endif
+
+pre-clean:
+ @ ${RM} -f ${FILESDIR}/md5
+
+.include <bsd.port.mk>