aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pyglet/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-30 22:24:19 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-30 22:24:19 +0800
commit95404c60b7084a37e009ded54acb921ace724aaf (patch)
tree3fc74e2a8eef00d4ace21daaa3e8e6cc465dc4aa /graphics/py-pyglet/Makefile
parentf33c898c97fbf5ece1dd2baf2a045056e920ec21 (diff)
downloadfreebsd-ports-graphics-95404c60b7084a37e009ded54acb921ace724aaf.tar.gz
freebsd-ports-graphics-95404c60b7084a37e009ded54acb921ace724aaf.tar.zst
freebsd-ports-graphics-95404c60b7084a37e009ded54acb921ace724aaf.zip
- Revert 332027: please don't touch my ports
Diffstat (limited to 'graphics/py-pyglet/Makefile')
-rw-r--r--graphics/py-pyglet/Makefile57
1 files changed, 12 insertions, 45 deletions
diff --git a/graphics/py-pyglet/Makefile b/graphics/py-pyglet/Makefile
index 2dcc95e40c7..cca78f040e6 100644
--- a/graphics/py-pyglet/Makefile
+++ b/graphics/py-pyglet/Makefile
@@ -3,7 +3,6 @@
PORTNAME= pyglet
PORTVERSION= 1.1.4
-PORTREVISION= 1
CATEGORIES= graphics multimedia x11-toolkits python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Cross-platform windowing and multimedia library for Python
-LICENSE= BSD
-
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= avbin>=0:${PORTSDIR}/multimedia/avbin
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -23,52 +19,23 @@ USE_GL= gl glu
USE_OPENAL= al
PORTDOCS= *
-
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= CHANGELOG NOTICE README
-
-DOCSRCDIR2= ${WRKSRC}/doc
-DOCSDIR2= ${DOCSDIR}/doc
-
PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS
-OPTIONS_GROUP= DEMOS_EXAMPLES
-OPTIONS_GROUP_DEMOS_EXAMPLES= DEMOS EXAMPLES
-OPTIONS_DEFAULT= DEMOS
-DEMOS_DESC= Install Demos programs, requires EXAMPLES
-
-OPTIONS_SUB= yes
-
+NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDEMOS} && ${PORT_OPTIONS:MEXAMPLES}
-SUB_FILES+= pkg-message pyglet-astraea pyglet-noisy
-DESKTOP_ENTRIES+="Astraea" "A sprite-based game loosely based on the classic Asteroids" "pyglet-astraea" \
- "pyglet-astraea" "Game;ArcadeGame;" false
-DESKTOP_ENTRIES+="Noisy" "Bounces balls around a window and plays noises" "pyglet-noisy" \
- "pyglet-noisy" "Game;ArcadeGame;" false
-# Sound Space not works, needs working AVbin
+.if ${ARCH} != "i386"
+IGNORE= crashes or doesn't work on !i386
.endif
-post-patch:
- @${FIND} ${WRKSRC} -name '*.py' | ${XARGS} \
- ${REINPLACE_CMD} -e 's|/usr/include|${PREFIX}/include|g'
- @${FIND} ${WRKSRC} -name "*.bak" -delete
-
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
- @${MKDIR} ${STAGEDIR}${DOCSDIR2}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR2})
-
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
-
-.if ${PORT_OPTIONS:MDEMOS} && ${PORT_OPTIONS:MEXAMPLES}
- ${INSTALL_SCRIPT} ${WRKDIR}/pyglet-astraea ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKDIR}/pyglet-noisy ${STAGEDIR}${PREFIX}/bin/
- ${LN} -sf ${EXAMPLESDIR}/astraea/res/asteroid2.png ${STAGEDIR}${PREFIX}/share/pixmaps/pyglet-astraea.png
- ${LN} -sf ${EXAMPLESDIR}/noisy/ball.png ${STAGEDIR}${PREFIX}/share/pixmaps/pyglet-noisy.png
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>