aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-06-25 09:35:17 +0800
committernork <nork@FreeBSD.org>2003-06-25 09:35:17 +0800
commit18bfbde0cc6f6d08a4e73fc598aa2cc995038bfc (patch)
tree96e875dfb80630bb7052a5ba008b9159a4426856 /lang/php4/Makefile
parenteb83f9637416f67115ba1cd2b383300c0546e7ca (diff)
downloadfreebsd-ports-graphics-18bfbde0cc6f6d08a4e73fc598aa2cc995038bfc.tar.gz
freebsd-ports-graphics-18bfbde0cc6f6d08a4e73fc598aa2cc995038bfc.tar.zst
freebsd-ports-graphics-18bfbde0cc6f6d08a4e73fc598aa2cc995038bfc.zip
Improve SNMP support (fix openssl dependency and add net-snmp5 support).
PR: ports/53687 Submitted by: Alex Dupre <sysadmin@alexdupre.com> (maintainer)
Diffstat (limited to 'lang/php4/Makefile')
-rw-r--r--lang/php4/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index ccf3d0604ee..95d650c4234 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -202,10 +202,14 @@ WITH_DOMXML= yes
WITH_ICONV_DEP= yes
.endif
-.if defined(WITH_SNMP) || defined(WITH_POSTGRESQL)
+.if defined(WITH_POSTGRESQL)
WITH_OPENSSL_DEP= yes
.endif
+.if defined(WITH_SNMP)
+WITH_OPENSSL= yes
+.endif
+
.if defined(WITH_WDDX) || defined(WITH_XMLRPC) || defined(WITH_XSLT)
WITH_XML_DEP= yes
.endif
@@ -484,7 +488,11 @@ CONFIGURE_ARGS+=--enable-shmop
.endif
.if defined(WITH_SNMP)
+.if exists(${LOCALBASE}/lib/libsnmp.so.4)
LIB_DEPENDS+= snmp.4:${PORTSDIR}/net/net-snmp4
+.else
+LIB_DEPENDS+= netsnmp.5:${PORTSDIR}/net/net-snmp
+.endif
CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} --enable-ucd-snmp-hack
.endif