aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
committermarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
commit264cdcd7a6bead083ad3106f86fb0744dedb57f5 (patch)
tree1a018b24ee2f215bd6917d868f44c8f904dda8bf /lang/php4/Makefile
parent8ea77b67d66da4a3b085568e881b2aab1f559c32 (diff)
downloadfreebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.gz
freebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.zst
freebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.zip
Use the new Apache bits from bsd.port.mk.
Submitted by: dinoex
Diffstat (limited to 'lang/php4/Makefile')
-rw-r--r--lang/php4/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 7223038f6c8..fbcb8abc0cb 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -522,21 +522,20 @@ CONFIGURE_ARGS+=--with-zlib=yes
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_APACHE)
-APXS?= ${LOCALBASE}/sbin/apxs
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
.endif
.if defined(WITH_APACHE2)
-APACHE_PORT?= ${PORTSDIR}/www/apache2
+APACHE_PORT?= www/apache2
CONFIGURE_ARGS+=--with-apxs2=${APXS}
SAPI_FILE= libexec/apache2/libphp4.so
.else
-APACHE_PORT?= ${PORTSDIR}/www/apache13
+APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
SAPI_FILE= libexec/apache/libphp4.so
.endif
-BUILD_DEPENDS+= ${APXS}:${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE_PORT}
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
PLIST_SUB+= SAPI_FILE=${SAPI_FILE} \