aboutsummaryrefslogtreecommitdiffstats
path: root/math/sage/Makefile
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2012-01-31 22:02:24 +0800
committerstephen <stephen@FreeBSD.org>2012-01-31 22:02:24 +0800
commitedf496a9874c092dae25cd8431db680a3e1bca63 (patch)
tree18f61dd7ea34c7b42ceaecad4bc81ac418590c01 /math/sage/Makefile
parent407a18c85e7d3ca79719d098c0e6ed828a768761 (diff)
downloadfreebsd-ports-graphics-edf496a9874c092dae25cd8431db680a3e1bca63.tar.gz
freebsd-ports-graphics-edf496a9874c092dae25cd8431db680a3e1bca63.tar.zst
freebsd-ports-graphics-edf496a9874c092dae25cd8431db680a3e1bca63.zip
- Added test target.
Suggested by: bf (private email)
Diffstat (limited to 'math/sage/Makefile')
-rw-r--r--math/sage/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 111e2074063..4348f5aeb5d 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -100,6 +100,12 @@ IGNORE= POSIX semaphores are required, and the support only works in FreeBSD 7-
MAKE_ENV+= MAKE="make -j${MAKE_JOBS_NUMBER}"
.endif
+check regression-test test: build
+ @${ECHO_MSG} This test can also be performed after installation by typing \"sage --testall\".
+ @${ECHO_MSG}
+ cd ${WRKSRC}; local/bin/sage-starts; \
+ ${LOCALBASE}/bin/bash -c ". local/bin/sage-env && sage-maketest"
+
INSTALL_SAGE_DIR= ${PREFIX}/${PORTNAME}-${PORTVERSION}
do-install:
cd ${WRKDIR} && ${FIND} -s ${WRKSRC} | ${SED} -e 's#${WRKDIR}/##' | \