aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php3/Makefile
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-03-05 02:27:57 +0800
committerdirk <dirk@FreeBSD.org>2001-03-05 02:27:57 +0800
commit00b6f48f525b28ad0c983c1e99ab50d59e984a9d (patch)
tree49d10c639731429a26a1a377966d2f1646402ae5 /www/mod_php3/Makefile
parent629b20c24ac35ea132b50e9c8dcf740c7fac06f6 (diff)
downloadfreebsd-ports-graphics-00b6f48f525b28ad0c983c1e99ab50d59e984a9d.tar.gz
freebsd-ports-graphics-00b6f48f525b28ad0c983c1e99ab50d59e984a9d.tar.zst
freebsd-ports-graphics-00b6f48f525b28ad0c983c1e99ab50d59e984a9d.zip
Add hooks for a standalone php3 slave port.
Diffstat (limited to 'www/mod_php3/Makefile')
-rw-r--r--www/mod_php3/Makefile30
1 files changed, 25 insertions, 5 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 731c13d41ab..51375fc6d36 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
#
-PORTNAME= mod_php3
+PORTNAME?= mod_php3
PORTVERSION= 3.0.18
-CATEGORIES= www
+CATEGORIES?= www
MASTER_SITES= ftp://ftp.php.net/pub/${PHP_DISTDIR}/ \
http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
@@ -22,23 +22,35 @@ DISTNAME= php-${PORTVERSION}
MAINTAINER= dirk@FreeBSD.org
+.if !defined(STANDALONE)
BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+.endif
PHP_DISTDIR= distributions
+SLAVEDIRS= lang/php3
+
GNU_CONFIGURE= yes
+
+.if defined(STANDALONE)
+CONFIGURE_ARGS= --with-config-file-path=${PREFIX}/etc/php.standalone
+.else
CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
- --enable-versioning \
+ --with-config-file-path=${PREFIX}/etc
+.endif
+
+CONFIGURE_ARGS+=--enable-versioning \
--with-system-regex \
- --with-config-file-path=${PREFIX}/etc \
--disable-debug \
--enable-track-vars \
--without-gd
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ CAT="${CAT}" \
+ REALCURDIR="${.CURDIR}"
AP_LIBEXEC= ${PREFIX}/libexec/apache
@@ -50,9 +62,14 @@ pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.php
post-install:
+.if !defined(STANDALONE)
@${ECHO} "Restarting Apache..."
@${PREFIX}/sbin/apachectl restart
@${INSTALL_DATA} ${WRKSRC}/php3.ini-dist ${PREFIX}/etc
+.else
+ @${MKDIR} ${PREFIX}/etc/php.standalone
+ @${INSTALL_DATA} ${WRKSRC}/php3.ini-dist ${PREFIX}/etc/php.standalone
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${PHPDOCDIR}
@@ -60,6 +77,8 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/$i ${PHPDOCDIR}
.endfor
.endif
+
+.if !defined(STANDALONE)
@${ECHO} "*****************************************************************************"
@${ECHO} "Make sure the mime.types are connected to the php module properly and"
@${ECHO} "index.php3 is part of your DirectoryIndex."
@@ -72,6 +91,7 @@ post-install:
@${ECHO} "AddType application/x-httpd-php3-source .php3s"
@${ECHO} "[...]"
@${ECHO} "*****************************************************************************"
+.endif
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc