aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php3/Makefile
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-08-27 05:18:15 +0800
committerdirk <dirk@FreeBSD.org>1999-08-27 05:18:15 +0800
commit642bb4d7aabda24f5b34da03397b4c73b5930691 (patch)
tree22c75f57e52781adfeda3a74780f6523b42ea1e3 /www/mod_php3/Makefile
parentba7b077fe34722d0e489dde6c0f191402f303db6 (diff)
downloadfreebsd-ports-graphics-642bb4d7aabda24f5b34da03397b4c73b5930691.tar.gz
freebsd-ports-graphics-642bb4d7aabda24f5b34da03397b4c73b5930691.tar.zst
freebsd-ports-graphics-642bb4d7aabda24f5b34da03397b4c73b5930691.zip
Fix two minor problems:
- if e. g. a "make BATCH=yes fetch" was followed by a "make all" the config menu popped up. - if gd was installed but gd support was not checked in the config menu, php was compiled with gd support nevertheless. (There may be other support options having the same behavior. I haven't checked all, yet.)
Diffstat (limited to 'www/mod_php3/Makefile')
-rw-r--r--www/mod_php3/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index c8aadd70a12..40a7801757f 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -3,7 +3,7 @@
# Date created: So 21 Jun 1998 16:09:39 CEST
# Whom: Stefan Herrmann <stefan@asterix.webaffairs.net>
#
-# $Id: Makefile,v 1.88 1999/08/22 19:00:27 mharo Exp $
+# $Id: Makefile,v 1.89 1999/08/26 09:24:16 dirk Exp $
#
DISTNAME= apache_${VERSION_APACHE}
@@ -87,7 +87,8 @@ CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
.endif
CONFIGURE_ENV= OPTIM='${OPTIM}' LIBS='-L${PREFIX}/lib'
-SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}"
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ TOUCH="${TOUCH}"
INSTALL_TARGET= install-quiet
@@ -103,12 +104,11 @@ PHP_CONF_ARGS= --prefix=${PREFIX} \
--with-apache=${WRKSRC} \
--with-config-file-path=${PREFIX}/etc \
--disable-debug \
- --enable-track-vars
+ --enable-track-vars \
+ --without-gd
-.if !defined(BATCH)
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.php
-.endif
post-extract:
@${LN} -s php-${VERSION_PHP} ${WRKDIR}/php