aboutsummaryrefslogtreecommitdiffstats
path: root/devel/eiffelstudio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/eiffelstudio/Makefile')
-rw-r--r--devel/eiffelstudio/Makefile32
1 files changed, 24 insertions, 8 deletions
diff --git a/devel/eiffelstudio/Makefile b/devel/eiffelstudio/Makefile
index f7e79eca62d..4aa98934f66 100644
--- a/devel/eiffelstudio/Makefile
+++ b/devel/eiffelstudio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eiffelstudio
PORTVERSION= 5.7
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/EiffelStudio%20${PORTVERSION}/Build%2064493/
DISTNAME= Eiffel${PORTVERSION:S/.//}_gpl_64493-freebsd-${EIFFEL_ARCH}
@@ -11,13 +11,10 @@ DISTNAME= Eiffel${PORTVERSION:S/.//}_gpl_64493-freebsd-${EIFFEL_ARCH}
MAINTAINER= ports@FreeBSD.org
COMMENT= Complete Integrated Development Environment for Eiffel
-LIB_DEPENDS= libc.so.6:misc/compat6x
-
USES= shebangfix
SHEBANG_FILES= library/event/example/gen_action_sequences \
library/vision2/interface/events/gen_action_sequences \
library/vision2/interface/events/gen_event_sensitive
-USE_GNOME= gtk20
NO_BUILD= yes
WRKSRC= ${WRKDIR}/Eiffel${PORTVERSION:S/.//}
@@ -32,7 +29,7 @@ SUB_LIST+= EIFFEL_HOST="${EIFFEL_HOST}"
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Try native version first, then try i386 compatibility framework.
.for arch in ${ARCH}
@@ -44,17 +41,36 @@ EIFFEL_ARCH= x86
. endif
.endfor
+.if ${EIFFEL_ARCH} == x86
+LIB_DEPENDS= libc.so.5:misc/compat5x
+USE_GNOME= gtk20 pangox-compat
+USE_XORG= x11 xcursor xext xft xi xinerama xrandr xrender xtst
+.elif ${EIFFEL_ARCH} == x86_64
+LIB_DEPENDS= libc.so.6:misc/compat6x
+USE_GNOME= gtk20
+USE_XORG= x11 xtst
+.endif
+
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${CP} -R ${WRKSRC}/* ${STAGEDIR}${DATADIR}
${FIND} ${STAGEDIR}${DATADIR} -type d -empty -delete
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-.for f in libgtk-x11-2.0.so.600 libgdk-x11-2.0.so.600 libatk-1.0.so.600 \
- libgdk_pixbuf-2.0.so.600 libpangoxft-1.0.so.800 libpangox-1.0.so.800 \
+.if ${EIFFEL_ARCH} == x86
+.for f in libgtk-x11-2.0.so.400 libgdk-x11-2.0.so.400 libatk-1.0.so.600 \
+ libgdk_pixbuf-2.0.so.400 libpangoxft-1.0.so.399 libpangox-1.0.so.399 \
+ libpango-1.0.so.399 libgobject-2.0.so.400 libgmodule-2.0.so.400 \
+ libgthread-2.0.so.400 libglib-2.0.so.400 libfreetype.so.9 libiconv.so.3
+ ${LN} -sf ${LOCALBASE}/lib/${f:C/\.[[:digit:]]+$//} \
+ ${STAGEDIR}${DATADIR}/studio/spec/${EIFFEL_HOST}/lib/${f}
+.endfor
+.elif ${EIFFEL_ARCH} == x86_64
+.for f in libgtk-x11-2.0.so.600 libgdk-x11-2.0.so.600 libgdk_pixbuf-2.0.so.600 \
libpango-1.0.so.800 libgobject-2.0.so.600 libgmodule-2.0.so.600 \
libgthread-2.0.so.600 libglib-2.0.so.600
${LN} -sf ${LOCALBASE}/lib/${f:C/\.[[:digit:]]+$//} \
${STAGEDIR}${DATADIR}/studio/spec/${EIFFEL_HOST}/lib/${f}
.endfor
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>