aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-pyglet
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-pyglet')
-rw-r--r--graphics/py-pyglet/Makefile57
-rw-r--r--graphics/py-pyglet/files/pkg-message.in26
-rw-r--r--graphics/py-pyglet/files/pyglet-astraea.in7
-rw-r--r--graphics/py-pyglet/files/pyglet-noisy.in7
-rw-r--r--graphics/py-pyglet/pkg-plist4
5 files changed, 12 insertions, 89 deletions
diff --git a/graphics/py-pyglet/Makefile b/graphics/py-pyglet/Makefile
index 2dcc95e40c7..cca78f040e6 100644
--- a/graphics/py-pyglet/Makefile
+++ b/graphics/py-pyglet/Makefile
@@ -3,7 +3,6 @@
PORTNAME= pyglet
PORTVERSION= 1.1.4
-PORTREVISION= 1
CATEGORIES= graphics multimedia x11-toolkits python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Cross-platform windowing and multimedia library for Python
-LICENSE= BSD
-
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= avbin>=0:${PORTSDIR}/multimedia/avbin
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -23,52 +19,23 @@ USE_GL= gl glu
USE_OPENAL= al
PORTDOCS= *
-
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= CHANGELOG NOTICE README
-
-DOCSRCDIR2= ${WRKSRC}/doc
-DOCSDIR2= ${DOCSDIR}/doc
-
PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS
-OPTIONS_GROUP= DEMOS_EXAMPLES
-OPTIONS_GROUP_DEMOS_EXAMPLES= DEMOS EXAMPLES
-OPTIONS_DEFAULT= DEMOS
-DEMOS_DESC= Install Demos programs, requires EXAMPLES
-
-OPTIONS_SUB= yes
-
+NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDEMOS} && ${PORT_OPTIONS:MEXAMPLES}
-SUB_FILES+= pkg-message pyglet-astraea pyglet-noisy
-DESKTOP_ENTRIES+="Astraea" "A sprite-based game loosely based on the classic Asteroids" "pyglet-astraea" \
- "pyglet-astraea" "Game;ArcadeGame;" false
-DESKTOP_ENTRIES+="Noisy" "Bounces balls around a window and plays noises" "pyglet-noisy" \
- "pyglet-noisy" "Game;ArcadeGame;" false
-# Sound Space not works, needs working AVbin
+.if ${ARCH} != "i386"
+IGNORE= crashes or doesn't work on !i386
.endif
-post-patch:
- @${FIND} ${WRKSRC} -name '*.py' | ${XARGS} \
- ${REINPLACE_CMD} -e 's|/usr/include|${PREFIX}/include|g'
- @${FIND} ${WRKSRC} -name "*.bak" -delete
-
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
- @${MKDIR} ${STAGEDIR}${DOCSDIR2}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR2})
-
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
-
-.if ${PORT_OPTIONS:MDEMOS} && ${PORT_OPTIONS:MEXAMPLES}
- ${INSTALL_SCRIPT} ${WRKDIR}/pyglet-astraea ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKDIR}/pyglet-noisy ${STAGEDIR}${PREFIX}/bin/
- ${LN} -sf ${EXAMPLESDIR}/astraea/res/asteroid2.png ${STAGEDIR}${PREFIX}/share/pixmaps/pyglet-astraea.png
- ${LN} -sf ${EXAMPLESDIR}/noisy/ball.png ${STAGEDIR}${PREFIX}/share/pixmaps/pyglet-noisy.png
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/py-pyglet/files/pkg-message.in b/graphics/py-pyglet/files/pkg-message.in
deleted file mode 100644
index fff608d1ba3..00000000000
--- a/graphics/py-pyglet/files/pkg-message.in
+++ /dev/null
@@ -1,26 +0,0 @@
-===============================================================================
-
-pyglet has been installed.
-
-pyglet have more Demos (Games)
-
-Astraea, Noisy
-
-
-You can use executable
-
- %%LOCALBASE%%/bin/pyglet-astraea
-
- %%LOCALBASE%%/bin/pyglet-noisy
-
-
-Or can use desktop files
-
- %%LOCALBASE%%/share/applications/pyglet-astraea.desktop
-
- %%LOCALBASE%%/share/applications/pyglet-noisy.desktop
-
-
-Have fun!
-
-===============================================================================
diff --git a/graphics/py-pyglet/files/pyglet-astraea.in b/graphics/py-pyglet/files/pyglet-astraea.in
deleted file mode 100644
index 627024ab0ed..00000000000
--- a/graphics/py-pyglet/files/pyglet-astraea.in
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-#
-# # $FreeBSD$
-#
-
-cd "%%EXAMPLESDIR%%/astraea"
-exec /usr/bin/env python ./astraea.py "${@}"
diff --git a/graphics/py-pyglet/files/pyglet-noisy.in b/graphics/py-pyglet/files/pyglet-noisy.in
deleted file mode 100644
index 6412cadbb26..00000000000
--- a/graphics/py-pyglet/files/pyglet-noisy.in
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-#
-# # $FreeBSD$
-#
-
-cd "%%EXAMPLESDIR%%/noisy"
-exec /usr/bin/env python ./noisy.py "${@}"
diff --git a/graphics/py-pyglet/pkg-plist b/graphics/py-pyglet/pkg-plist
index d7c832933dc..afad5225b7f 100644
--- a/graphics/py-pyglet/pkg-plist
+++ b/graphics/py-pyglet/pkg-plist
@@ -1,5 +1,3 @@
-%%DEMOS%%bin/pyglet-astraea
-%%DEMOS%%bin/pyglet-noisy
%%PYTHON_SITELIBDIR%%/pyglet/__init__.py
%%PYTHON_SITELIBDIR%%/pyglet/__init__.pyc
%%PYTHON_SITELIBDIR%%/pyglet/__init__.pyo
@@ -297,8 +295,6 @@
%%PYTHON_SITELIBDIR%%/pyglet/window/xlib/xsync.py
%%PYTHON_SITELIBDIR%%/pyglet/window/xlib/xsync.pyc
%%PYTHON_SITELIBDIR%%/pyglet/window/xlib/xsync.pyo
-%%DEMOS%%share/pixmaps/pyglet-astraea.png
-%%DEMOS%%share/pixmaps/pyglet-noisy.png
@dirrm %%PYTHON_SITELIBDIR%%/pyglet/window/xlib
@dirrm %%PYTHON_SITELIBDIR%%/pyglet/window/win32
@dirrm %%PYTHON_SITELIBDIR%%/pyglet/window/carbon