aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-20 01:45:00 +0800
committerRong-En Fan <rafan@FreeBSD.org>2006-07-20 01:45:00 +0800
commit27bcc91cb0a74bc80c22071c33e543b513846d19 (patch)
tree3987a0cd03630e3dfec1c225622fcd09e6993b27
parentdb0c41f7c0710713ad81e487ef87a058452049ea (diff)
downloadfreebsd-ports-27bcc91cb0a74bc80c22071c33e543b513846d19.tar.gz
freebsd-ports-27bcc91cb0a74bc80c22071c33e543b513846d19.tar.zst
freebsd-ports-27bcc91cb0a74bc80c22071c33e543b513846d19.zip
Add p5-WWW-Comic 1.06, retrieve comic strip images.
PR: ports/100507 Submitted by: chinsan <chinsan.tw at gmail.com>
Notes
Notes: svn path=/head/; revision=168256
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Comic/Makefile31
-rw-r--r--www/p5-WWW-Comic/distinfo3
-rw-r--r--www/p5-WWW-Comic/pkg-descr5
-rw-r--r--www/p5-WWW-Comic/pkg-plist12
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3412238c6625..022993f60755 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -756,6 +756,7 @@
SUBDIR += p5-W3C-LinkChecker
SUBDIR += p5-W3C-LogValidator
SUBDIR += p5-WWW-Babelfish
+ SUBDIR += p5-WWW-Comic
SUBDIR += p5-WWW-Curl
SUBDIR += p5-WWW-Dilbert
SUBDIR += p5-WWW-Google-News
diff --git a/www/p5-WWW-Comic/Makefile b/www/p5-WWW-Comic/Makefile
new file mode 100644
index 000000000000..20724367d7dd
--- /dev/null
+++ b/www/p5-WWW-Comic/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WWW-Comic
+# Date created: 2006/06/28
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Comic
+PORTVERSION= 1.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Retrieve comic strip images
+
+RUN_DEPENDS= p5-Module-Pluggable>=3.01:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-WWW-Dilbert>=1.19:${PORTSDIR}/www/p5-WWW-Dilbert \
+ p5-WWW-VenusEnvy>=1.10:${PORTSDIR}/www/p5-WWW-VenusEnvy
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= WWW::Comic.3 WWW::Comic::Plugin::uComics.3 \
+ WWW::Comic::Plugin::MrWiggles.3 WWW::Comic::Plugin::UserFriendly.3 \
+ WWW::Comic::Plugin::VenusEnvy.3 WWW::Comic::Plugin::UFS.3 \
+ WWW::Comic::Plugin.3 WWW::Comic::Plugin::Dilbert.3 \
+ WWW::Comic::Plugin::Goats.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Comic/distinfo b/www/p5-WWW-Comic/distinfo
new file mode 100644
index 000000000000..1a5c5a8b7868
--- /dev/null
+++ b/www/p5-WWW-Comic/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Comic-1.06.tar.gz) = 211826fbbdf07e8448145c6a7a33f621
+SHA256 (WWW-Comic-1.06.tar.gz) = b2f4251919c17bc37958b78b7018f8c941097e377ee77578b744bea389064934
+SIZE (WWW-Comic-1.06.tar.gz) = 15729
diff --git a/www/p5-WWW-Comic/pkg-descr b/www/p5-WWW-Comic/pkg-descr
new file mode 100644
index 000000000000..105399499119
--- /dev/null
+++ b/www/p5-WWW-Comic/pkg-descr
@@ -0,0 +1,5 @@
+This module will download cartoon comic strip images from various websites
+and return a binary blob of the image, or write it to disk. Multiple comic
+strips can be supported through subclassed plugin modules.
+
+WWW: http://search.cpan.org/dist/WWW-Comic/
diff --git a/www/p5-WWW-Comic/pkg-plist b/www/p5-WWW-Comic/pkg-plist
new file mode 100644
index 000000000000..08f47a4557c4
--- /dev/null
+++ b/www/p5-WWW-Comic/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/WWW/Comic.pm
+%%SITE_PERL%%/WWW/Comic/Plugin.pm
+%%SITE_PERL%%/WWW/Comic/Plugin/UserFriendly.pm
+%%SITE_PERL%%/WWW/Comic/Plugin/uComics.pm
+%%SITE_PERL%%/WWW/Comic/Plugin/VenusEnvy.pm
+%%SITE_PERL%%/WWW/Comic/Plugin/Goats.pm
+%%SITE_PERL%%/WWW/Comic/Plugin/MrWiggles.pm
+%%SITE_PERL%%/WWW/Comic/Plugin/Dilbert.pm
+%%SITE_PERL%%/WWW/Comic/Plugin/UFS.pm
+@dirrmtry %%SITE_PERL%%/WWW/Comic/Plugin
+@dirrmtry %%SITE_PERL%%/WWW/Comic
+@dirrmtry %%SITE_PERL%%/WWW