aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-07-19 23:43:33 +0800
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-07-19 23:43:33 +0800
commit2e25ec457764a40bfcdfbff471765bdfe12ede66 (patch)
tree4ca2158754690c54dc4e6d172882e21344532e0b
parent4da180cc34b42a5de410a40e30490dbbf5901e5c (diff)
downloadfreebsd-ports-2e25ec457764a40bfcdfbff471765bdfe12ede66.tar.gz
freebsd-ports-2e25ec457764a40bfcdfbff471765bdfe12ede66.tar.zst
freebsd-ports-2e25ec457764a40bfcdfbff471765bdfe12ede66.zip
- Fix input error on some Big5 range
- Summitted by Edward G.J. Lee <edt1023@info.sayya.org> Thanks. PR: ports/100545 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=168250
-rw-r--r--chinese/zhcon/Makefile1
-rw-r--r--chinese/zhcon/files/patch-src-winime.cpp11
-rw-r--r--chinese/zhcon/files/patch-src-winime.h15
3 files changed, 27 insertions, 0 deletions
diff --git a/chinese/zhcon/Makefile b/chinese/zhcon/Makefile
index b12d100952a4..856b9f89fa63 100644
--- a/chinese/zhcon/Makefile
+++ b/chinese/zhcon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zhcon
PORTVERSION= 0.2.5
+PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/chinese/zhcon/files/patch-src-winime.cpp b/chinese/zhcon/files/patch-src-winime.cpp
new file mode 100644
index 000000000000..c017310bfebf
--- /dev/null
+++ b/chinese/zhcon/files/patch-src-winime.cpp
@@ -0,0 +1,11 @@
+--- src/winime.cpp.orig Tue Apr 25 00:38:28 2006
++++ src/winime.cpp Wed Jul 19 22:29:47 2006
+@@ -184,6 +184,8 @@
+ p++;
+ while (IsGB2312_1(*p) && IsGB2312_2(*(p + 1)))
+ p += 2;
++ while (IsBIG5_1(*p) && IsBIG5_2(*(p + 1)))
++ p += 2;
+ return !IsHzCode1(*p);
+ }
+
diff --git a/chinese/zhcon/files/patch-src-winime.h b/chinese/zhcon/files/patch-src-winime.h
new file mode 100644
index 000000000000..1b878902fa0b
--- /dev/null
+++ b/chinese/zhcon/files/patch-src-winime.h
@@ -0,0 +1,15 @@
+--- src/winime.h.orig Tue Apr 25 00:38:26 2006
++++ src/winime.h Wed Jul 19 22:27:58 2006
+@@ -68,6 +68,12 @@
+ bool IsGB2312_2(char c) const {
+ return c >= 0xA1 && c <= 0xFE;
+ }
++ bool IsBIG5_1(char c) const {
++ return c >= 0xA1 && c <= 0xFE;
++ }
++ bool IsBIG5_2(char c) const {
++ return c >= 0x40 && c <= 0x7E;
++ }
+
+ void AddCandilist(char*& p,unsigned& buflen);
+ void SkipNext(char*& rp);