aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-28 18:49:53 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-28 18:49:53 +0800
commit39cf37b9003ef1c14a992aa6b71ed57c96652924 (patch)
tree475e93a6894cc4504c5c54013eb0bdb409d7b31b
parent54edf3ba8d2c33e14e728f72c7321a5cf1d18763 (diff)
downloadfreebsd-ports-39cf37b9003ef1c14a992aa6b71ed57c96652924.tar.gz
freebsd-ports-39cf37b9003ef1c14a992aa6b71ed57c96652924.tar.zst
freebsd-ports-39cf37b9003ef1c14a992aa6b71ed57c96652924.zip
Update to 0.13 which supports Ruby 1.6.
Notes
Notes: svn path=/head/; revision=33202
-rw-r--r--x11-toolkits/ruby-qt/Makefile7
-rw-r--r--x11-toolkits/ruby-qt/distinfo2
-rw-r--r--x11-toolkits/ruby-qt/pkg-plist7
-rw-r--r--x11-toolkits/ruby-qt2/Makefile7
-rw-r--r--x11-toolkits/ruby-qt2/distinfo2
-rw-r--r--x11-toolkits/ruby-qt2/pkg-plist7
6 files changed, 14 insertions, 18 deletions
diff --git a/x11-toolkits/ruby-qt/Makefile b/x11-toolkits/ruby-qt/Makefile
index 2244913694be..d315b6fe1a93 100644
--- a/x11-toolkits/ruby-qt/Makefile
+++ b/x11-toolkits/ruby-qt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 0.12
+PORTVERSION= 0.13
CATEGORIES= x11-toolkits ruby
MASTER_SITES= http://sfns.u-shizuoka-ken.ac.jp/geneng/horie_hp/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -25,6 +25,7 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-qt-include=${X11BASE}/include/X11/qt \
--with-qt-lib=${X11BASE}/lib
+MAKE_ARGS= LOCAL_LIBS=-lgcc
INSTALL_TARGET= site-install
.if defined(WITH_I18N)
@@ -40,9 +41,7 @@ QT_PORTNAME= qt145
.endif
post-patch:
- ${PERL} -i -pe ' \
- s,/usr/X11\b,${X11BASE},g; \
- ' ${WRKSRC}/lib/qt.rb
+ ${RUBY} -i -pe 'gsub %r"/usr/X11\b", "${X11BASE}"' ${WRKSRC}/lib/qt.rb
post-install:
.if !defined(NOPORTDOCS)
diff --git a/x11-toolkits/ruby-qt/distinfo b/x11-toolkits/ruby-qt/distinfo
index d2685be5a64d..ef8a0cb84f63 100644
--- a/x11-toolkits/ruby-qt/distinfo
+++ b/x11-toolkits/ruby-qt/distinfo
@@ -1 +1 @@
-MD5 (ruby/ruby-qt-0.12.tar.gz) = 6e018ae243e8dcc30ae93150f8352d3c
+MD5 (ruby/ruby-qt-0.13.tar.gz) = e6821bcaf6041dfea68a130ab10a383d
diff --git a/x11-toolkits/ruby-qt/pkg-plist b/x11-toolkits/ruby-qt/pkg-plist
index 9081867fcaf7..67b2527cec87 100644
--- a/x11-toolkits/ruby-qt/pkg-plist
+++ b/x11-toolkits/ruby-qt/pkg-plist
@@ -8,10 +8,8 @@
%%RUBY_EXAMPLESDIR%%/qt/application/fileopen.xpm
%%RUBY_EXAMPLESDIR%%/qt/application/fileprint.xpm
%%RUBY_EXAMPLESDIR%%/qt/application/filesave.xpm
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/rbbr_rb.rb
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/rbbr_qt.rb
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/qtbrows2.rb
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/splitter.rb
+%%RUBY_EXAMPLESDIR%%/qt/classbrows/classtree.rb
+%%RUBY_EXAMPLESDIR%%/qt/classbrows/qtbrows3.rb
%%RUBY_EXAMPLESDIR%%/qt/connect/connect.rb
%%RUBY_EXAMPLESDIR%%/qt/connect/README.orig
%%RUBY_EXAMPLESDIR%%/qt/cursor/README.orig
@@ -34,6 +32,7 @@
%%RUBY_EXAMPLESDIR%%/qt/movies/trolltech.gif
%%RUBY_EXAMPLESDIR%%/qt/pinguin/pinguin.xpm
%%RUBY_EXAMPLESDIR%%/qt/pinguin/pixbutton.rb
+%%RUBY_EXAMPLESDIR%%/qt/rubyedit/NewFile
%%RUBY_EXAMPLESDIR%%/qt/rubyedit/rubyedit.rb
%%RUBY_EXAMPLESDIR%%/qt/rubyedit/rubyedit_lib.rb
%%RUBY_EXAMPLESDIR%%/qt/rubyedit/editcopy.xpm
diff --git a/x11-toolkits/ruby-qt2/Makefile b/x11-toolkits/ruby-qt2/Makefile
index 2244913694be..d315b6fe1a93 100644
--- a/x11-toolkits/ruby-qt2/Makefile
+++ b/x11-toolkits/ruby-qt2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qt
-PORTVERSION= 0.12
+PORTVERSION= 0.13
CATEGORIES= x11-toolkits ruby
MASTER_SITES= http://sfns.u-shizuoka-ken.ac.jp/geneng/horie_hp/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -25,6 +25,7 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-qt-include=${X11BASE}/include/X11/qt \
--with-qt-lib=${X11BASE}/lib
+MAKE_ARGS= LOCAL_LIBS=-lgcc
INSTALL_TARGET= site-install
.if defined(WITH_I18N)
@@ -40,9 +41,7 @@ QT_PORTNAME= qt145
.endif
post-patch:
- ${PERL} -i -pe ' \
- s,/usr/X11\b,${X11BASE},g; \
- ' ${WRKSRC}/lib/qt.rb
+ ${RUBY} -i -pe 'gsub %r"/usr/X11\b", "${X11BASE}"' ${WRKSRC}/lib/qt.rb
post-install:
.if !defined(NOPORTDOCS)
diff --git a/x11-toolkits/ruby-qt2/distinfo b/x11-toolkits/ruby-qt2/distinfo
index d2685be5a64d..ef8a0cb84f63 100644
--- a/x11-toolkits/ruby-qt2/distinfo
+++ b/x11-toolkits/ruby-qt2/distinfo
@@ -1 +1 @@
-MD5 (ruby/ruby-qt-0.12.tar.gz) = 6e018ae243e8dcc30ae93150f8352d3c
+MD5 (ruby/ruby-qt-0.13.tar.gz) = e6821bcaf6041dfea68a130ab10a383d
diff --git a/x11-toolkits/ruby-qt2/pkg-plist b/x11-toolkits/ruby-qt2/pkg-plist
index 9081867fcaf7..67b2527cec87 100644
--- a/x11-toolkits/ruby-qt2/pkg-plist
+++ b/x11-toolkits/ruby-qt2/pkg-plist
@@ -8,10 +8,8 @@
%%RUBY_EXAMPLESDIR%%/qt/application/fileopen.xpm
%%RUBY_EXAMPLESDIR%%/qt/application/fileprint.xpm
%%RUBY_EXAMPLESDIR%%/qt/application/filesave.xpm
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/rbbr_rb.rb
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/rbbr_qt.rb
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/qtbrows2.rb
-%%RUBY_EXAMPLESDIR%%/qt/classbrows/splitter.rb
+%%RUBY_EXAMPLESDIR%%/qt/classbrows/classtree.rb
+%%RUBY_EXAMPLESDIR%%/qt/classbrows/qtbrows3.rb
%%RUBY_EXAMPLESDIR%%/qt/connect/connect.rb
%%RUBY_EXAMPLESDIR%%/qt/connect/README.orig
%%RUBY_EXAMPLESDIR%%/qt/cursor/README.orig
@@ -34,6 +32,7 @@
%%RUBY_EXAMPLESDIR%%/qt/movies/trolltech.gif
%%RUBY_EXAMPLESDIR%%/qt/pinguin/pinguin.xpm
%%RUBY_EXAMPLESDIR%%/qt/pinguin/pixbutton.rb
+%%RUBY_EXAMPLESDIR%%/qt/rubyedit/NewFile
%%RUBY_EXAMPLESDIR%%/qt/rubyedit/rubyedit.rb
%%RUBY_EXAMPLESDIR%%/qt/rubyedit/rubyedit_lib.rb
%%RUBY_EXAMPLESDIR%%/qt/rubyedit/editcopy.xpm