aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-20 06:58:38 +0800
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-20 06:58:38 +0800
commit5521e8d9ff0725f9c7e16e76ba006ee5b18308e3 (patch)
tree9bce88690cfc932b3e6c7e97aa4bd4d890dade9e
parentef70919e2ce61a1eda81ac5e0f3c1f7235c8829e (diff)
downloadfreebsd-ports-5521e8d9ff0725f9c7e16e76ba006ee5b18308e3.tar.gz
freebsd-ports-5521e8d9ff0725f9c7e16e76ba006ee5b18308e3.tar.zst
freebsd-ports-5521e8d9ff0725f9c7e16e76ba006ee5b18308e3.zip
Add iconv support for translating file names across multiple charsets.
PR: 68102
Notes
Notes: svn path=/head/; revision=111834
-rw-r--r--net/netatalk-devel/Makefile5
-rw-r--r--net/netatalk-devel/files/patch-etc_afpd_Makefile.in20
2 files changed, 24 insertions, 1 deletions
diff --git a/net/netatalk-devel/Makefile b/net/netatalk-devel/Makefile
index 9f34778e9889..d16312364faf 100644
--- a/net/netatalk-devel/Makefile
+++ b/net/netatalk-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netatalk
PORTVERSION= 2.0.b1
+PORTREVISION= 1
CATEGORIES= net print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= netatalk
@@ -22,8 +23,10 @@ LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
NO_LATEST_LINK= yes
USE_BZIP2= yes
+USE_ICONV= yes
CONFIGURE_ARGS+= --with-tcp-wrappers \
- --with-pkgconfdir=${PREFIX}/etc
+ --with-pkgconfdir=${PREFIX}/etc \
+ --with-libiconv=${LOCALBASE}
.if defined(WITH_PAM)
CONFIGURE_ARGS+= --with-pam=/etc/pam.d
PLIST_SUB+= NETATALKPAM=""
diff --git a/net/netatalk-devel/files/patch-etc_afpd_Makefile.in b/net/netatalk-devel/files/patch-etc_afpd_Makefile.in
new file mode 100644
index 000000000000..ee39127d24c6
--- /dev/null
+++ b/net/netatalk-devel/files/patch-etc_afpd_Makefile.in
@@ -0,0 +1,20 @@
+--- etc/afpd/Makefile.in.orig Sat Jun 19 18:36:07 2004
++++ etc/afpd/Makefile.in Sat Jun 19 18:37:03 2004
+@@ -62,7 +62,7 @@
+ CCDEPMODE = @CCDEPMODE@
+
+ CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/sys \
+- @CFLAGS@ @SLP_CFLAGS@ \
++ @CFLAGS@ @SLP_CFLAGS@ @ICONV_CFLAGS@ \
+ -D_PATH_AFPDDEFVOL=\"$(pkgconfdir)/AppleVolumes.default\" \
+ -D_PATH_AFPDSYSVOL=\"$(pkgconfdir)/AppleVolumes.system\" \
+ -D_PATH_AFPDPWFILE=\"$(pkgconfdir)/afppasswd\" \
+@@ -105,7 +105,7 @@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+
+-LIBS = @LIBS@ @PAM_LIBS@ @QUOTA_LIBS@ @SLP_LIBS@
++LIBS = @LIBS@ @PAM_LIBS@ @QUOTA_LIBS@ @SLP_LIBS@ @ICONV_LIBS@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@