aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-09-17 18:53:31 +0800
committerSatoshi Asami <asami@FreeBSD.org>1998-09-17 18:53:31 +0800
commit6470b4dc9c5e85815e7ec1472d2cfbd001a8ed2d (patch)
tree34d83443625691a3bb02eb0ebe7f22e82ced9b8b
parent8ce1982fd8289a49a65182c8e04334a29f84a2ed (diff)
downloadfreebsd-ports-6470b4dc9c5e85815e7ec1472d2cfbd001a8ed2d.tar.gz
freebsd-ports-6470b4dc9c5e85815e7ec1472d2cfbd001a8ed2d.tar.zst
freebsd-ports-6470b4dc9c5e85815e7ec1472d2cfbd001a8ed2d.zip
tcp_wrapper is now converted to ELF. While I'm here, fix smail Makefile:
libwrap is a shared library so it should be LIB_DEPENDS, and delete some spaces and tab-only lines.
Notes
Notes: svn path=/head/; revision=13204
-rw-r--r--mail/smail/Makefile9
-rw-r--r--net/rwhois/Makefile4
-rw-r--r--net/rwhoisd/Makefile4
-rw-r--r--security/ssh/Makefile4
-rw-r--r--security/ssh2/Makefile4
5 files changed, 13 insertions, 12 deletions
diff --git a/mail/smail/Makefile b/mail/smail/Makefile
index c3703e24f9c1..f0222325f0c7 100644
--- a/mail/smail/Makefile
+++ b/mail/smail/Makefile
@@ -3,7 +3,7 @@
# Date created: 16 Oct 1994
# Whom: torstenb
#
-# $Id: Makefile,v 1.19 1997/10/15 09:38:57 torstenb Exp $
+# $Id: Makefile,v 1.20 1998/01/25 20:45:14 torstenb Exp $
#
DISTNAME= smail-3.2.0.101
@@ -14,7 +14,8 @@ MASTER_SITES= ftp://ftp.uu.net/networking/mail/smail/ \
MAINTAINER= torstenb@FreeBSD.ORG
-BUILD_DEPENDS= ${PREFIX}/lib/libident.a:${PORTSDIR}/security/libident \ ${PREFIX}/lib/libwrap.a:${PORTSDIR}/security/tcp_wrapper
+BUILD_DEPENDS= ${PREFIX}/lib/libident.a:${PORTSDIR}/security/libident
+LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
INSTALL_TARGET= install installman
@@ -52,7 +53,7 @@ replace:
fi;\
fi
if [ -e /usr/local/bin/newaliases ]; then \
- cp -fp /usr/local/bin/newaliases /usr/bin/newaliases; \
+ cp -fp /usr/local/bin/newaliases /usr/bin/newaliases; \
fi
if [ -e /usr/bin/mailq ]; then \
mv -f /usr/bin/mailq /usr/bin/mailq.BAK; \
@@ -63,5 +64,5 @@ replace:
if [ -e /usr/local/bin/mailq ]; then \
cp -fp /usr/local/bin/mailq /usr/bin/mailq; \
fi
-
+
.include <bsd.port.mk>
diff --git a/net/rwhois/Makefile b/net/rwhois/Makefile
index 51815cf2a45b..b7abe40c4437 100644
--- a/net/rwhois/Makefile
+++ b/net/rwhois/Makefile
@@ -3,7 +3,7 @@
# Date created: May 9th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.1.1.1 1997/05/30 20:13:23 jfitz Exp $
+# $Id: Makefile,v 1.2 1997/06/03 06:11:35 asami Exp $
#
DISTNAME= rwhois-1.0B9.2
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.rwhois.net/pub/
MAINTAINER= jfitz@FreeBSD.ORG
-LIB_DEPENDS= wrap\\.7\\.:${PORTSDIR}/security/tcp_wrapper
+LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
HAS_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX}/lib/rwhois
diff --git a/net/rwhoisd/Makefile b/net/rwhoisd/Makefile
index 51815cf2a45b..b7abe40c4437 100644
--- a/net/rwhoisd/Makefile
+++ b/net/rwhoisd/Makefile
@@ -3,7 +3,7 @@
# Date created: May 9th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.1.1.1 1997/05/30 20:13:23 jfitz Exp $
+# $Id: Makefile,v 1.2 1997/06/03 06:11:35 asami Exp $
#
DISTNAME= rwhois-1.0B9.2
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.rwhois.net/pub/
MAINTAINER= jfitz@FreeBSD.ORG
-LIB_DEPENDS= wrap\\.7\\.:${PORTSDIR}/security/tcp_wrapper
+LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
HAS_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX}/lib/rwhois
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index 9ea8172591cb..8b56942b7285 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.62 1998/08/19 19:51:10 hoek Exp $
+# $Id: Makefile,v 1.63 1998/09/15 21:31:53 asami Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
@@ -147,7 +147,7 @@ CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
(!defined(USE_TCPWRAP) || ${USE_TCPWRAP} != NO)
CONFIGURE_ENV+= LDFLAGS=-L${PREFIX}/lib CFLAGS="${CFLAGS} -I${PREFIX}/include"
CONFIGURE_ARGS+= --with-libwrap
-LIB_DEPENDS+= wrap\\.7\\.:${PORTSDIR}/security/tcp_wrapper
+LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.endif
# Include SOCKS firewall support
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 9ea8172591cb..8b56942b7285 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.62 1998/08/19 19:51:10 hoek Exp $
+# $Id: Makefile,v 1.63 1998/09/15 21:31:53 asami Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
@@ -147,7 +147,7 @@ CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
(!defined(USE_TCPWRAP) || ${USE_TCPWRAP} != NO)
CONFIGURE_ENV+= LDFLAGS=-L${PREFIX}/lib CFLAGS="${CFLAGS} -I${PREFIX}/include"
CONFIGURE_ARGS+= --with-libwrap
-LIB_DEPENDS+= wrap\\.7\\.:${PORTSDIR}/security/tcp_wrapper
+LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.endif
# Include SOCKS firewall support