aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 23:35:52 +0800
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-25 23:35:52 +0800
commit64ad2aa62b112dc2aaf33197367df7a882ec2aa6 (patch)
tree1e1c2b54ccebda1ce7d6f77e8817a3f1a20cb5a6
parent0337ce5afa621a0a135fc6dd0d991fa4f617273b (diff)
downloadfreebsd-ports-64ad2aa62b112dc2aaf33197367df7a882ec2aa6.tar.gz
freebsd-ports-64ad2aa62b112dc2aaf33197367df7a882ec2aa6.tar.zst
freebsd-ports-64ad2aa62b112dc2aaf33197367df7a882ec2aa6.zip
Add thinglaunch.
Thinglaunch is a very fast launcher program for X. You can bind it to a key in your favorite window manager, and when you want to start a program, just type its name. thinglaunch has a tiny footprint and depends only on Xlib. WWW: http://unix.freshmeat.net/projects/thinglaunch/ PR: ports/83904 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=140094
-rw-r--r--x11/Makefile1
-rw-r--r--x11/thinglaunch/Makefile30
-rw-r--r--x11/thinglaunch/distinfo2
-rw-r--r--x11/thinglaunch/pkg-descr10
4 files changed, 43 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index f975eba206d7..31f075247b85 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -172,6 +172,7 @@
SUBDIR += startup-notification
SUBDIR += sxpc
SUBDIR += temperature.app
+ SUBDIR += thinglaunch
SUBDIR += tkgoodstuff
SUBDIR += tycoon
SUBDIR += vdesk
diff --git a/x11/thinglaunch/Makefile b/x11/thinglaunch/Makefile
new file mode 100644
index 000000000000..07ea5df234ae
--- /dev/null
+++ b/x11/thinglaunch/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: thinglaunch
+# Date created: 22 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thinglaunch
+PORTVERSION= 1.03
+CATEGORIES= x11
+MASTER_SITES= http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A very fast launcher program for X
+
+USE_X_PREFIX= yes
+
+CPPFLAGS= -I${X11BASE}/include -lX11
+LDFLAGS= -L${X11BASE}/lib
+
+PLIST_FILES= bin/thinglaunch
+
+do-build:
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c \
+ -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/thinglaunch/distinfo b/x11/thinglaunch/distinfo
new file mode 100644
index 000000000000..be94b2063463
--- /dev/null
+++ b/x11/thinglaunch/distinfo
@@ -0,0 +1,2 @@
+MD5 (thinglaunch-1.03.tar.gz) = 3442545e91ba18e43e46638c0a3b485a
+SIZE (thinglaunch-1.03.tar.gz) = 3315
diff --git a/x11/thinglaunch/pkg-descr b/x11/thinglaunch/pkg-descr
new file mode 100644
index 000000000000..b6b8cecb1eaf
--- /dev/null
+++ b/x11/thinglaunch/pkg-descr
@@ -0,0 +1,10 @@
+Thinglaunch is a very fast launcher program for X.
+
+You can bind it to a key in your favorite window manager, and when you want to
+start a program, just type its name. thinglaunch has a tiny footprint and
+depends only on Xlib.
+
+WWW: http://unix.freshmeat.net/projects/thinglaunch/
+
+- ehaupt
+ehaupt@critical.ch