aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-06-20 22:42:18 +0800
committerMarkus Brueffer <markus@FreeBSD.org>2004-06-20 22:42:18 +0800
commit6c2f2367a719810a7f06a94359b65cde82eec194 (patch)
treebf923a4593f04f0379a4468ee3da9dc76eb80e35
parentafd951530a4a649efcd7e6e365e20794e009f70e (diff)
downloadfreebsd-ports-6c2f2367a719810a7f06a94359b65cde82eec194.tar.gz
freebsd-ports-6c2f2367a719810a7f06a94359b65cde82eec194.tar.zst
freebsd-ports-6c2f2367a719810a7f06a94359b65cde82eec194.zip
- Don't use Makefile.kde anymore
- Respect CFLAGS and PTHREAD_LIBS Approved by: maintainer timeout (4 weeks)
Notes
Notes: svn path=/head/; revision=111860
-rw-r--r--net-im/kmerlin/Makefile10
-rw-r--r--net/kmerlin/Makefile10
2 files changed, 12 insertions, 8 deletions
diff --git a/net-im/kmerlin/Makefile b/net-im/kmerlin/Makefile
index 50753074ca02..ff6233c1bcf1 100644
--- a/net-im/kmerlin/Makefile
+++ b/net-im/kmerlin/Makefile
@@ -19,8 +19,10 @@ COMMENT= An IM (Instant Messenger) KDE client for the Microsoft MSN Network
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
+
CONFIGURE_ARGS+= --prefix=${LOCALBASE}
-_NO_KDE_FIXPTHREAD= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
post-patch:
.for i in replacepage identityeditdialog identitysetting \
@@ -28,7 +30,7 @@ post-patch:
@${RM} ${WRKSRC}/src/setting/${i}.h ${WRKSRC}/src/setting/${i}.cpp
.endfor
@${RM} ${WRKSRC}/src/login.h ${WRKSRC}/src/login.cpp
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/kmerlin/Makefile b/net/kmerlin/Makefile
index 50753074ca02..ff6233c1bcf1 100644
--- a/net/kmerlin/Makefile
+++ b/net/kmerlin/Makefile
@@ -19,8 +19,10 @@ COMMENT= An IM (Instant Messenger) KDE client for the Microsoft MSN Network
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
+
CONFIGURE_ARGS+= --prefix=${LOCALBASE}
-_NO_KDE_FIXPTHREAD= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
post-patch:
.for i in replacepage identityeditdialog identitysetting \
@@ -28,7 +30,7 @@ post-patch:
@${RM} ${WRKSRC}/src/setting/${i}.h ${WRKSRC}/src/setting/${i}.cpp
.endfor
@${RM} ${WRKSRC}/src/login.h ${WRKSRC}/src/login.cpp
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>