aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2004-06-21 05:18:36 +0800
committerJoerg Wunsch <joerg@FreeBSD.org>2004-06-21 05:18:36 +0800
commit71bf94a6613ea8f61fbbbf9943cee5ebc6a60212 (patch)
treeb0d94120fcddf701972bdf936b52b47cf0f24ed6
parentb71acf0516decd543f3b0ae73524fb82c6a11295 (diff)
downloadfreebsd-ports-71bf94a6613ea8f61fbbbf9943cee5ebc6a60212.tar.gz
freebsd-ports-71bf94a6613ea8f61fbbbf9943cee5ebc6a60212.tar.zst
freebsd-ports-71bf94a6613ea8f61fbbbf9943cee5ebc6a60212.zip
Don't use the ancient -m avrr85xx linker `emulation' option, binutils
2.15 doesn't provide it anymore. Use -m avr2 instead now. This patch is only required as a stop-gap measure, until the official sources have fixed that.
Notes
Notes: svn path=/head/; revision=111881
-rw-r--r--devel/simulavr/Makefile2
-rw-r--r--devel/simulavr/files/patch-test_asm22
2 files changed, 23 insertions, 1 deletions
diff --git a/devel/simulavr/Makefile b/devel/simulavr/Makefile
index 2e32330ce41d..bd985f5f49b2 100644
--- a/devel/simulavr/Makefile
+++ b/devel/simulavr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= simulavr
PORTVERSION= 0.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/simulavr/files/patch-test_asm b/devel/simulavr/files/patch-test_asm
new file mode 100644
index 000000000000..56a7749fb4d6
--- /dev/null
+++ b/devel/simulavr/files/patch-test_asm
@@ -0,0 +1,22 @@
+--- test_asm/test_8515/Makefile.am.orig Thu Aug 14 04:35:06 2003
++++ test_asm/test_8515/Makefile.am Thu Jun 17 10:22:38 2004
+@@ -51,7 +51,7 @@
+
+ all-local: $(TEST_ELF) $(TEST_LST) $(TEST_BIN) $(TEST_HEX)
+ for prg in $(TEST_PRG); do \
+- $(AVR_LD) -m avr85xx -o $$prg $${prg}.elf || exit 1; \
++ $(AVR_LD) -m avr2 -o $$prg $${prg}.elf || exit 1; \
+ done
+
+ clean-local:
+--- test_asm/test_8515/Makefile.in.orig Mon Jan 19 00:58:31 2004
++++ test_asm/test_8515/Makefile.in Thu Jun 17 10:23:08 2004
+@@ -379,7 +379,7 @@
+
+ all-local: $(TEST_ELF) $(TEST_LST) $(TEST_BIN) $(TEST_HEX)
+ for prg in $(TEST_PRG); do \
+- $(AVR_LD) -m avr85xx -o $$prg $${prg}.elf || exit 1; \
++ $(AVR_LD) -m avr2 -o $$prg $${prg}.elf || exit 1; \
+ done
+
+ clean-local: