aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-30 05:39:11 +0800
committerSteve Price <steve@FreeBSD.org>1999-12-30 05:39:11 +0800
commit945485fde52cef5e2e34afb18ef81a3bc3995b04 (patch)
treefcd6bca076e6af2cadd6464285baabadea08e14d
parenta0963f61c272c619461747e3c1f148d38758ceb5 (diff)
downloadfreebsd-ports-945485fde52cef5e2e34afb18ef81a3bc3995b04.tar.gz
freebsd-ports-945485fde52cef5e2e34afb18ef81a3bc3995b04.tar.zst
freebsd-ports-945485fde52cef5e2e34afb18ef81a3bc3995b04.zip
Update to version 1.21.
PR: 13705 Submitted by: Garrett Wollman <wollman@khavrinen.lcs.mit.edu>
Notes
Notes: svn path=/head/; revision=24274
-rw-r--r--www/p5-Apache/Makefile34
-rw-r--r--www/p5-Apache/distinfo2
-rw-r--r--www/p5-Apache/files/patch-aa62
-rw-r--r--www/p5-Apache/files/post-install-notes26
-rw-r--r--www/p5-Apache/pkg-plist94
5 files changed, 46 insertions, 172 deletions
diff --git a/www/p5-Apache/Makefile b/www/p5-Apache/Makefile
index 6ccc17c77175..b7b038e6b1f9 100644
--- a/www/p5-Apache/Makefile
+++ b/www/p5-Apache/Makefile
@@ -1,46 +1,48 @@
# New ports collection makefile for: p5-Apache
-# Version required: 1.19
+# Version required: 1.21
# Date created: April 26th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= mod_perl-1.19
-PKGNAME= p5-Apache-1.19
+DISTNAME= mod_perl-1.21
+PKGNAME= p5-Apache-1.21
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
MAINTAINER= jfitz@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/apache13:patch
+.if !defined(APACHE_PORT)
+APACHE_PORT=apache13
+.endif
+BUILD_DEPENDS= ${PREFIX}/sbin/apxs:${PORTSDIR}/www/${APACHE_PORT} \
+ ${PREFIX}/bin/lwp-download:${PORTSDIR}/www/p5-libwww
USE_PERL5= YES
-CONFIGURE_ENV= APACHEDIR=${WRKDIRPREFIX}${.CURDIR}/../apache13/work/ INSTALL_PROGRAM="${INSTALL_PROGRAM}"
-MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
- Apache::FakeRequest.3 Apache::Leak.3 \
- Apache::Log.3 Apache::Options.3 \
- Apache::PerlRun.3 Apache::PerlRunXS.3 \
+MAN3= Apache.3 Apache::Constants.3 Apache::Debug.3 \
+ Apache::ExtUtils.3 Apache::FakeRequest.3 Apache::Include.3 \
+ Apache::Leak.3 Apache::Log.3 Apache::Options.3 \
+ Apache::PerlRun.3 Apache::PerlRunXS.3 Apache::PerlSections.3 \
Apache::RedirectLogFix.3 \
- Apache::Registry.3 Apache::SizeLimit.3 \
+ Apache::Registry.3 Apache::RegistryLoader.3 \
+ Apache::Resource.3 Apache::SIG.3 Apache::SizeLimit.3 \
+ Apache::StatINC.3 \
Apache::Status.3 Apache::Symbol.3 Apache::Symdump.3 \
Apache::Table.3 Apache::URI.3 Apache::Util.3 \
Apache::httpd_conf.3 Apache::src.3 Bundle::Apache.3 \
- Apache::Debug.3 mod_perl.3 Apache::SIG.3 Apache::Resource.3 \
- Apache::RegistryLoader.3 Apache::StatINC.3 Apache::Include.3 \
- Apache::PerlSections.3 cgi_to_mod_perl.3 \
- mod_perl_cvs.3 mod_perl_method_handlers.3 mod_perl_traps.3 \
+ cgi_to_mod_perl.3 mod_perl.3 mod_perl_cvs.3 \
+ mod_perl_method_handlers.3 mod_perl_traps.3 \
mod_perl_tuning.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL USE_APXS=1 WITH_APXS=${PREFIX}/sbin/apxs EVERYTHING=1
post-install:
${MKDIR} ${PREFIX}/share/doc/mod_perl
${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/share/doc/mod_perl
- @ ${SETENV} ${MAKE_ENV} PORTSDIR=${PORTSDIR} ${CONFIGURE_ENV} /usr/bin/perl ${SCRIPTDIR}/install_httpd
.if !defined(BATCH)
@ /usr/bin/more -e ${FILESDIR}/post-install-notes
.endif
diff --git a/www/p5-Apache/distinfo b/www/p5-Apache/distinfo
index 93638875862b..5617eb59a45d 100644
--- a/www/p5-Apache/distinfo
+++ b/www/p5-Apache/distinfo
@@ -1 +1 @@
-MD5 (mod_perl-1.19.tar.gz) = 721fe5245aefdffecf5f54a9c29c5938
+MD5 (mod_perl-1.21.tar.gz) = 3695bb66e8eecf6cceec97e54d48f48e
diff --git a/www/p5-Apache/files/patch-aa b/www/p5-Apache/files/patch-aa
index 394f337bc4e9..0e2d165e922d 100644
--- a/www/p5-Apache/files/patch-aa
+++ b/www/p5-Apache/files/patch-aa
@@ -1,45 +1,17 @@
---- Makefile.PL~ Fri Jan 22 11:57:51 1999
-+++ Makefile.PL Sun May 9 19:41:55 1999
-@@ -67,12 +67,10 @@
- sleep(1);
- }
-
--%Apache::MyConfig::Setup = ();
--eval 'require Apache::MyConfig' ;
--
--$APACHE_SRC_DEFAULT = $@ ?
-- '../apache_x.x/src' :
-- $Apache::MyConfig::Setup{Apache_Src} ;
-+opendir( WRKDIR, "$ENV{APACHEDIR}" ) || die( "Can't open $ENV{APACHEDIR}: $!\n" );
-+( $srcdir ) = grep( /^apache/, readdir( WRKDIR ) );
-+closedir( WRKDIR );
-+$APACHE_SRC_DEFAULT = "$ENV{APACHEDIR}" . $srcdir . "/src";
-
- my $PWD = cwd;
-
-@@ -157,12 +155,12 @@
- }
- $PORT ||= $Port;
- $TARGET = "";
--$DO_HTTPD = $ENV{DO_HTTPD} || 0;
-+$DO_HTTPD = 1;
- $NO_HTTPD = $ENV{NO_HTTPD} || 0;
- $PREP_HTTPD = 0;
- $PERL_TRACE = 0;
- $ALL_HOOKS = 0;
--$APACHE_SRC = "";
-+$APACHE_SRC = $APACHE_SRC_DEFAULT;
- $APACHE_PREFIX = "";
- $APACHE_HEADER_INSTALL = 1;
- $PERL_SECTIONS = 0;
-@@ -1570,8 +1568,8 @@
- my $repl = "";
- my @file = ();
- my $ccopts = ccopts();
-- my $dssv = "-DSERVER_SUBVERSION";
-- my $ssv = qq($dssv=\\"mod_perl/$VERSION\\" );
-+ my $dssv = "\n-DSERVER_SUBVERSION";
-+ my $ssv = qq($dssv=\\"mod_perl/$VERSION\\" \\);
-
- my $inc = " $ccopts -I. -I../.. -DUSE_PERL_SSI" if $PERL_SSI;
- $inc .= " -DAPACHE_SSL" if is_ssl() and $PERL_SSI;
+--- apaci/configure.orig Mon Aug 10 16:09:55 1998
++++ apaci/configure Sat Sep 11 23:34:15 1999
+@@ -89,7 +89,13 @@
+ echo "##" >>$my_makefileconf
+ echo "" >>$my_makefileconf
+ echo "# provide some stuff Apache usually provides" >>$my_makefileconf
+-echo "CFLAGS=-DMOD_PERL $my_apxs_cflags" >>$my_makefileconf
++echo -n "CFLAGS=-DMOD_PERL " >>$my_makefileconf
++#
++# GAW addition: make up for bug in APXS which fails to properly quote
++# DEFAULT_PATH
++#
++$my_apxs -q CFLAGS | sed 's,",\\",g' >>$my_makefileconf
++echo "" >>$my_makefileconf
+ echo "INCLUDES=$my_apxs_includes" >>$my_makefileconf
+ echo "RANLIB=ranlib" >>$my_makefileconf
+ echo "LIBEXT=so" >>$my_makefileconf
diff --git a/www/p5-Apache/files/post-install-notes b/www/p5-Apache/files/post-install-notes
index ce3a10ac8ae4..9b6179b53fe5 100644
--- a/www/p5-Apache/files/post-install-notes
+++ b/www/p5-Apache/files/post-install-notes
@@ -1,23 +1,15 @@
Post-install Notes for p5-Apache
================================
-This port has built a new httpd binary that includes the perl5 module
-(mod_perl). To avoid overwriting an existing httpd binary, it has been
-installed as
+This port has built a new Apache dynamic shared object (DSO).
+If it was built from source, the module has already been
+activated in ${PREFIX}/etc/apache/apache.conf. If, however,
+it was installed using the binary package, the activation must be
+done manually, using the command
+ ${PREFIX}/sbin/apxs -e -a -n perl libperl.so
-${PREFIX}/sbin/httpd_modperl
+This is actually a bug. (If you are using conditional module loading
+in apache.conf, such as with mod_ssl, apxs may add the module in the
+wrong place.)
($PREFIX is usually /usr/local unless you override it).
-
-In order to use this module, you should rename it to httpd. Remember that
-this binary is the standard apache port, with mod_perl and nothing else
-added. If you have already built yourself an httpd binary containing
-optional modules, you are better off building mod_perl yourself.
-
-The original source for p5-Apache can be found at any CPAN mirror, in the
-directory
-
-modules/by-module/Apache/
-
---
-j.
diff --git a/www/p5-Apache/pkg-plist b/www/p5-Apache/pkg-plist
index c5fa27d0f4b7..63354fc230e6 100644
--- a/www/p5-Apache/pkg-plist
+++ b/www/p5-Apache/pkg-plist
@@ -1,4 +1,3 @@
-sbin/httpd_modperl
share/doc/mod_perl/post-install-notes
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Connection.pm
@@ -52,100 +51,9 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Leak/Leak.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Leak/Leak.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Symbol/Symbol.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Symbol/Symbol.so
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/alloc.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap_compat.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap_config.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap_config_auto.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap_ctype.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap_md5.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap_mmn.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/ap_sha1.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/buff.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/compat.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/conf.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/explain.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/fnmatch.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/hsregex.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_conf_globals.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_config.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_core.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_log.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_main.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_protocol.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_request.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/http_vhost.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/httpd.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/multithread.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/rfc1413.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/scoreboard.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/util_date.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/util_md5.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/util_script.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include/util_uri.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/asciitab.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/hashtable.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/iasciitab.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/latin1tab.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/nametab.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/utf8tab.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/xmldef.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/xmlparse.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/xmlrole.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/xmltok.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite/xmltok_impl.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/perl/mod_perl.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/perl/mod_perl_version.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/perl/mod_perl_xs.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/perl/perl_PL.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/proxy/mod_proxy.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/standard/mod_rewrite.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/bs2000/ebcdic.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/bs2000/os-inline.c
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/bs2000/os.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/os2/os-inline.c
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/os2/os.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/tpf/ebcdic.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/tpf/os-inline.c
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/tpf/os.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/unix/os-inline.c
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/unix/os.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/getopt.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/os.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/passwd.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/readdir.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/registry.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/resource.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/service.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/installer/installdll/test/resource.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/installer/installdll/test/test.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/regex/cclass.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/regex/cname.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/regex/regex2.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/regex/utils.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/support/suexec.h
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/typemap
+libexec/apache/libperl.so
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Leak
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Symbol
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/include
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib/expat-lite
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/lib
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/perl
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/proxy
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules/standard
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/modules
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/bs2000
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/os2
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/tpf
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/unix
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/installer/installdll/test
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/installer/installdll
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32/installer
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os/win32
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/os
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/regex
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include/support
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/include
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/mod_perl
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Constants