aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2007-05-27 04:31:58 +0800
committerkrion <krion@FreeBSD.org>2007-05-27 04:31:58 +0800
commit9b5e5e76c02e2d75cbc1e07889ace8ec79a231a2 (patch)
tree14e0ab71ea99110353b37549faa1ddbcb377d3f9
parent2b2c12c28b66d24f54d7244e1d83da35251424dd (diff)
downloadfreebsd-ports-9b5e5e76c02e2d75cbc1e07889ace8ec79a231a2.tar.gz
freebsd-ports-9b5e5e76c02e2d75cbc1e07889ace8ec79a231a2.tar.zst
freebsd-ports-9b5e5e76c02e2d75cbc1e07889ace8ec79a231a2.zip
Fix build with gcc4.2
-rw-r--r--x11/buttonbox/Makefile9
-rw-r--r--x11/buttonbox/files/patch-button.c14
2 files changed, 16 insertions, 7 deletions
diff --git a/x11/buttonbox/Makefile b/x11/buttonbox/Makefile
index eabe9a3f95d0..9bfe61846be4 100644
--- a/x11/buttonbox/Makefile
+++ b/x11/buttonbox/Makefile
@@ -22,12 +22,6 @@ PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -o buttonbox -L${X11BASE}/lib \
-I${X11BASE}/include -lX11 -lXext button.c configuration.c \
@@ -36,6 +30,7 @@ do-build:
pre-install:
${ECHO_CMD} bin/buttonbox > ${PLIST}
${ECHO_CMD} lib/X11/app-defaults/ButtonBox.ad >> ${PLIST}
+
.if !defined(NOPORTDOCS)
for i in ${DOCS}; \
do ${ECHO_CMD} ${DOCDIR}/$${i} >> ${PLIST}; \
@@ -53,4 +48,4 @@ do-install:
done
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/buttonbox/files/patch-button.c b/x11/buttonbox/files/patch-button.c
new file mode 100644
index 000000000000..35733ff4d036
--- /dev/null
+++ b/x11/buttonbox/files/patch-button.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- button.c.orig
++++ button.c
+@@ -31,7 +31,7 @@
+
+
+
+-static char* default_font = "7x13";
++char* default_font = "7x13";
+
+ static Bool button_window_proc (Dispatcher* dispatcher, XEvent* event, void* data);
+