aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-21 00:04:23 +0800
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-21 00:04:23 +0800
commitad01a88a64bebb1a5356c5645ac081746323f039 (patch)
tree2d9cbdf5a5bb60f21b2cf859ba8823282483db08
parent542c9d11504fda8698c9bcf29636f96fde955a0e (diff)
downloadfreebsd-ports-ad01a88a64bebb1a5356c5645ac081746323f039.tar.gz
freebsd-ports-ad01a88a64bebb1a5356c5645ac081746323f039.tar.zst
freebsd-ports-ad01a88a64bebb1a5356c5645ac081746323f039.zip
Fix a bug with syncing offline copy with LiveJournal.
PR: ports/68123 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=111864
-rw-r--r--deskutils/logjam/Makefile2
-rw-r--r--deskutils/logjam/files/patch-src::sync.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index afdc9975a365..6d2af9a9719c 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= logjam
PORTVERSION= 4.4.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= deskutils
MASTER_SITES= http://logjam.danga.com/download/
diff --git a/deskutils/logjam/files/patch-src::sync.c b/deskutils/logjam/files/patch-src::sync.c
new file mode 100644
index 000000000000..5d010136d36a
--- /dev/null
+++ b/deskutils/logjam/files/patch-src::sync.c
@@ -0,0 +1,15 @@
+--- protocol/liblivejournal/livejournal/sync.c.old Fri Jun 18 14:57:51 2004
++++ protocol/liblivejournal/livejournal/sync.c Fri Jun 18 14:58:20 2004
+@@ -33,8 +33,10 @@
+ static int
+ entry_date_compare_func(const void *a, const void *b) {
+ /* struct tm* cast needed to un-constify the times passed to mktime. */
+- const LJEntry *entrya = a; time_t timea = mktime((struct tm*)&entrya->time);
+- const LJEntry *entryb = b; time_t timeb = mktime((struct tm*)&entryb->time);
++ const LJEntry *entrya = *(LJEntry **)a;
++ const LJEntry *entryb = *(LJEntry **)b;
++ time_t timea = mktime((struct tm*)&entrya->time);
++ time_t timeb = mktime((struct tm*)&entryb->time);
+ /* mktime actually converts the times to local time, which isn't
+ * quite correct, but since we're comparing times directly like this
+ * it should still sort the same way and timegm is potentially slower. */