aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 21:30:42 +0800
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 21:30:42 +0800
commitbb34de42c0ccac8e962cab97e064965d23f081de (patch)
treedd40b82023ab94a6839b4f4d440c3cd5cab978ee
parent533c87fa4d98c0e6100d18f59559906241ed4230 (diff)
downloadfreebsd-ports-bb34de42c0ccac8e962cab97e064965d23f081de.tar.gz
freebsd-ports-bb34de42c0ccac8e962cab97e064965d23f081de.tar.zst
freebsd-ports-bb34de42c0ccac8e962cab97e064965d23f081de.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Notes
Notes: svn path=/head/; revision=93887
-rw-r--r--lang/diveintopython/Makefile4
-rw-r--r--lang/eperl/Makefile3
-rw-r--r--lang/fesi/Makefile2
-rw-r--r--lang/icc/Makefile4
-rw-r--r--lang/icc7/Makefile4
-rw-r--r--lang/ifc/Makefile4
-rw-r--r--lang/ifc7/Makefile4
-rw-r--r--lang/kawa/Makefile2
-rw-r--r--lang/sml-nj/Makefile2
-rw-r--r--mail/claws-mail/Makefile2
-rw-r--r--mail/sendmail-old/Makefile4
-rw-r--r--mail/sendmail811/Makefile4
-rw-r--r--mail/spambnc/Makefile2
-rw-r--r--mail/sylpheed-claws/Makefile2
-rw-r--r--math/djbfft/Makefile2
-rw-r--r--math/gnuplot+/Makefile2
-rw-r--r--math/jacal/Makefile2
-rw-r--r--math/javanns/Makefile4
-rw-r--r--math/mupad/Makefile2
-rw-r--r--math/p5-Math-LinearCombination/Makefile2
-rw-r--r--math/p5-Math-SimpleVariable/Makefile2
-rw-r--r--math/py-gato/Makefile2
-rw-r--r--math/rcalc/Makefile2
-rw-r--r--math/scigraphica/Makefile2
-rw-r--r--misc/metatheme2/Makefile4
-rw-r--r--multimedia/xmms/Makefile2
-rw-r--r--multimedia/xmps/Makefile2
-rw-r--r--net/clusterit/Makefile3
-rw-r--r--net/coda5_doc/Makefile2
-rw-r--r--net/gopher/Makefile2
-rw-r--r--net/ntp-devel/Makefile5
-rw-r--r--net/ntp-stable/Makefile5
-rw-r--r--net/ntp/Makefile5
-rw-r--r--net/p5-Net-Radius/Makefile2
-rw-r--r--net/p5-Net-XWhois/Makefile2
-rw-r--r--net/ppxp/Makefile2
-rw-r--r--net/xipdump/Makefile2
37 files changed, 54 insertions, 49 deletions
diff --git a/lang/diveintopython/Makefile b/lang/diveintopython/Makefile
index a9b427b85c94..88f3426b0842 100644
--- a/lang/diveintopython/Makefile
+++ b/lang/diveintopython/Makefile
@@ -42,9 +42,9 @@ post-patch:
do-install:
@ ${MKDIR} ${DIPDLDIR}
- @ cd ${WRKSRC} && find *.html *.css images \
+ @ cd ${WRKSRC} && ${FIND} *.html *.css images \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
- @ cd ${WRKDIR}/py && find * \
+ @ cd ${WRKDIR}/py && ${FIND} * \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.for format in html html-flat pdf text word help xml common examples
@ ${INSTALL_DATA} \
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index 89e8648f25ba..675baab58bc5 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -35,7 +35,8 @@ test:
@(cd ${WRKSRC}; ${MAKE} test)
post-patch:
- @${FIND} ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l strnstr | \
+ @${FIND} ${WRKSRC} -type f -name "*.[ch]" | \
+ ${XARGS} ${GREP} -l strnstr | \
${XARGS} ${PERL} -pi -e 's|strnstr|ePerl_strnstr|g'
do-install:
diff --git a/lang/fesi/Makefile b/lang/fesi/Makefile
index cd146ad04f7f..76eb52532412 100644
--- a/lang/fesi/Makefile
+++ b/lang/fesi/Makefile
@@ -24,7 +24,7 @@ JDK_VERSION= 1.1.8
WRKSRC= ${WRKDIR}/${PORTNAME}
post-extract:
- @(cd ${WRKSRC} && find * -type d -exec ${CHMOD} 755 {} \;)
+ @(cd ${WRKSRC} && ${FIND} * -type d -exec ${CHMOD} 755 {} \;)
do-install:
@${MKDIR} ${PREFIX}/share/java/classes ${PREFIX}/share/java/fesi
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index c7fb741a3b8e..5307be6e9df8 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -85,9 +85,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
@${CHMOD} a-x ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/Errormatch.txt
# Use the Linux ABI for the binaries
.for i in iccbin iccfilt icid icpcbin icpi mcpcom profmerge proforder xiar xild
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index c7fb741a3b8e..5307be6e9df8 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -85,9 +85,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
@${CHMOD} a-x ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/Errormatch.txt
# Use the Linux ABI for the binaries
.for i in iccbin iccfilt icid icpcbin icpi mcpcom profmerge proforder xiar xild
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index d78eabe30757..22ac742f92ea 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -77,9 +77,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
# Use the Linux ABI for the binaries
.for i in ifcbin fpp icid f90com profmerge proforder xiar xild
@brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index d78eabe30757..22ac742f92ea 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -77,9 +77,9 @@ pre-patch:
# Remove unneeded/unsafe access rights
.for i in docs ia32/include ia32/lib
@${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
- xargs -0 ${CHMOD} a-x,g-w
+ ${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
- @${FIND} ${WRKSRC}/opt -type d -print0 | xargs -0 ${CHMOD} go-w
+ @${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
# Use the Linux ABI for the binaries
.for i in ifcbin fpp icid f90com profmerge proforder xiar xild
@brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
diff --git a/lang/kawa/Makefile b/lang/kawa/Makefile
index 7d8f16a523f9..bc3c22ab0659 100644
--- a/lang/kawa/Makefile
+++ b/lang/kawa/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ARGS= --enable-kawa-frontend
GNU_CONFIGURE= yes
pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi \
-e 's|sed |gsed |g;' \
-e 's|JAR = jar|JAR = ${JAR}|g;'
perl -pi -e 's|{JAVAC-javac}|{JAVAC-${JAVAC}}|g;' \
diff --git a/lang/sml-nj/Makefile b/lang/sml-nj/Makefile
index a5820da3364a..e8453ee486e7 100644
--- a/lang/sml-nj/Makefile
+++ b/lang/sml-nj/Makefile
@@ -65,7 +65,7 @@ do-install:
${SED} -e "s,^BIN_DIR=.*\$$,BIN_DIR=${SML_BINDIR}," \
< ${WRKDIR}/bin/.run-sml > ${SML_BINDIR}/.run-sml
${CHMOD} 755 ${SML_BINDIR}/.run-sml
- cd ${WRKDIR} && tar -cf - `find . -name x86-unix` | \
+ cd ${WRKDIR} && tar -cf - `${FIND} . -name x86-unix` | \
tar -C ${SML_BASE} -xf -
cd ${WRKDIR} && tar -cf - `${SCRIPTDIR}/get-cm ${WRKDIR}` | \
tar -C ${SML_BASE} -xf -
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 9c831939aa92..80069e6cc446 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -154,7 +154,7 @@ post-install:
tb2sylpheed update-po uudec ${DATADIR}
.if !defined(WITHOUT_THEMES)
@${MKDIR} ${DATADIR}/themes
- @cd ${WRKDIR}/${THEMEFILE:C/.tar.gz//} && for d in `find .`; do \
+ @cd ${WRKDIR}/${THEMEFILE:C/.tar.gz//} && for d in `${FIND} .`; do \
if ${TEST} -d $${d}; then ${MKDIR} ${DATADIR}/themes/$${d}; else \
${INSTALL_DATA} $${d} ${DATADIR}/themes/$${d}; fi; \
done
diff --git a/mail/sendmail-old/Makefile b/mail/sendmail-old/Makefile
index 60b4b75851b3..79d73dec3cc0 100644
--- a/mail/sendmail-old/Makefile
+++ b/mail/sendmail-old/Makefile
@@ -111,9 +111,9 @@ pre-install:
@${CAT} ${FILESDIR}/pkg-milter >>${PLIST}
.endif
.if !defined(NOPORTDOCS)
- @cd ${WRKSRC} && find cf -type f | \
+ @cd ${WRKSRC} && ${FIND} cf -type f | \
${AWK} '{print "share/sendmail/" $$1}' >>${PLIST}
- @cd ${WRKSRC} && find -d cf -type d | \
+ @cd ${WRKSRC} && ${FIND} -d cf -type d | \
${AWK} '{print "@dirrm share/sendmail/" $$1}' >>${PLIST}
@${ECHO_CMD} "@dirrm share/sendmail" >>${PLIST}
.for i in ${DOCS}
diff --git a/mail/sendmail811/Makefile b/mail/sendmail811/Makefile
index 60b4b75851b3..79d73dec3cc0 100644
--- a/mail/sendmail811/Makefile
+++ b/mail/sendmail811/Makefile
@@ -111,9 +111,9 @@ pre-install:
@${CAT} ${FILESDIR}/pkg-milter >>${PLIST}
.endif
.if !defined(NOPORTDOCS)
- @cd ${WRKSRC} && find cf -type f | \
+ @cd ${WRKSRC} && ${FIND} cf -type f | \
${AWK} '{print "share/sendmail/" $$1}' >>${PLIST}
- @cd ${WRKSRC} && find -d cf -type d | \
+ @cd ${WRKSRC} && ${FIND} -d cf -type d | \
${AWK} '{print "@dirrm share/sendmail/" $$1}' >>${PLIST}
@${ECHO_CMD} "@dirrm share/sendmail" >>${PLIST}
.for i in ${DOCS}
diff --git a/mail/spambnc/Makefile b/mail/spambnc/Makefile
index 0791b32f791b..614f5960cacc 100644
--- a/mail/spambnc/Makefile
+++ b/mail/spambnc/Makefile
@@ -25,7 +25,7 @@ PLIST= ${WRKDIR}/.pkg-plist
pre-install:
@${RM} -f ${PLIST}
- @(cd ${WRKDIR} && find -s . -type f | ${GREP} -v "^\.\/\." | \
+ @(cd ${WRKDIR} && ${FIND} -s . -type f | ${GREP} -v "^\.\/\." | \
${SED} -e 's,.,share/spambnc,1' >> ${PLIST})
@echo "%%PORTDOCS%%share/doc/spambnc/documentation.html" >> ${PLIST}
@echo "@dirrm share/spambnc" >> ${PLIST}
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 9c831939aa92..80069e6cc446 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -154,7 +154,7 @@ post-install:
tb2sylpheed update-po uudec ${DATADIR}
.if !defined(WITHOUT_THEMES)
@${MKDIR} ${DATADIR}/themes
- @cd ${WRKDIR}/${THEMEFILE:C/.tar.gz//} && for d in `find .`; do \
+ @cd ${WRKDIR}/${THEMEFILE:C/.tar.gz//} && for d in `${FIND} .`; do \
if ${TEST} -d $${d}; then ${MKDIR} ${DATADIR}/themes/$${d}; else \
${INSTALL_DATA} $${d} ${DATADIR}/themes/$${d}; fi; \
done
diff --git a/math/djbfft/Makefile b/math/djbfft/Makefile
index 5d133a101f4b..558e70faf565 100644
--- a/math/djbfft/Makefile
+++ b/math/djbfft/Makefile
@@ -19,7 +19,7 @@ ALL_TARGET=
INSTALL_TARGET=setup check
post-patch:
- @find ${WRKSRC} -type f -exec \
+ @${FIND} ${WRKSRC} -type f -exec \
${PERL} -pi -e 's!(djbfft.a)!lib\1!' {} \;
@${PERL} -pi -e 's|("include)|\1/${PORTNAME}|' ${WRKSRC}/hier.c
diff --git a/math/gnuplot+/Makefile b/math/gnuplot+/Makefile
index 9215858fdbee..92afb869a2a9 100644
--- a/math/gnuplot+/Makefile
+++ b/math/gnuplot+/Makefile
@@ -62,7 +62,7 @@ post-patch:
cd ${WRKSRC}; ${TOUCH} configure
pre-build:
- find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
+ ${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
post-build:
cd ${WRKSRC}/docs; ${GMAKE} info
diff --git a/math/jacal/Makefile b/math/jacal/Makefile
index 0eba59de917a..41ab518071a3 100644
--- a/math/jacal/Makefile
+++ b/math/jacal/Makefile
@@ -27,6 +27,6 @@ MAN1= jacal.1
do-configure:
cd ${WRKSRC}; \
- find . -type f -exec perl -spi -e 's|%%PREFIX%%|${PREFIX}|' {} ';'
+ ${FIND} . -type f -exec perl -spi -e 's|%%PREFIX%%|${PREFIX}|' {} ';'
.include <bsd.port.mk>
diff --git a/math/javanns/Makefile b/math/javanns/Makefile
index 4da6e973ea1f..fabb67158780 100644
--- a/math/javanns/Makefile
+++ b/math/javanns/Makefile
@@ -28,8 +28,8 @@ USE_REINPLACE= yes
post-extract:
# Permissions in the tar file are whacked
- find ${WRKSRC} -type d -print | xargs ${CHMOD} 755
- find ${WRKSRC} -type f -print | xargs ${CHMOD} 644
+ ${FIND} ${WRKSRC} -type d -print | ${XARGS} ${CHMOD} 755
+ ${FIND} ${WRKSRC} -type f -print | ${XARGS} ${CHMOD} 644
do-configure:
${INSTALL_DATA} ${FILESDIR}/javanns.sh ${WRKSRC}
diff --git a/math/mupad/Makefile b/math/mupad/Makefile
index 1435de9e0057..e059a893dce8 100644
--- a/math/mupad/Makefile
+++ b/math/mupad/Makefile
@@ -40,7 +40,7 @@ do-install:
@${MKDIR} ${PREFIX}/mupad/freebsd
@${MKDIR} ${PREFIX}/mupad/share
@${MKDIR} ${PREFIX}/mupad/packages
- find ${WRKSRC} -name "*.orig" | xargs ${RM}
+ ${FIND} ${WRKSRC} -name "*.orig" | ${XARGS} ${RM}
${RM} -rf ${WRKSRC}/packages/scilab/linux
${RM} -rf ${WRKSRC}/packages/scilab/solaris
${TAR} cf - -C ${WRKSRC}/linux . | ${TAR} xf - -C ${PREFIX}/mupad/freebsd
diff --git a/math/p5-Math-LinearCombination/Makefile b/math/p5-Math-LinearCombination/Makefile
index 7f3d7c7185d2..7399fb5faf0e 100644
--- a/math/p5-Math-LinearCombination/Makefile
+++ b/math/p5-Math-LinearCombination/Makefile
@@ -24,7 +24,7 @@ PERL_CONFIGURE= yes
MAN3= Math::LinearCombination.3
pre-patch:
- @${FIND} ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "*.pm" | ${XARGS} ${PERL} -pi -e \
's!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+!my !;'
.include <bsd.port.mk>
diff --git a/math/p5-Math-SimpleVariable/Makefile b/math/p5-Math-SimpleVariable/Makefile
index 8562aea22629..b5fd3bcf2e71 100644
--- a/math/p5-Math-SimpleVariable/Makefile
+++ b/math/p5-Math-SimpleVariable/Makefile
@@ -23,7 +23,7 @@ PERL_CONFIGURE= yes
MAN3= Math::SimpleVariable.3
pre-patch:
- @${FIND} ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "*.pm" | ${XARGS} ${PERL} -pi -e \
'$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
.include <bsd.port.mk>
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
index 533f2b108bd0..b19ae6fa6f29 100644
--- a/math/py-gato/Makefile
+++ b/math/py-gato/Makefile
@@ -33,7 +33,7 @@ do-build:
do-install:
@ ${MKDIR} ${GATO_DIR}
- @ cd ${WRKSRC} && find *.py *.pyc *.pyo \
+ @ cd ${WRKSRC} && ${FIND} *.py *.pyc *.pyo \
-name Gato.py\* -o -name Gred.py\* -o -print \
| ${CPIO} ${BINOWN}:${BINGRP} ${GATO_DIR}
.for script in Gato Gred
diff --git a/math/rcalc/Makefile b/math/rcalc/Makefile
index a5ccbdb17617..c2aadc5cbc66 100644
--- a/math/rcalc/Makefile
+++ b/math/rcalc/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g'
.include <bsd.port.mk>
diff --git a/math/scigraphica/Makefile b/math/scigraphica/Makefile
index 503ea4a8a390..b0d756f2a2f9 100644
--- a/math/scigraphica/Makefile
+++ b/math/scigraphica/Makefile
@@ -33,7 +33,7 @@ MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/misc/metatheme2/Makefile b/misc/metatheme2/Makefile
index b5fcb9006d97..9f497c8fa1e7 100644
--- a/misc/metatheme2/Makefile
+++ b/misc/metatheme2/Makefile
@@ -32,12 +32,12 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
pre-patch:
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]datadir[)]/gnome/|(datadir)/|g ; \
s|[(]datadir[)]/locale|(prefix)/share/locale|g'
post-configure:
- @find ${WRKSRC}/plugins -name "*.c" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC}/plugins -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
's|%%X11BASE%%|${X11BASE}|g ; s|%%LOCALBASE%%|${LOCALBASE}|g'
.include <bsd.port.mk>
diff --git a/multimedia/xmms/Makefile b/multimedia/xmms/Makefile
index bd5c3930880e..808e9df7be58 100644
--- a/multimedia/xmms/Makefile
+++ b/multimedia/xmms/Makefile
@@ -111,7 +111,7 @@ pre-extract:
.endif
post-patch:
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|\(datadir\)/aclocal|(prefix)/share/aclocal|g'
@${REINPLACE_CMD} -e 's|{datadir}/locale|{prefix}/share/locale|g' \
${WRKSRC}/configure
diff --git a/multimedia/xmps/Makefile b/multimedia/xmps/Makefile
index 746f7771cd0b..c5d41c31c6a2 100644
--- a/multimedia/xmps/Makefile
+++ b/multimedia/xmps/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
post-configure:
diff --git a/net/clusterit/Makefile b/net/clusterit/Makefile
index 250aa272b211..51c8b3367f27 100644
--- a/net/clusterit/Makefile
+++ b/net/clusterit/Makefile
@@ -27,7 +27,8 @@ USE_XLIB= yes
.endif
post-patch:
- @find ${WRKSRC} -name Makefile | xargs ${PERL} -pi -e 's#/usr/X11R6#${X11BASE}#g'
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
+ ${PERL} -pi -e 's#/usr/X11R6#${X11BASE}#g'
.for file in command.c rvt.c screen.c
@${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/rvt/${file}
.endfor
diff --git a/net/coda5_doc/Makefile b/net/coda5_doc/Makefile
index 3c13a694933e..fba24324ea32 100644
--- a/net/coda5_doc/Makefile
+++ b/net/coda5_doc/Makefile
@@ -100,7 +100,7 @@ do-build:
@${ECHO} "or two."
do-install:
- find ${WRKSRC} -type d -exec chmod 755 {} \;
+ ${FIND} ${WRKSRC} -type d -exec chmod 755 {} \;
cd ${WRKSRC}; tar cf - man | (cd ${PREFIX}; tar xvf -)
.if !defined(NOPORTDOCS)
cd ${WRKSRC}; tar cf - doc | (cd ${PREFIX}/share; tar xvf -)
diff --git a/net/gopher/Makefile b/net/gopher/Makefile
index fb2d79cf5113..f5ef219a6d15 100644
--- a/net/gopher/Makefile
+++ b/net/gopher/Makefile
@@ -24,7 +24,7 @@ MAN1= gopher.1 gophfilt.1
MAN5= gopherrc.5
pre-patch:
- @${FIND} ${WRKSRC} -name '*.[ch]' | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's,<malloc.h>,<stdlib.h>,'
.include <bsd.port.mk>
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index 90febb39c523..7145e0038ead 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -32,8 +32,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ntp
${TAR} -C ${WRKSRC}/html -cf - . | \
${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
- find ${PREFIX}/share/doc/ntp | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/doc/ntp -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/doc/ntp | \
+ ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/doc/ntp -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
diff --git a/net/ntp-stable/Makefile b/net/ntp-stable/Makefile
index 8e8f8c176bb5..907514ea34d0 100644
--- a/net/ntp-stable/Makefile
+++ b/net/ntp-stable/Makefile
@@ -31,8 +31,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ntp
${TAR} -C ${WRKSRC}/html -cf - . | \
${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
- find ${PREFIX}/share/doc/ntp | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/doc/ntp -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/doc/ntp | \
+ ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/doc/ntp -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 8e8f8c176bb5..907514ea34d0 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -31,8 +31,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ntp
${TAR} -C ${WRKSRC}/html -cf - . | \
${TAR} -C ${PREFIX}/share/doc/ntp --unlink -xf -
- find ${PREFIX}/share/doc/ntp | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/doc/ntp -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/doc/ntp | \
+ ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/doc/ntp -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.mk>
diff --git a/net/p5-Net-Radius/Makefile b/net/p5-Net-Radius/Makefile
index 65d4405c655d..731c243e52d5 100644
--- a/net/p5-Net-Radius/Makefile
+++ b/net/p5-Net-Radius/Makefile
@@ -22,6 +22,6 @@ PERL_CONFIGURE= yes
MAN3= Net::Radius::Dictionary.3 Net::Radius::Packet.3
post-extract:
- find ${WRKDIR} -type f | xargs perl -pi -e "s:\r::g"
+ ${FIND} ${WRKDIR} -type f | ${XARGS} perl -pi -e "s:\r::g"
.include <bsd.port.mk>
diff --git a/net/p5-Net-XWhois/Makefile b/net/p5-Net-XWhois/Makefile
index 23870ceca27e..c202ea7b8a88 100644
--- a/net/p5-Net-XWhois/Makefile
+++ b/net/p5-Net-XWhois/Makefile
@@ -21,6 +21,6 @@ PERL_CONFIGURE= YES
MAN3= Net::XWhois.3
post-patch:
- @find ${WRKSRC} -type f -name "*.orig" -exec rm -f "{}" ";"
+ @${FIND} ${WRKSRC} -type f -name "*.orig" -exec rm -f "{}" ";"
.include <bsd.port.mk>
diff --git a/net/ppxp/Makefile b/net/ppxp/Makefile
index 796e196a2e68..5ad48499627c 100644
--- a/net/ppxp/Makefile
+++ b/net/ppxp/Makefile
@@ -66,7 +66,7 @@ DOC_ja_JP= QuickStart.txt QuickUsage.txt guide-1.html guide-2.html \
guide-11.html guide.html Answers.txt Report.txt
post-patch:
- @find ${WRKSRC} -name '*.orig' -exec ${RM} -f '{}' ';'
+ @${FIND} ${WRKSRC} -name '*.orig' -exec ${RM} -f '{}' ';'
@${PERL} -pi -e 's/^CFLAGS/#$$&/' ${WRKSRC}/configure
post-install:
diff --git a/net/xipdump/Makefile b/net/xipdump/Makefile
index ec38aee2ddb8..583100a4dcc9 100644
--- a/net/xipdump/Makefile
+++ b/net/xipdump/Makefile
@@ -30,7 +30,7 @@ MAN8= xipdump.8
post-build:
@${CP} ${PKGDIR}/pkg-plist ${PLIST}
- @(cd ${WRKSRC}/data; find pkc pkt ! -type d | \
+ @(cd ${WRKSRC}/data; ${FIND} pkc pkt ! -type d | \
${SED} -e 's|^|share/xipdump/|' >> ${PLIST})
@${ECHO_CMD} "@dirrm share/xipdump/pkt" >> ${PLIST}
@${ECHO_CMD} "@dirrm share/xipdump/pkc" >> ${PLIST}