aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-06-19 17:21:28 +0800
committerKris Kennaway <kris@FreeBSD.org>2004-06-19 17:21:28 +0800
commitef790344e635a311e4b948cd8dba9e189d058b96 (patch)
tree5883f4448e759afee0407a5f23cbaec73be2e8e0
parent99db1b22d996ad1f1a49c9b58fd08bb037508fe5 (diff)
downloadfreebsd-ports-ef790344e635a311e4b948cd8dba9e189d058b96.tar.gz
freebsd-ports-ef790344e635a311e4b948cd8dba9e189d058b96.tar.zst
freebsd-ports-ef790344e635a311e4b948cd8dba9e189d058b96.zip
BROKEN on amd64: Does not compile
Notes
Notes: svn path=/head/; revision=111799
-rw-r--r--lang/libjit/Makefile8
-rw-r--r--mail/libspf/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/lang/libjit/Makefile b/lang/libjit/Makefile
index 625245da5048..e42c2f7ad25c 100644
--- a/lang/libjit/Makefile
+++ b/lang/libjit/Makefile
@@ -19,4 +19,10 @@ INFO= libjit
MAN3= libjit.3
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/libspf/Makefile b/mail/libspf/Makefile
index 2f6ae4dee298..b1ceb4bf8714 100644
--- a/mail/libspf/Makefile
+++ b/mail/libspf/Makefile
@@ -55,6 +55,12 @@ SPF_DEBUG_FILE= /dev/null
SPF_CFLAGS+= -DDEBUG_LOG_FILE=\\\"${SPF_DEBUG_FILE}\\\" \
-DOUTPUT_LOG_FILE=\\\"${SPF_LOG_FILE}\\\"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64"
+.endif
+
# This is all a bit messy, but given the inconvenient original Makefile,
# this seems to be the best way to make this port work in this version.
# The author of libspf is working on autotools support, so this ugliness
@@ -100,4 +106,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tools/spfquery-${PORTNAME} ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>