aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2010-09-16 02:35:24 +0800
committerade <ade@FreeBSD.org>2010-09-16 02:35:24 +0800
commit3ad75a4581c2f69fb2331ab72fee36ff8af166ba (patch)
treeb5ab9adb45e9a850892479ebc329ab2118d673c8 /Mk/bsd.port.mk
parentf72275e68db56a5d187d3a748951a6347a5ace60 (diff)
downloadfreebsd-ports-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.tar.gz
freebsd-ports-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.tar.zst
freebsd-ports-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.zip
Autotools update. Read ports/UPDATING 20100915 for details.
Approved by: portmgr (for Mk/bsd.port.mk part) Tested by: Multiple -exp runs
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ffd0233a5442..c51b18177be2 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -318,7 +318,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Default: gmake
##
# USE_ICONV - If set, this port uses libiconv.
-# USE_GETTEXT - If set, this port uses GNU gettext (libintl).
+# USE_GETTEXT - The port uses GNU gettext (libintl).
+# 'build' as a build-time dependency
+# 'yes' as a library dependency
+# 'run' as a run-time dependency
##
# USE_PERL5 - If set, this port uses perl5 in one or more of the extract,
# patch, build, install or run phases.
@@ -1892,10 +1895,14 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.endif
.if defined(USE_GETTEXT)
-. if ${USE_GETTEXT:L} == "yes"
+. if ${USE_GETTEXT:L} == "build"
+BUILD_DEPENDS+= xgettext:${PORTSDIR}/devel/gettext
+. elif ${USE_GETTEXT:L} == "run"
+RUN_DEPENDS+= xgettext:${PORTSDIR}/devel/gettext
+. elif ${USE_GETTEXT:L} == "yes"
LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext
. else
-LIB_DEPENDS+= intl.${USE_GETTEXT}:${PORTSDIR}/devel/gettext
+IGNORE= USE_GETTEXT can be only one of build, run, or yes
. endif
.endif