aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-10-13 07:32:32 +0800
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-10-13 07:32:32 +0800
commit97141f42648653a6949f820452f93f61e8909793 (patch)
treec0d734f47874b88ee5544e9ef5b13fb88eb7dd6b /Mk/bsd.port.mk
parentff5e779d28895190dc623b7033fdf54210dd53b9 (diff)
downloadfreebsd-ports-97141f42648653a6949f820452f93f61e8909793.tar.gz
freebsd-ports-97141f42648653a6949f820452f93f61e8909793.tar.zst
freebsd-ports-97141f42648653a6949f820452f93f61e8909793.zip
Re-work the way pre-install was being depended. I couldn't make the
install cookie work any other way (perhaps I'm just being stupid). In any case, INSTALL_COOKIE now works as advertised, and prevents duplicate installations. pre-install users will have to keep their own cookies if they wish to avoid duplicate installations, or tell me how to make the rules run properly.
Notes
Notes: svn path=/head/; revision=223
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index baf026a67f77..9e39894a8c53 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.51 1994/10/12 03:12:19 ache Exp $
+# $Id: bsd.port.mk,v 1.52 1994/10/12 03:25:59 ache Exp $
#
# Please view me with 4 column tabs!
@@ -192,9 +192,9 @@ pre-install:
.endif
.if !target(install)
-install: ${INSTALL_COOKIE}
+install: pre-install ${INSTALL_COOKIE}
-${INSTALL_COOKIE}: pre-install
+${INSTALL_COOKIE}:
@echo "===> Installing for ${DISTNAME}"
.if defined(USE_GMAKE)
@(cd ${WRKSRC}; ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} install)